Imatest 功能接口

Imatest 的标准界面是一个功能强大且用途广泛的工具,可用于与其众多模块进行交互,但对于实验室技术人员或对Imatest 的众多功能培训有限的人员来说,它可能比较复杂且令人生畏。

此外,总有可能出现一个或多个设置与预期值不同的情况。Imatest 设置存储在imatest.ini文件中,并在每次模块运行时更新。这些设置可以保存到指定名称的文件中,也可以从指定名称的文件加载或合并。这赋予用户对设置的强大控制权,但仍然难以获得适用于生产或实验室环境的正确设置——这一点至关重要,因为错误的设置可能会对测试结果产生不可预测的影响。

这些问题已通过Imatest 功能界面(在Imatest 3.9中引入)得到解决——这是一个简单但高度可定制的标准Imatest界面的替代方案,可确保始终使用正确的设置。

功能界面对于任何需要运行程序的人来说都特别重要。
大量采用一致设置进行的测试。

Imatest 功能接口

Imatest 功能接口是一个独立的接口,用于运行Imatest模块。

  • 简洁明了:只显示必要的功能。
  • 一致性:您可以指定一个合并文件,以确保设置正确且一致。
  • 操作人员无需担心设置细节,即使接受过有限培训的人员也能轻松使用。

如有需要,您可以随时返回到标准的Imatest界面(主窗口)。

它可以打开

  • (在 Windows 系统中)依次点击“所有程序” 、 “Imatest” 、“(如果需要,请选择版本)”、 “Imatest 功能界面”
  • 从“实用工具”菜单中,单击“功能界面” 。

如果您正在使用快捷方式,请将目标(显示在右侧)从用于标准Imatest Master运行的run_imatest.bat更改为run_functional.bat 。

Imatest Functional Interface with three buttons shown
Imatest 功能界面显示三个已安装的按钮(最多 12 个按钮);
按钮宽度为最大宽度的 80%;选择大字体以确保可见性
当您按下功能界面中的按钮时,
  • 包含重要设置的ini文件的内容会被合并到imatest.ini文件中,并且
  • 模块已运行。如果模块已按照以下说明正确设置,则始终会使用正确的设置。

按钮文本、合并文件和模块均在编辑器中指定,该编辑器可通过点击左下角的“编辑”按钮打开。(从 Windows 系统打开功能界面时,此菜单不会显示,但可通过点击“设置” > “显示编辑菜单”来显示。)

Imatest 功能接口
显示全部 12 个按钮;全宽

功能界面编辑器

点击功能界面左下角的“编辑”按钮或其右侧的弹出菜单即可打开编辑器。(如果未显示此菜单,请点击“设置” ,然后点击“显示编辑菜单” 。)

功能编辑器窗口(用于功能界面的按钮 1)

功能编辑器设置:

全局设置:这些设置会影响所有按钮。

  • 隐藏无描述文本的按钮。选中此项后,仅显示描述字段中包含文本的按钮。未选中此项后,显示全部十二个按钮。
  • 按钮宽度(滑块):设置按钮的(相对)宽度:1 为最大宽度。如果描述文字较短,可以改善按钮的视觉效果。

模块:选择要运行的模块:SFR、SFRplus、Light Falloff 等。长长的列表中包括 Rescharts 和 Multicharts 模块。

描述:这是显示在按钮(上例中的按钮 1)上的文字。它应该清晰明了,具有描述性。

工具提示文本:这是鼠标悬停在按钮上方时显示在框中的文本。如有需要,请在此处输入更多详细信息和说明。

要合并到 imatest.ini 中的命名 ini 文件:此 ini 文件包含要使用的已保存设置。通常不应使用 imatest.ini 的完整副本。该 ini 文件应包含以下内容

  • 要运行的模块部分(上例中的 [q13]——这是 Stepchart 的旧名称,为了向后兼容而保留),
  • [imatest] (一些通用设置),
  • [dcraw] (使用 dcraw 对图像进行去马赛克处理的设置),以及
  • [rdraw] (如果需要:通用读取原始数据的设置)。

最好从 ini 合并文件中删除文件名。

INI 文件编辑器打开合并文件,如下所述:它是一个非常强大的工具,用于为功能接口以及 Imatest IT(工业测试版本)准备合并文件。

默认编辑器会在标准编辑器(Windows 系统中为记事本)中打开合并文件。

您可以使用顶部的“编辑功能界面”菜单来编辑其他按钮。

INI 文件概述

Imatest设置保存在 INI 文件中: imatest.ini、 rescharts.ini和multicharts.ini 。当在输入对话框、设置中更改设置或编辑 INI 文件时(见下文),这些文件都会更新。设置可以编辑并保存到指定名称的文件中,用作功能接口合并文件或IT (工业测试)控制文件。

您无需知道确切位置,因为 INI 文件编辑器会从正确的位置打开 imatest.ini(或 rescharts.ini 或 multicharts.ini),该位置由系统环境变量 $APPDATA$ 确定(在 Windows Vista/7(英文版)中为 C:\Users\用户名\AppData\Roaming)。imatest.ini 在 Windows Vista/7 英文版中的完整路径为 C:\Users \用户名\AppData\Roaming\Imatestimatest.ini。在其他操作系统和语言中,该名称可能有所不同。

INI 文件是文本文件,其结构是:节标题用方括号 ([ ... ]) 括起来,行格式为:
名称 = 值,
例如,nwid_save = 2601。值可以是数字、字符串或空值。其含义通常很明显。必须包含等号 (=)。
[部分]
name1 = value1
name2 = value2
...
[下一节]
例如: dispwelcome = 1 表示在 Imatest 启动时显示欢迎屏幕。edfile是图像编辑器的位置,用于在交互式模块(例如 Rescharts)中显示已保存的屏幕截图。 [imatest]
dispwelcome = 1
evalvl = 1
exiftool = 2
展开 = 最小
字体大小 = 10
readexif = 1
shrink_largef = 1
获取 = 0
edfile = C:\Program Files (x86)\IrfanView\i_view32.exe
[sfr]
filecomb = 0
文件夹 = C:\ImatestData\SFR
保存目录 = C:ImatestDataSFRResults

对于功能接口合并文件或 IT 控制文件,可以按照下列步骤之一删除非必要部分和数据。

准备合并文件

INI 文件编辑器与您在“设置”中点击“编辑/重置模块”或在Rescharts或Multicharts中点击的编辑器相同。它经过增强,可以更方便地为功能接口和 IT(工业测试)版本创建 INI 文件。您可以按照以下步骤快速设置合并文件。

INI File Editor
INI 文件编辑器
  • 在 Imatest(或Rescharts或Multicharts窗口)中,运行要添加到功能接口的模块,确保已设置要保存的设置(正确的 dcraw 去马赛克参数、单位、显示等)。
  • 点击设置,编辑/重置模块,打开 INI 编辑器。

方法一:使用外部编辑器(记事本)。

  • 点击左下角“功能界面/IT设置”部分的“打开文本编辑器” 。这将在记事本中打开一个空白编辑器窗口。
  • 选择与您刚刚运行的模块对应的部分(在本例中为 [a13]),然后单击“复制部分内容” 。
  • 将剪贴板内容粘贴(Ctrl+V)到记事本窗口中。
  • 对 [imatest]、[dcraw]、[rdraw] 以及任何其他相关部分重复此步骤。例如,如果您计划显示主观质量因子,则可能需要将 [sqf] 添加到 [sfr] 或 [sfrplus]。
  • 编辑合并文件的内容。浏览记事本中的内容,删除可能干扰运行的路径名。如果不这样做,您将始终需要从保存的文件夹导航。(保留某些路径名,例如 Colorcheck 或 Multicharts 的颜色参考文件)。此外,最好删除图像大小和裁剪设置;这些设置往往会覆盖最近运行的设置,而这些设置通常应该保存。常见的路径名包括 nht_save、nwid_save 和 roi_mult 或 roi(取决于模块)。
  • 保存记事本内容,注意保存位置和路径名称。您以后随时可以打开该文件进行编辑。

方法二:使用 INI 文件编辑器。

  • 点击“另存为...”将文件保存到目标合并文件位置:请先执行此操作,以免意外覆盖原始文件。
  • 选择要从合并文件中移除的模块段。(可能有很多模块段。)通常,您需要保留目标模块及其相关模块的模块段(例如,保留 [sqf] 模块段以对应 [sfr] 或 [sfrplus] 模块)。大多数情况下,您还需要保留其他一些模块段,特别是 [imatest]、[dcraw] 和 [rdraw]。
  • 编辑合并文件的内容。检查剩余部分,删除可能干扰运行的路径名。否则,您将始终需要从保存的文件夹导航。(保留某些路径名,例如 Colorcheck 或 Multicharts 的颜色参考文件)。此外,最好删除图像大小和裁剪设置;这些设置往往会覆盖最近运行的设置,而这些设置通常应该保存。常见的路径名包括 nht_save、nwid_save 和 roi_mult 或 roi(取决于模块)。
  • 点击“保存” 。您以后随时可以打开文件进行编辑。

完成按钮设置,

  • 点击“实用工具”、“功能界面”切换到功能界面。
  • 在功能界面窗口的左下角,单击要添加或编辑的按钮编号。
  • 根据需要编辑设置按钮。您需要将 ini 合并文件的位置添加到“要合并到 imatest.ini 的命名 ini 文件”框中。然后单击“确定” 。

按钮应该已经准备就绪了。:-) 当然,你肯定想测试一下。

INI 文件参考页面对于功能接口和工业测试 (IT) 版本都应该很有帮助。