Imatest功能介面

Imatest 的標準介面是一個功能強大且用途廣泛的工具,可用於與其眾多模組進行交互,但它可能很複雜且令人生畏,尤其是對於實驗室技術人員或在Imatest 的眾多功能方面培訓有限的人員而言。

此外,總有可能出現一個或多個設定與預期值不同的情況。 Imatest 設定儲存在imatest.ini檔案中,並在每次模組執行時更新。這些設定可以儲存到指定名稱的檔案中,也可以從指定名稱的檔案載入或合併。這賦予使用者對設定的強大控制權,但仍然難以獲得適用於生產或實驗室環境的正確設定——這一點至關重要,因為錯誤的設定可能會對測試結果產生不可預測的影響。

這些問題已透過Imatest 功能介面(在Imatest 3.9中引入)得到解決——這是一個簡單但高度可自訂的標準Imatest介面的替代方案,可確保始終使用正確的設定。

功能介面對於任何需要運行程式的人來說都特別重要。
大量採用一致設定進行的測試。

Imatest 功能介面

Imatest 功能介面是一個獨立的接口,用於運行Imatest模組。

  • 簡潔明了:只顯示必要的功能。
  • 一致性:您可以指定合併文件,以確保設定正確且一致。
  • 操作人員無需擔心設定細節,即使接受過有限訓練的人員也能輕鬆使用。

如有需要,您可以隨時返回標準的Imatest介面(主視窗)。

它可以打開

  • (在 Windows 系統中)依序點選「所有程式」 、 「Imatest」 、「(如果需要,請選擇版本)」、 「Imatest 功能介面」。
  • 從「實用工具」功能表中,按一下「功能介面」 。

如果您正在使用快捷方式,請將目標(顯示在右側)從用於標準Imatest Master執行的run_imatest.bat變更為run_functional.bat 。

Imatest Functional Interface with three buttons shown
Imatest 功能介面顯示三個已安裝的按鈕(最多 12 個按鈕);
按鈕寬度為最大寬度的 80%;選擇大字體以確保可見性
當您按下功能介面中的按鈕時,
  • 包含重要設定的ini檔案的內容會被合併到imatest.ini檔案中,並且
  • 模組已運作。如果模組已按照以下說明正確設置,則始終會使用正確的設定。

按鈕文字、合併檔案和模組均在編輯器中指定,該編輯器可透過點擊左下角的「編輯」按鈕開啟。 (從 Windows 系統開啟功能介面時,此選單不會顯示,但可點選「設定」 > 「顯示編輯選單」來顯示。)

Imatest 功能介面
顯示全部 12 個按鈕;全寬

功能介面編輯器

點擊功能介面左下角的「編輯」按鈕或其右側的彈出式選單即可開啟編輯器。 (如果未顯示此選單,請點選「設定」 ,然後點選「顯示編輯選單」 。)

功能編輯器視窗(用於功能介面的按鈕 1)

功能編輯器設定:

全域設定:這些設定會影響所有按鈕。

  • 隱藏無描述文字的按鈕。選取此項目後,僅顯示描述欄位中包含文字的按鈕。未選取此項目後,顯示全部十二個按鈕。
  • 按鈕寬度(滑桿):設定按鈕的(相對)寬度:1 為最大寬度。如果描述文字較短,可以改善按鈕的視覺效果。

模組:選擇要執行的模組:SFR、SFRplus、Light Falloff 等。長長的清單中包括 Rescharts 和 Multicharts 模組。

描述:這是顯示在按鈕(上例中的按鈕 1)上的文字。它應該清晰明了,具有描述性。

工具提示文字:這是滑鼠懸停在按鈕上方時顯示在框中的文字。如有需要,請在此輸入更多詳細資訊和說明。

若要合併至 imatest.ini 中的命名 ini 檔案:此 ini 檔案包含要使用的已儲存設定。通常不應使用 imatest.ini 的完整副本。該 ini 檔案應包含以下內容

  • 要運行的模組部分(上例中的 [q13]——這是 Stepchart 的舊名稱,為了向後相容而保留),
  • [imatest] (一些通用設定),
  • [dcraw] (使用 dcraw 對影像進行去馬賽克處理的設定),以及
  • [rdraw] (如果需要:通用讀取原始資料的設定)。

最好從 ini 合併檔案中刪除檔案名稱。

INI 文件編輯器開啟合併文件,如下所述:它是一個非常強大的工具,用於為功能介面以及 Imatest IT(工業測試版本)準備合併文件。

預設編輯器會在標準編輯器(Windows 系統中為記事本)中開啟合併檔案。

您可以使用頂部的“編輯功能介面”功能表來編輯其他按鈕。

INI 文件概述

Imatest設定保存在 INI 檔案中: imatest.ini、 rescharts.ini和multicharts.ini 。當在輸入對話方塊、設定中變更設定或編輯 INI 檔案時(請參閱下文),這些檔案都會更新。設定可以編輯並儲存到指定名稱的檔案中,用作功能介面合併檔案或IT (工業測試)控製文件。

您無需知道確切位置,因為 INI 檔案編輯器會從正確的位置開啟 imatest.ini(或 rescharts.ini 或 multicharts.ini),該位置由系統環境變數 $APPDATA$ 決定(在 Windows Vista/7(英文版)中為 C:\Users\使用者名稱\AppData\Roaming)。 imatest.ini 在 Windows Vista/7 英文版中的完整路徑為 C:\Users \使用者名稱\AppData\Roaming\Imatestimatest.ini。在其他作業系統和語言中,該名稱可能有所不同。

INI 文件是文字文件,其結構是:節標題用方括號 ([ ... ]) 括起來,行格式為:
名稱 = 值,
例如,nwid_save = 2601。值可以是數字、字串或空值。其意義通常很明顯。必須包含等號 (=)。
[部分]
name1 = value1
name2 = value2
…
[下一節]
例如: dispwelcome = 1 表示在 Imatest 啟動時顯示歡迎畫面。 edfile是影像編輯器的位置,用於在互動式模組(例如 Rescharts)中顯示已儲存的螢幕截圖。 [imatest]
dispwelcome = 1
evalvl = 1
exiftool = 2
展開 = 最小
字體大小 = 10
readexif = 1
shrink_largef = 1
獲取 = 0
edfile = C:\Program Files (x86)\IrfanView\i_view32.exe
[sfr]
filecomb = 0
資料夾 = C:\ImatestData\SFR
儲存目錄 = C:ImatestDataSFRResults

對於功能介面合併文件或 IT 控製文件,可以按照下列步驟之一刪除非必要部分和資料。

準備合併文件

INI 檔案編輯器與您在「設定」中點擊「編輯/重設模組」或在Rescharts或Multicharts中點擊的編輯器相同。它經過增強,可以更方便地為功能介面和 IT(工業測試)版本建立 INI 檔案。您可以按照以下步驟快速設定合併文件。

INI File Editor
INI 文件編輯器
  • 在 Imatest(或Rescharts或Multicharts視窗)中,執行要新增至功能介面的模組,確保已設定要儲存的設定(正確的 dcraw 去馬賽克參數、單位、顯示等)。
  • 點選設置,編輯/重置模組,開啟 INI 編輯器。

方法一:使用外部編輯器(記事本)。

  • 點選左下角「功能介面/IT設定」部分的「開啟文字編輯器」 。這將在記事本中開啟一個空白編輯器視窗。
  • 選擇與您剛剛執行的模組對應的部分(在本例中為 [a13]),然後按一下「複製部分內容」 。
  • 將剪貼簿內容貼上(Ctrl+V)到記事本視窗中。
  • 對 [imatest]、[dcraw]、[rdraw] 以及任何其他相關部分重複此步驟。例如,如果您打算顯示主觀質量因子,則可能需要將 [sqf] 新增至 [sfr] 或 [sfrplus]。
  • 編輯合併文件的內容。瀏覽記事本中的內容,刪除可能幹擾運行的路徑名稱。如果不這樣做,您將始終需要從已儲存的資料夾導航。 (保留某些路徑名,例如 Colorcheck 或 Multicharts 的顏色參考檔)。此外,最好刪除圖像大小和裁剪設置;這些設置往往會覆蓋最近運行的設置,而這些設置通常應該保存。常見的路徑名包括 nht_save、nwid_save 和 roi_mult 或 roi(取決於模組)。
  • 儲存記事本內容,注意儲存位置和路徑名稱。您以後隨時可以開啟該文件進行編輯。

方法二:使用 INI 檔案編輯器。

  • 點擊「另存為...」將檔案儲存到目標合併檔案位置:請先執行此操作,以免意外覆寫原始檔案。
  • 選擇要從合併檔案移除的模組段。 (可能有很多模組段。)通常,您需要保留目標模組及其相關模組的模組段(例如,保留 [sqf] 模組段以對應 [sfr] 或 [sfrplus] 模組)。大多數情況下,您還需要保留其他一些模組段,特別是 [imatest]、[dcraw] 和 [rdraw]。
  • 編輯合併文件的內容。檢查剩餘部分,刪除可能幹擾運行的路徑名稱。否則,您將始終需要從已儲存的資料夾導航。 (保留某些路徑名,例如 Colorcheck 或 Multicharts 的顏色參考檔)。此外,最好刪除圖像大小和裁剪設置;這些設置往往會覆蓋最近運行的設置,而這些設置通常應該保存。常見的路徑名包括 nht_save、nwid_save 和 roi_mult 或 roi(取決於模組)。
  • 點選「儲存」 。您以後隨時可以開啟文件進行編輯。

完成按鈕設置,

  • 點選「實用工具」、「功能介面」切換到功能介面。
  • 在功能介面視窗的左下角,按一下要新增或編輯的按鈕編號。
  • 根據需要編輯設定按鈕。您需要將 ini 合併檔案的位置新增至「要合併到 imatest.ini 的命名 ini 檔案」方塊中。然後按一下“確定” 。

按鈕應該已經準備就緒了。 :-) 當然,你一定想測試一下。

INI 檔案參考頁面對於功能介面和工業測試 (IT) 版本都應該很有幫助。