SVGテストチャート

Test Charts は 、高品質のインクジェット プリンターで印刷するためのテスト チャート ファイルを作成します。このページでは、スケーラブル ベクター グラフィックス (SVG)チャートに焦点を当てています。これらのチャートの多くは、 Imatest SFR 、 SFRplus 、 eSFR ISO 、 Checkerboard 、およびSFRregを使用してシャープネス (MTF) を測定するために使用されます。(ビットマップ チャートについては、別の場所で説明しています。) SVG チャートは、制限なくプリンターの最大品質 (解像度) で任意のサイズで印刷でき、一般的にビットマップ 画像よりもはるかに少ないストレージを必要とします。SFRplus およびeSFR ISO (ISO 12233:2014/2017 に基づく) を使用した自動テスト用に設計されたSVGチャートは、馴染みのあるものの廃止された ISO 12233:2000 チャートに比べて多くの利点があります。

これらのチャートのほとんどは、 Imatestストアから入手できます。高品質の写真用プリンター(オフィス用プリンターでは不十分です)と、高品質なカラーマネジメント印刷のスキルをお持ちでない限り、印刷はお勧めしません。ご自身で印刷されたチャートの結果は保証できません。

導入

ベクターグラフィック画像は、線や多角形などの基本要素で構成されており、任意のサイズに拡大縮小でき、ビットマップ画像のようなピクセル化の問題もありません。サイズに関係なく、プリンターの最高品質で印刷できます。ベクターグラフィックは、連続的なグレースケールトーンを必要としない線、曲線、領域で構成されるテストチャートを作成するのに最適です。

スケーラブルベクターグラフィックス(SVG)は、ワールドワイドウェブコンソーシアム( W3C )が認めるXMLファイル形式です。SVGファイルは、優れた無料のオープンソースプログラムであるInkscapeで読み込み、編集、印刷できます。また、Adobe Illustrator、Corel Drawなどのソフトウェアにインポートすることも可能です。

手術

テストチャートを実行するには、 Imatestを起動し、Imatestメインウィンドウ右側のユーティリティタブにある「テストチャート」をクリックします。すると、下図のようなダイアログボックスが表示されます。使用可能な設定項目は、パターンによって異なります。

ISO規格4:1コントラストの5x7 SFRplusチャート用テストチャート設定

SVGチャートパターンの選択肢は右側に表示されています(SVGスクエアとウェッジから始まります)。
SVGチャートパターンの選択肢は右側に表示されています(SVGスクエアとウェッジから始まります)。

パターン(グラフの種類)とオプションを選択してください。グラフのプレビューがすぐに表示されます。オプションをじっくりと確認することをお勧めします(すべてのオプションがこのページに表示されるわけではありません)。オプションを選択したら、テストグラフのフォルダ(ディレクトリ)とファイル名を入力し、 「テストグラフの作成」をクリックします。 「閉じる」をクリックするとキャンセルできます。グラフのプレビュー図(印刷用ではありません)が表示されます。拡大すると詳細を確認できます。以下に例を示します。

チャートの画像が表示されている図はプレビュー用です。チャートがどのようなものか大まかに表示され、必要に応じて拡大表示できます。この図から直接チャートを印刷しないでください。SVGチャートを印刷するには、印刷テスト用のSVG出力ファイル(上記の例ではchart_temp.svg)をSVGをサポートするエディタに読み込んでください。( Inkscapeを推奨しますが、Adobe Illustrator、Corel Drawなども使用できます。)これにより、印刷サイズの選択、注釈の追加、カラーマネジメントなどが可能になります。

グラフは、領域を選択するか、関心のあるポイントをクリックすることで拡大表示できます。ダブルクリックすると、元の画像に戻ります。プレビュー画像(または拡大表示画像)は、アンチエイリアシングが適用されていないため、ノイズやギザギザが生じる場合があります。

SVGチャートのプレビュー( 印刷用ではありません。出力ファイルをご利用ください! ) 5×7の歪んだチャート。コントラスト比は4:1で、いくつかのマス目にフォーカス補助機能が付いています。
SVGチャートのプレビュー(印刷用ではありません。出力ファイルをご利用ください! )
5×7の歪んだチャート。コントラスト比は4:1で、いくつかのマス目にフォーカス補助機能が付いています。

一般設定

これらの設定は、ほとんどのSVGチャートに適用されます。

ハイライトカラー

マゼンタのハイライトカラー

標準的な白黒(または白灰色)のチャートに加えて、白を任意の加法混色または減法混色の原色(R、G、B、C、M、Y)に置き換えることができます。

ベイヤーセンサーの分析では、異なる色が特に重要になります。ベイヤーセンサーでは、ピクセルの行が交互に {R、G、R、B、R、...} と {G、B、G、B、G、...} に感度を持ちます。R センサーと B センサーの数は緑色センサーの半分(総ピクセル数の 4分の 1)しかないため、赤黒チャートと青黒チャートの MTF は白黒チャートよりも劣ると予想されます。デモザイキングアルゴリズムは通常、詳細を計算するために異なる色のピクセルを使用します (つまり、他のチャネルに情報が存在する場合、赤チャネルのエッジはより鮮明になります)。また、異なるアルゴリズムは異なるパフォーマンスを示します。

コントラスト比

選択肢:なし、最大、80、50、40、25、20、10、5、4、2、1.414、1.2、1.1

明るい領域と暗い領域の反射率の比(対数周波数チャートでは上部のみ)。最大コントラスト比はプリンターと用紙によって異なります。光沢面(またはラスター面)では通常約 100 ですが、マット面では約 40 です。最大印刷濃度 = -log 10 (最小反射率) はGamutvisionで推定できます。

高コントラストのターゲットでは、クリッピングが問題となることがよくあります。旧規格(2012年以前)のISO-12233では、コントラスト比は少なくとも40(通常は80で印刷)とされていましたが、最近の実験では、コントラスト比が低い方が、ガンマやカメラの非線形性の影響を受けにくく、より正確で一貫性のある結果が得られることが示されています。SFRplusチャートの標準値は10です。2012年にはISO規格が変更され、コントラスト比4:1が推奨されるようになります。これは、テストチャートとSFRplusモジュールの両方で完全にサポートされています。

コントラスト比は、非線形信号処理(ノイズ低減や閾値によるシャープ化など)を実行するカメラのMTF(SFR)測定値に影響を与えます。これは、民生用カメラではほぼ普遍的に見られる機能です。カメラの特性評価には、コントラスト比10と2(「コントラスト(alt)」で設定)の2種類以上のコントラスト比を含むチャートを使用することをお勧めします。

対比(代替)

選択肢:なし、最大、80、50、40、25、20、10、5、4、2、1.414、1.2、1.1

左下象限のいくつかの領域に表示する第 2 のコントラスト比を選択します。コントラスト (alt) = 2.0 は、上のプレビュー画像と下のプレビュー画像に示されている 5 x 9 チャートの 4 つの領域で使用されます。「なし」を選択した場合、チャート内のすべての正方形のコントラストは同じになります。コントラスト (alt) は、多くの (おそらくほとんどの) デジタル カメラの非線形信号処理により、高コントラストのエッジが低コントラストのエッジよりも強くシャープになるため、高コントラストのエッジと低コントラストのエッジで MTF 測定値が異なるため、重要です。

ガンマ

選択肢:2.5、2.2、2.0、1.8、1.5、1.0

ガンマ値は、普段お使いのカラースペースとワークフローに合わせて設定してください(Windows の場合は 2.2、古い Mac システムの場合は 1.8 が標準です)。デフォルト値は 2.2 です。ガンマ値は、印刷時のコントラスト比とオプションのステップチャートの精度に影響します。正しいコントラスト比を得るには、印刷に使用する値(カラーマネジメントを使用している場合は、カラースペースの値、つまり Adobe RGB (1998) の場合は 2.2)と同じ値にする必要があります。なお、これはプリンターのガンマ値であり、カメラのガンマ値とは間接的にしか関係ありません。カメラのガンマ値は、オプションのグレースケール ステップチャートを使用してStepchartで測定できます。

チャートの明るさ

選択肢:最も明るい、明るい、中程度の明るさ、中程度、中程度の暗さ、最も暗い

チャートの明暗両方のグレースケールレベルを決定します。中間調がカメラの線形応答領域内にある可能性が高いSFRエッジチャートに有効です。

軽さ(代替)

選択肢:最も明るい、明るい、中程度の明るさ、中程度、中程度の暗さ、最も暗い

2番目(代替)のコントラスト比を持つ領域の明るさ。通常はチャートの明るさと同じです。

グラフの種類

テストチャートでは、いくつかの種類のSVGチャートを生成できます。以下にチャートの一覧を示します。ここではすべての設定項目を網羅的に紹介するわけではありません。テストチャートを開き、さまざまな設定を試して、その効果を確認することで、それぞれの設定がどのような効果をもたらすかを知ることができます。チャート画像をクリックすると、拡大表示されます。

Imatestストアでは、多数のチャートデザインをご用意しております。特別なカスタム要件については、お問い合わせください。 sales at imatest dot com詳細は

SVG形式の正方形と扇形(レターサイズ、A4サイズなどの印刷用)

このパターンは、ImatestのSVGチャート機能が最初に開発された際に設計されました。自動ROI検出に対応していないため、現在ではImatestの重要な機能ではありません。傾斜した正方形、「双曲線」状のくさび形、空間周波数が異なる棒グラフ、そして密度ステップが0.1のKodak Q-13ステップチャートの複製で構成されています。多様なパターンが含まれているため、今でも興味深いものです。

高品質インクジェットプリンターでA4、A3、またはレターサイズに印刷し、右図のように大きな背景にグループで配置するように最適化されていますが、品質を損なうことなく任意のサイズで印刷できます。この目的には、自動的に検出できるSFRregパターンが推奨されています。1枚のシートに印刷するチャートには大きすぎる視野(FoV)には、複数のSFRregパターンを使用できます。この場合、 SFRplus 、 eSFR ISO 、 Checkerboard 、およびSFRregが推奨されます。

小型SVGチャート;3x3配置
小さな版画の配置

右側のグラフは、コントラスト比 = 20 (現在ではほとんどの場合4、最大10を推奨しています)、ガンマ = 2.2、ハイライトカラー = 白、グラフの明るさ = 明度を使用して作成されました。

チャートの詳細: 中央の正方形の端と右下の実線は、 SFRで使用するために約5.7度(arctan(0.1))傾いています。収束する線パターン(「双曲線」ウェッジ)は、モアレパターン(ナイキスト周波数付近でのエイリアシングによって生じる色)を表示することを目的としています。これらは、MTFと解像度消失(エイリアシングの開始)を測定するウェッジモジュールで分析できます。右側のステップチャートパターンは、画像が正しく印刷されている場合、濃度ステップが0.1です。これは、Kodak Q-13チャートの複製です。

ダウンロード可能なチャートは2種類あります。それぞれ304KB(SVG形式)または500KB(PDF形式。Inkscapeのインストールが面倒な方向け)です。リンクを右クリックしてファイルを保存してください。

小柄
SVG形式の正方形とくさび形のパターン

SVG形式の正方形(1x2、2x3、3x5)

これらは、比較的低解像度のシステム向けに斜めエッジパターンを生成するために使用できます。ただし、Imatestでは広く使用されていません。

SVG形式の4x7以上の正方形(SFRplus用)

これらのチャートはSFRplusで使用され、ほとんどの用途では5x7と5x9が推奨されます。7x11は高解像度カメラでのみ推奨されます。3x17と5x25は、アスペクト比が非常に広いカメラ用です。必要に応じてInkscapeでサイズを小さく編集できます。一般的な設定は上に示されています。

SFRplusの設定

SFRplusチャートの設定。画像をクリックすると拡大表示されます。
SFRplusチャートの設定。画像をクリックすると拡大表示されます。

Imatest StoreでSFRplusチャートを購入することをお勧めしますが、ワイドボディの写真品質インクジェットプリンターとある程度のスキル(カラーマネジメントの知識など)があれば、ご自身で印刷することも可能です。5x7と5x9が標準グリッドサイズですが、4x7と7x11のグリッドもSFRplusに対応しています。下記にリストされている多くのオプションは、SFRplusに対応しています。

SFRplusチャートのオプション。標準値は括弧[...]で囲まれています。

  • パターン: [5x7および5x9] SVG正方形、4x7、5x7、5x9、7x11はSFRplusに対応しています。右側の数字は、インクジェットプリンターで印刷する場合の推奨最小サイズです。
  • ハイライトカラー: [白] ほとんどの場合、白が好ましいですが、加法混色および減法混色の原色(R、G、B、C、M、またはY)を選択することもできます。
  • コントラスト比: [10:1] 20を超える値はクリッピングが頻繁に発生する可能性があるため推奨されません。新しい(2012年に予定されている)ISO 12233規格が発行されると、4:1が標準的なチャートコントラストになります。
  • コントラスト(代替): [2] 数個の正方形(上の画像では4つ)のコントラストを交互に変更します。ほとんどのデジタルカメラでは信号処理が均一ではないため、これは便利です。コントラストの高い特徴の近傍では最大のシャープ化(高空間周波数ブースト)が行われ、近傍にコントラストの高い特徴がない場合は、シャープ化(またはノイズ低減、シャープ化ローパスフィルタリングの逆)が少なくなります。信号処理が不均一な場合、低コントラストのエッジは、コントラストの高いエッジとは異なる(低い)MTFを持ちます。
  • ガンマ: [2.2] 印刷に使用されるガンマ(コントラスト)。sRGBまたはAdobe RGB(どちらも一般的なWindowsカラースペース)の場合は、ガンマ=2.2を使用します。
  • 追加されたグラフィック: [H-Bars、SQ-20 ステップチャート、フォーカススター] これには、0.1 の密度増分を持つ 20 ステップ (5x4) ステップチャートと、歪みを測定するためのバーが含まれます。
    • Hバー(上下の水平バー)は、標準的なSFRplusチャートのデザインの一部であり、一般的には含めるべきものです(ただし、Imatest 3.9+ではバーは必ずしも必要ではありません)。
    • ステップチャート(グレースケールステップチャート)。インクジェット印刷用のチャートには、一般的に濃度増分0.1の4×5チャートが推奨されます。
    • フォーカススター。一般的に推奨されます。フォーカス補助ツールであり、分析には使用しません。Imatest社が印刷するチャートでは、カラーパターンに置き換えられる場合があります。
    • [0] 一部の正方形の中央にある小さなフォーカス補助パターンを指定します。これは、(2012年にリリース予定の)低コントラストのISO 12233エッジパターンの正方形の中央にあるパターンを修正したもので、自動エッジ検出への影響を最小限に抑えるように設計されています。
  • チャートの明るさ: [中間の明るさ] 四角形の外側の明るさ。
  • 反転(Lt/Dk)、歪み、特殊:多くのオプションが利用可能です。 六角形チャート
    • 標準(H & V) 標準的なSFRplusチャート。
    • 反転(H & V):グレースケールステップチャートを除き、明暗の正方形が反転します。
    • 通常の(六角形)正方形のパターンではなく、六角形のパターン。
      ほぼ垂直なエッジとほぼ水平なエッジに加えて、ほぼ45度のエッジも含まれるため、動きによるぼやけの分析に役立ちます。六角形の向きは交互に変わります。右図を参照してください。
    • 反転(六角形)
    • 通常の(矢状面および子午線)正方形。つまり、放射状および接線方向の正方形。Imatest 3.9 の時点ではまだサポートされていません。
    • 反転(沈下・子午線)
    • 標準歪み補正チャートは、中程度の魚眼レンズ(強い樽型歪み)で使用するためのものです。
    • 反転歪曲
    • 通常歪み+極端な魚眼レンズで使用するための事前歪み補正チャート。
    • 反転歪曲+
    • 通常、カスタム歪み、カスタム歪みを加えたプリディストーションチャート(極端な歪みまで可能です)。
  • 明るさ(代替): [中間の明るさ] 代替コントラスト四角形付近の明るさ。チャートの明るさと同じにしておくのが最適です。

右下のボックスにフォルダ名とファイル名を指定し、「テストチャートを作成」をクリックしてチャートをSVG形式で保存します。

以下の手順に従ってチャートを印刷してください。印刷には、写真品質のインクジェットプリンターを使用し、半光沢、光沢、または滑らかなマット紙などの高品質用紙を使用してください。広角レンズの場合は、マット紙が(ほぼ)反射の影響を受けないため、強く推奨します。

印刷(用紙)サイズは、低解像度画像(3メガピクセル未満)の場合は13x19インチまで小さくできますが、チャートの幅は、6メガピクセル未満のコンパクトデジタルカメラの場合は少なくとも24インチ、15メガピクセルまでのDSLRやその他のカメラの場合は39インチ(24インチ用紙に印刷、40インチのフォームボードにぴったり収まります)、15メガピクセル以上の高品質カメラの場合は60インチ(44インチ用紙に印刷、40x60インチのフォームボードにぴったり収まります)にする必要があります。エッジが目視できれいでシャープに見えることを確認してください。良い拡大鏡またはルーペで確認してください。チャートの品質については、 「チャートの品質と距離」で詳しく説明します。

チャートを印刷する場合は、高品質なカラーマネジメント対応の写真印刷に精通していることを強くお勧めします。ワイドボディの写真品質インクジェットプリンターが必要です。手順は複雑なので、注意深く実行してください。普通紙にチャートを印刷することは絶対に避けてください。端の品質が悪く、テスト結果はテスト対象システムよりもチャートの品質(の悪さ)をより反映する傾向があります。

印刷した図表は、厚さ1/2インチ(12.5cm)の大きな発泡スチロール板に、スプレー接着剤または両面テープで貼り付けてください。1/2インチの発泡スチロール板は、標準的な1/4インチまたは3/8インチの板よりも平らな状態を保ちます。

アメリカ空軍1951年決議図アメリカ空軍1951年決議図

由緒ある米空軍決議1951は、MTFが標準画像の見た目にどのように影響するかを示しています。この決議はImatestのどのモジュールでもサポートされていません。テストにはお勧めしません。自動測定には不向きで、多くのスペースが無駄になっていますが、良くも悪くも馴染み深く、視覚的な例としては優れています。数値(ほとんど役に立たないもの)は省略されています。

隣接する棒グラフのサイズは、2の6乗根(2 1/6 )の係数で異なります。この図表については、 en.wikipedia.org/wiki/ 1951_USAF_resolution_test_chart で説明されています。

ドット柄

ドットパターンチャートは、Imatestドットパターンモジュールと併用して、CPIQ(カメラ付き携帯電話画像品質)規格に準拠した歪みと横色収差を測定するために設計されています。多くのオプションが用意されていますが、一般的にはコントラスト比10以上での印刷が推奨されます。CPIQ規格に完全に準拠するには、ドット半径0.16、縦方向のドット数を15個以上使用してください。

ISO 12233:2014 ( eSFR ISO ): 4:1 エッジ

主な設定:

グレースケールと追加スクエアでは、拡張(3:2)、拡張(16:9)、追加ウェッジなど、さまざまな構成を選択できます。SFRregセンターチャートはここで選択できます。

内側の円/四角形:内側の四角形を強く推奨します。円はeSFR ISOのエッジ検出を妨げる可能性があります。

ISO 12233:2014規格に示されている図表には、9つの正方形しかありません。正方形の外側の領域は規定されていないため、追加された正方形(側面)や扇形、その他の変更はISO規格への準拠には影響しませんが、図表の有用性を大幅に向上させます。(元の図表にある3つの点だけでは、自動検出には不十分です。)

eSFR ISOチャートの設定。画像をクリックすると拡大表示されます。
eSFR ISOチャートの設定。画像をクリックすると拡大表示されます。

チェッカーボード(SVG)パターン

チェッカーボード図を生成するには、(ビットマップの歪みグリッドではなく)この選択肢を使用することをお勧めします。縦方向の正方形の数は、12個程度(多すぎても少なすぎてもいけません)が適切です。コントラスト比は4:1または10:1が推奨されます。

チェッカーボードチャートの設定。画像をクリックすると拡大表示されます。
チェッカーボードチャートの設定。画像をクリックすると拡大表示されます。
(36パッチDR)インクジェットプリンターには対応していません

SVGの象限または登録マーク( SFRreg用)

これらは任意のサイズで印刷でき、好きなように配置できます。SFRregチャートには様々な興味深い用途があります。コントラスト比は4:1または10:1が推奨されます。

SFRregチャートの設定。画像をクリックすると拡大表示されます。
SFRregチャートの設定。画像をクリックすると拡大表示されます。

PNG(ビットマップ)ファイルをSVGファイルと一緒に保存する

Imatest 2021.1以降では、SVGファイルとともにビットマップ(PNG)ファイルを保存できるようになりました。ほとんどの場合は不要ですが、例えば、完全なイメージングシステムシミュレーション(開発中)でイメージセンサーをモデル化する場合など、ビットマップ画像が役立つ場面もあります。以下に、必要な手順を示します。

  • Inkscapeをダウンロードしてインストールしてください(無料ですし、SVGファイルの編集や印刷に最適です)。古いバージョン(1.0.1より前)をお使いの場合は、まずアンインストールすることをお勧めします。InkscapeはWindows、Macintosh、Linux版が利用可能です。inkscape.exeがインストールされているフォルダをメモしておいてください(WindowsのデフォルトはC:\Program Files\Inkscape\binです)。
PNG 保存領域はプレビュー画像の下にある。
PNG 保存領域はプレビュー画像の下にある。
  • 「セットアップ」をクリックし、inkscape.exeフォルダを開きます。
  • 「テストチャートを作成」をクリックしたときにPNGファイルを保存するには、 「PNG(ビットマップ)ファイルを保存」にチェックを入れ、PNG(画像)の高さをピクセル単位で選択します。幅は比例して調整されます。 ?をクリックすると、このページへのリンクが開きます。

ビットマップ (PNG) 変換は、 Inkscape のマニュアルページに記載されている構文のシステムコマンドを発行することによって実行されます。SVG ファイルの名前が "chart_temp.svg" の場合、  一般的なWindowsシステムで画像の高さが640ピクセルと指定されている場合、システムコマンドは次のようになります。

"C:\Program Files\Inkscape\bin\inkscape.exe" --export-type=png -h 640 "C:\imatest\Graphics\chart_temp.svg"

Inkscapeのエクスポート形式リスト(svg、png、ps、eps、pdf、emf、wmf、xaml)に含まれる標準ビットマップファイル形式はPNGのみです。PNGファイルは、ほぼすべての画像編集ソフトで他のビットマップファイル形式に変換できます。私たちはよく、無料で高機能なIrfanviewを使用しています。

SVGチャートの印刷

SVGチャートはInkscapeから直接印刷できます。画像はビットマップ(PNG)形式に変換することもできます(印刷には推奨されません)。また、InkscapeからPDF形式で保存し、Adobe AcrobatやFoxit ReaderなどのPDFビューアで印刷することも可能です。

最終的な印刷コマンドを発行する前に、必ず印刷イメージをプレビューしてください。

Inkscapeからの印刷

  • Inkscapeをダウンロードしてインストールしてください。優れた内蔵チュートリアルにアクセスするには、Inkscapeを開き、「ヘルプ」 → 「チュートリアル」をクリックしてください。
  • Imatest Test Chartsを実行してSVGチャートを作成してください。適切なフォルダとファイル名を選択してください。ファイル拡張子はsvgです。
  • 保存したSVGファイルをInkscapeで開きます。必要に応じて編集してください。例えば、鏡像を作成するには、グラフ画像を選択し、「オブジェクト」 →「水平反転」をクリックします。選択したグラフを右クリックし、「グループ解除」をクリックして、必要に応じてグラフを並べ替えることもできます。
  • 印刷オプションを設定してください。正しく印刷するための設定はやや複雑です。
ドキュメントプロパティウィンドウ
ドキュメントプロパティウィンドウ

ファイル、ドキュメントのプロパティ…をクリックして、右側に表示されているドキュメントのプロパティウィンドウを開きます。ページタブを表示します。フォーマットでは、USレター、A4などの標準ページサイズを選択するか、カスタムページサイズを選択できます。ほとんどの大判インクジェットプリンターでは、カスタムページサイズが必要です。たとえば、13x19インチの印刷の場合は、幅に19.00 、高さに13.00 、幅の右側の単位ボックスにインチを入力します。ページの向きは、横向きに設定してください。ページサイズの選択が完了したら、右上のXをクリックしてウィンドウを閉じます。

Inkscapeウィンドウ (下図) で図を選択し、 WとHの間にある小さな南京錠アイコンをクリックして縦横比を固定し、 WまたはHのいずれかを目的の寸法に設定します。もう一方の寸法は自動的に設定されます。X を左、 Yを下の余白に設定します。表示されている値(X = 0.5、 Y = 0.25、 W = 10、 H = 8インチ) は、US レターサイズ (8.5 x 11 インチ) の用紙の中央に画像を配置します。または、Ctrl キーを押しながら角の矢印のいずれかをドラッグして画像を拡大し、縦横比を維持することもできます。

Inkscapeウィンドウ
Inkscapeウィンドウの一部に印刷設定(X、Y、W、H、…)を表示しています。
エプソンR2400印刷ダイアログボックス
Epson R2400プリンタードライバーダイアログボックス
  • ファイル、印刷…をクリックして印刷ダイアログウィンドウを開きます。次に、プロパティ…をクリックしてプリンターのプロパティダイアログウィンドウを開きます。常に高品質の印刷設定と用紙を使用してください。印刷方向を横向きに設定します。ICCカラーマネジメントを使用せず、プリンタードライバーでガンマを選択できる場合は、チャートの作成に使用したガンマと同じ値を使用してください(一般的には2.2が推奨されます)。
  • 右側の画像は、Epson R2400の印刷ダイアログボックスです。InkscapeはICC規格に準拠していないため(ICCプロファイルを認識しないため)、プリンタードライバーでカラーマネジメントを実行するように設定されています。カラーマネジメント/ICCプロファイルを使用することで、最も正確な階調表現が得られ、コントラストも期待値に最も近いものになります。
  • ICCプリンタープロファイルをお持ちの場合は、プリンタードライバーのウィンドウで適用できる場合があります。メーカー提供のプロファイルで十分な場合が多いですが、階調値が重要な場合はカスタムプロファイルの方が適しています。SilverFast 8.5 – Printer Calibrationは、分光光度計を使用せずにICCプリンタープロファイルを取得できる優れた低コストツールです。It8.7チャートで校正されたフラットベッドスキャナーを使用します。

Adobe RGB (1998) は、ガンマ値が正確に 2.2 であるため、推奨される入力プロファイルです (sRGB は約 2.2 です)。相対測色レンダリング インテントは、知覚レンダリング インテントよりも線形応答が高くなります (黒点補正を参照)。印刷プレビューを確認してください。上記の設定がすべて正確に行われていない限り、印刷サイズは正しく表示されません。Inkscape は印刷サイズの設定に非常に厳しいため、注意が必要です。プレビューはやや時間がかかる場合があります。

  • プロパティウィンドウで「OK」をクリックし、次に印刷ダイアログウィンドウで「OK」をクリックします。印刷は処理遅延後に開始されますが、コンピュータのメモリ容量と処理速度によっては、かなり長い時間(多くの場合1分以上)かかることがあります。
Inkscapeのビットマップエクスポートウィンドウ
Inkscapeのビットマップエクスポートダイアログボックス

画像エディタからビットマップファイルを印刷する

一般的にこの方法は推奨しません。非常に大きなグラフはファイルサイズが大きくなり、画質が劣化する可能性が高いためです。可能な限り、SVGファイルまたはPDFファイルから直接印刷してください。

  • 上記の手順1~4に従ってください。Inkscapeをインストールし、SVGテストチャートを作成して保存し、Inkscapeで開き、チャート画像を選択して、ドキュメントプロパティウィンドウを使用してページと画像のサイズを設定し、チャート画像の隅にあるハンドルを使用して画像のサイズを設定します。
  • ファイルメニューから「ビットマップの書き出し」を選択して、右側に表示されている「ビットマップの書き出し」ウィンドウを開きます。必要に応じて、単位をインチまたはセンチメートルに設定します。幅(右上)は、印刷されるグラフ画像の幅(棒グラフの長さ)です。高さは、棒グラフの上下に空白の白い領域があるため、印刷された画像の表示高さよりもわずかに大きくなります。
  • キヤノンまたはHPプリンターの場合は、 dpi(ビットマップサイズ)を300または600に設定してください。エプソンプリンターの場合は、360または720に設定してください。幅24インチ未満の小さなチャートは、dpiを高く設定すると若干鮮明になる場合がありますが、その差はほとんど分かりません。幅30インチ以上の非常に大きな印刷物の場合は、メモリを節約するためにdpiを低く設定することをお勧めします。幅と高さは、結果として得られるファイルのピクセルサイズを示します(これらのボックスは変更しないでください)。
  • ファイル名を希望の保存場所に設定してください。PNG形式を維持してください。PNGはロスレス圧縮方式であり、この種のシンプルな画像であれば非常に高い圧縮率が得られます。次に、「エクスポート」をクリックしてください。
  • 画像エディタに画像を読み込みます。ドキュメントプロパティで指定した用紙サイズと、ビットマップの書き出しウィンドウで指定した幅で印刷します。 カラーマネジメントされたワークフローを使用している場合(強く推奨)、ファイルプロファイルをAdobe RGBに設定します(データは変更しません)。Adobe RGBは、ガンマ値が正確に2.2であるため、Windows標準のsRGBカラースペースよりもわずかに正確です(sRGBは近似値です)。レンダリングインテントを、 ブラックポイント補正をオフにした相対測色に設定します。

Foxit ReaderからPDFファイルを印刷する

Foxit Readerの印刷ダイアログ
Foxit Readerの印刷ダイアログボックス。

Inkscape 0.46からの印刷に問題が発生した際に、この方法を開発しました。

  • この方法で素晴らしい結果が得られていますが、試す場合は、プリンタードライバーでカラーマネジメントを実行するように設定する方法を知っておく必要があります。
  • 上記の手順1~4に従ってください。Inkscapeをインストールし、SVGテストチャートを作成して保存し、Inkscapeで開き、チャート画像を選択して、ドキュメントプロパティウィンドウを使用してページと画像のサイズを設定し、チャート画像の隅にあるハンドルを使用して画像のサイズを設定します。
  • 「ファイル」→「名前を付けて保存」をクリックします。 「ファイルの種類」ダイアログボックスで「Portable Document Format (*.pdf)」を選択し、ファイルを保存します。
  • Foxit ReaderなどのPDFリーダーでファイルを開いてください。
  • 「ファイル」→「印刷」または印刷アイコンをクリックします。右側に表示されているダイアログボックス(Foxit Readerの場合)が表示されます。
  • サイズとプリンタードライバーの設定が正しいことを確認してください。右側に表示されている設定は一般的なものですが、結果は異なる場合があります。カラーマネジメントはプリンタードライバーによって適用されます。右側に一般的な設定が表示されています。次に「OK」をクリックしてください。可能であれば、印刷結果をプレビューすることを強くお勧めします。

チャートの測定と校正

テストチャートのグレースケールおよびカラーパッチを測定する手順については、 「テストチャートパッチの測定」を参照してください。これらの測定によって生成されたCGATSファイルは、カラーチャートまたはグレースケールチャートを分析するImatestモジュール( Color/Tone Interactive 、 Colorcheck 、 Stepchart 、 Rescharts (SFRplus) 、 MultiTest )のいずれでも読み込むことができます。