测试图表工具 用于创建可在高品质喷墨打印机上打印的测试图表文件。本页面重点介绍可缩放矢量图形 (SVG)图表,其中许多图表用于使用Imatest SFR 、 SFRplus 、 eSFR ISO 、 Checkerboard和SFRreg测量清晰度 (MTF)。(位图图表将在其他地方介绍。)SVG 图表可以以打印机的最高质量(即分辨率)打印任意尺寸,没有任何限制,而且通常比位图图像占用更少的存储空间。专为使用SFRplus和eSFR ISO (基于 ISO 12233:2014/2017)进行自动化测试而设计的 SVG 图表,相比于我们熟悉但已过时的 ISO 12233:2000 图表,具有诸多优势。
这些图表大多可通过Imatest 商店获取。除非您拥有高品质照片打印机(办公打印机效果不佳)以及具备高质量色彩管理打印技能,否则我们不建议您自行打印。我们无法保证自行打印的图表效果。
介绍
矢量图形由线条、多边形等基本图形组成,可以缩放到任意大小,并且不会像位图图像那样出现像素化问题。无论尺寸大小,它们都能以打印机的最高质量进行打印。矢量图形非常适合生成由线条、曲线和区域组成的测试图表,这些图表不需要连续的灰度色调。
可缩放矢量图形 (SVG)是一种 XML 文件格式,已被万维网联盟 ( W3C ) 认可。SVG 文件可以使用Inkscape (一款优秀的免费开源软件)读取、编辑和打印。此外,它们还可以导入到 Adobe Illustrator、Corel Draw 等软件中。
手术
要运行测试图表,请运行Imatest ,然后单击 Imatest 主窗口右侧“实用工具”选项卡中的“测试图表” 。此时将显示如下所示的对话框。不同模式的可用设置会有所不同。
适用于 5x7 SFRplus 测试图(ISO 标准 4:1 对比度)的测试图设置

选择图表类型和选项。图表预览会立即显示;建议您花些时间探索这些选项(本页不会列出所有选项)。选择选项后,输入测试图表文件夹(目录)和文件名,然后单击“创建测试图表” 。您可以单击“关闭”取消操作。此时将显示图表预览图(不可打印)。您可以放大查看细节。示例如下所示。
图中所示的图表仅供预览:它大致展示了图表的外观,您可以根据需要放大查看。请勿直接从该图中打印图表。要打印 SVG 图表,请将打印测试的 SVG 输出文件(上例中的 chart_temp.svg)加载到支持 SVG 的编辑器中。(推荐使用Inkscape ;Adobe Illustrator、Corel Draw 等软件也适用。)这样您就可以选择打印尺寸、添加注释、使用颜色管理等功能。
您可以通过选择区域或单击感兴趣的点来放大图表。双击即可恢复完整图像。预览图像(或图像的放大图)可能存在一些瑕疵,并且由于缺少抗锯齿功能而显得锯齿状。

5x7 变形图表;4:1 对比度,多个方格内有对焦辅助。
常规设置
这些设置适用于大多数 SVG 图表。
高亮颜色
除了标准的白/黑(或白/灰)色卡外,您还可以用任何加色或减色原色(红、绿、蓝、青、品红或黄)代替白色。
在分析拜耳传感器时,不同颜色尤为重要。拜耳传感器中,像素的交替行分别对{R, G, R, B, R, ...}和{G, B, G, B, G, ...}敏感。由于红色和蓝色传感器的数量只有绿色传感器的一半(总像素数的四分之一),因此可以预期,红黑和蓝黑图表的MTF值会比白黑图表更差。去马赛克算法通常利用不同颜色的像素来计算细节(例如,如果其他通道中存在信息,则红色通道中的边缘会更清晰)。此外,不同的算法性能也不同。
对比度
选项:无、最大值、80、50、40、25、20、10、5、4、2、1.414、1.2、1.1
明暗区域反射率之比(仅指对数频率图中的上部区域)。最大对比度取决于打印机和纸张。对于光面(或光泽面),最大对比度通常约为 100,而对于哑光面,则约为 40。最大打印密度 = -log 10 (最小反射率)可通过Gamutvision进行估算。
高对比度测试图经常会出现过曝问题。旧版(2012 年之前)ISO-12233 标准要求对比度至少为 40(通常打印时为 80),但近期的实验表明,较低的对比度可以产生更准确、更一致的结果,并且受伽马校正和相机非线性的影响更小。SFRplus测试图的标准对比度值为 10。2012 年,ISO 标准将更新为推荐对比度为 4:1,测试图和 SFRplus 模块均完全支持此标准。
对比度会影响执行非线性信号处理(例如,使用阈值进行降噪和锐化)的相机的MTF(SFR)测量结果——这几乎是消费级相机的普遍特性。建议使用至少包含两种对比度(10和2,可通过“对比度(alt)”设置)的图表来表征相机。
对比(alt)
选项:无、最大值、80、50、40、25、20、10、5、4、2、1.414、1.2、1.1
选择第二个对比度,用于在左下象限的几个区域中显示——在上方和下方预览图像所示的 5 x 9 图表中,有四个区域使用了对比度 (alt) = 2.0。如果选择“无”,则图表中的所有方块都具有相同的对比度。对比度 (alt) 之所以重要,是因为许多(或许是大多数)数码相机中的非线性信号处理会导致高对比度边缘比低对比度边缘锐化得更强,从而使高对比度边缘和低对比度边缘具有不同的 MTF 测量值。
伽马
选项:2.5、2.2、2.0、1.8、1.5、1.0
您应该使用适用于您常用色彩空间和工作流程的伽玛值(Windows 标准值为 2.2;较旧的 Mac 系统为 1.8)。默认值为 2.2。伽玛值会影响打印对比度和可选阶梯图的准确性:它必须与打印时使用的值相同(即色彩空间的值,例如,如果使用色彩管理,则 Adobe RGB (1998) 的伽玛值为 2.2),才能获得正确的对比度。请注意,这是打印机伽玛值,它与相机伽玛值只有间接关系,相机伽玛值可以使用Stepchart 的可选灰度阶梯图进行测量。
图表亮度
选项:最浅、浅、中浅、中等、中深、最深
确定图表中亮部和暗部的灰阶级别。这对于SFR边缘图表非常有用,因为其中间色调很可能位于摄像机的线性响应区域内。
亮度(alt)
选项:最浅、浅、中浅、中等、中深、最深
具有第二种(替代)对比度的区域的亮度。通常与图表亮度相同。
图表类型
测试图表可以生成多种类型的 SVG 图表。我们在下面列出了这些图表。这里我们不列出所有设置——您可以打开测试图表,尝试各种设置并查看其效果,从而了解它们的具体功能。点击图表图像可以查看大图。
Imatest商店提供多种图表设计。如有特殊定制需求,请联系我们。
详情请见下文。
SVG 正方形和楔形图案(适用于打印信纸尺寸、A4 等)这个图案是在 Imatest SVG 图表功能最初开发时设计的。由于它与自动 ROI 检测不兼容,因此不再是 Imatest 的重要组成部分。它由倾斜的正方形、“双曲”楔形、不同空间频率的条形以及密度步长为 0.1 的 Kodak Q-13 阶梯图的复制品组成。尽管如此,它仍然具有一定的参考价值,因为它包含了多种图案。 它针对使用高品质喷墨打印机打印 A4、A3 或 Letter 尺寸的图表进行了优化,并以多组形式排列在更大的背景上,如右图所示——尽管它可以打印成任何尺寸而不会损失质量。目前建议使用可自动检测的SFRreg图案来实现此目的。对于单张打印图表时视野 (FoV) 过大的情况,可以使用多个 SFRreg 图案,此时建议使用SFRplus 、 eSFR ISO 、 Checkerboard和SFRreg 图案。 | ![]() |
右侧图表的创建参数为:对比度 = 20(我们现在建议大多数情况下使用 4,最大值为 10),伽玛值 = 2.2,高亮颜色 = 白色,图表亮度 = 亮。 图表详情: 中心方框和右下角实心区域的边缘倾斜约 5.7 度(arctan(0.1)),用于SFR分析。汇聚线图案(“双曲”楔形)用于观察莫尔条纹:这是由于奈奎斯特频率附近的混叠现象而产生的颜色。可以使用楔形模块分析这些图案,该模块可以测量 MTF 和分辨率消失点(混叠的起始点)。右侧的阶梯图图案在图像正确打印的情况下,密度步长为 0.1:它是柯达 Q-13 色卡的复制品。 提供两张图表供下载。每张图表大小分别为 304 KB(SVG 格式)或 500 KB(PDF 格式——方便那些不想安装 Inkscape 的用户)。右键点击链接即可保存文件。
| ![]() |
SVG 正方形 1x2、2x3、3x5
这些方法可用于为分辨率相对较低的系统生成倾斜边缘图案。它们在 Imatest 中应用并不广泛。
SVG 正方形 4x7 及以上尺寸(适用于 SFRplus)
这些图表与SFRplus配合使用,建议大多数应用场景使用 5x7 和 5x9 尺寸。7x11 尺寸仅推荐用于超高分辨率相机。3x17 和 5x25 尺寸适用于宽高比极宽的相机。如有需要,可在Inkscape中编辑缩小尺寸。典型设置如上所示。
SFRplus 设置

虽然我们推荐 您从 Imatest 商店购买 SFRplus 色卡,但如果您拥有宽幅照片级喷墨打印机并具备一定的技能(例如,了解色彩管理),也可以自行打印。5x7 和 5x9 是标准网格尺寸,但 4x7 和 7x11 网格也与 SFRplus 兼容。以下列出的许多选项都与 SFRplus 兼容。
SFRplus图表选项。标准值用方括号括起来[...]。
- 图案: [5x7 和 5x9] SVG 正方形,4x7、5x7、5x9、7x11 尺寸与 SFRplus 兼容。右侧数字为喷墨打印机打印时的最小推荐尺寸。
- 高光颜色: [白色] 白色在大多数情况下是首选,但也可以选择加色原色和减色原色(红、绿、蓝、青、品红或黄)。
- 对比度: [10:1] 不建议使用高于 20 的值,因为这样容易出现图像溢出。新的 ISO 12233 标准(预计于 2012 年发布)发布后,4:1 将成为标准图表对比度。
- 对比度(交替): [2] 几个方块(上图中的四个)的交替对比度。这很有用,因为大多数数码相机中的信号处理并不均匀:最大程度的锐化(高空间频率增强)发生在对比度高的特征附近,而当附近没有对比度高的特征时,锐化程度较低(或降噪,这与锐化低通滤波相反)。当信号处理不均匀时,低对比度边缘的MTF值与高对比度边缘的MTF值不同(更低)。
- Gamma: [2.2] 用于打印的 Gamma 值(对比度)。对于 sRGB 或 Adobe RGB(均为常见的 Windows 色彩空间),请使用 gamma = 2.2
- 新增图形: [H-Bars、SQ-20 阶梯图、聚焦星] 这包括一个 20 步(5x4)阶梯图,密度增量为 0.1,以及用于测量畸变的条形图。
- H 形条(顶部和底部的水平条)是标准 SFRplus 图表设计的一部分,通常应该包含在内(尽管在 Imatest 3.9+ 中,条形并非严格必要)。
- 阶梯图(灰度阶梯图)。对于喷墨打印的图表,通常建议使用 4x5 的图表,密度增量为 0.1。
- 焦点星。通常推荐使用。用于辅助对焦,不用于分析。在 Imatest 打印的图表中,焦点星可能被颜色图案所取代。
- [0] 表示在某些方格中心有一个小的对焦辅助图案。这是低对比度 ISO 12233 边缘图案(将于 2012 年发布)中方格中心图案的修改版本,旨在最大限度地减少对自动边缘检测的影响。
- 图表亮度: [中等亮度] 方格外的亮度。
- 反转浅/深、失真、特殊效果:多种选项可供选择。

- 正常(水平和垂直)标准 SFRplus 图表。
- 反转(水平和垂直)明暗方块反转,但灰度阶梯图除外。
- 普通(六边形)六边形图案代替正方形图案。
除了近乎垂直和近乎水平的边缘外,还包括近乎 45 度的边缘,这使得它们可用于检查运动相关的模糊。六边形方向交替。如图所示。 - 反转(六边形)
- 正常(矢状面和子午面)矢状面和子午面(即径向和切向)正方形。截至 Imatest 3.9 版本尚不支持。
- 倒置(垂线和子午线)
- 适用于中等鱼眼镜头(严重桶形畸变)的普通畸变预畸变图表。
- 反转失真
- 适用于极端鱼眼镜头的普通畸变+预畸变图表。
- 反转扭曲+
- 普通 自定义扭曲 预扭曲图表,带有自定义扭曲(可以达到非常夸张的程度)。
- 亮度(alt): [中等亮度] 接近交替对比度方块的亮度。最好与图表亮度保持一致。
在右下角的框中指定文件夹和文件名,然后单击“创建测试图表”以 SVG 格式保存图表。
请按照以下说明打印图表。打印时请使用照片级喷墨打印机,并选择高品质纸张:半光泽纸、光面纸或光滑涂层哑光纸。强烈建议广角镜头使用哑光纸,因为它(几乎)不会产生眩光。
对于低分辨率图像(低于 300 万像素),打印(纸张)尺寸可以小至 13x19 英寸;但图表宽度至少应为 24 英寸(适用于 600 万像素以下的小型数码相机)、39 英寸(打印在 24 英寸的纸张上;可完美适配 40 英寸的泡沫板,适用于单反相机和其他 1500 万像素以下的相机)、60 英寸(打印在 44 英寸的纸张上;可完美适配 40x60 英寸的泡沫板,适用于 1500 万像素以上的高品质相机)。务必确保边缘清晰锐利;使用放大镜或放大镜仔细检查。图表质量的详细说明请参见“图表质量和距离”部分。
如果您选择打印图表,我们强烈建议您熟悉高质量色彩管理照片打印技术。您需要一台宽幅照片级喷墨打印机。操作说明较为复杂,请务必仔细阅读并遵循。切勿在普通复印纸上打印图表。普通复印纸打印的图表边缘质量较差,测试结果往往更多地反映图表本身的质量问题,而非被测系统的质量问题。
打印好的图表应使用喷胶或双面胶带粘贴在 1/2 英寸(12.5 厘米)厚的泡沫板上。1/2 英寸厚的泡沫板比标准的 1/4 英寸或 3/8 英寸厚的泡沫板更平整。
美国空军 1951 年分辨率图表
经典的美国空军第1951号决议图展示了MTF如何影响标准图像的外观。该决议图不被任何Imatest模块支持,因此我们不建议将其用于测试。它不太适合自动测量,而且浪费了大量空间,但无论如何,它为人熟知,是一个很好的视觉示例。图中省略了大部分无用的数字。
相邻条形图案的大小相差 2 的六次方根 (2 1/6 )。该图表的描述见en.wikipedia.org/wiki/1951_USAF_resolution_test_chart 。
ISO 12233:2014( eSFR ISO ):4:1 边缘关键设置: “灰度”和“添加方格”选项允许您选择多种配置,包括增强型 (3:2)、扩展型 (16:9) 和额外楔形块。您可以在此处选择 SFRreg 中心图表。 内圆/内方:强烈建议使用内方方。圆形可能会干扰 eSFR ISO 边缘检测。 ISO 12233:2014 标准中所示的图表只有 9 个方格。由于方格外的区域未作具体规定,因此添加的方格(在两侧)、楔形以及其他改动并不影响 ISO 标准的符合性,但却大大提高了图表的实用性。(原图中的三个点不足以进行自动检测。) | ![]() |
棋盘格(SVG)图案建议使用此选项(而非棋盘格位图扭曲网格)生成棋盘格图。垂直方格的数量应在 12 个左右(不要太多或太少)。建议对比度为 4:1 或 10:1。 | ![]() |
| (36片装DR)不适用于喷墨打印机 | |
SVG象限或注册标记(用于SFRreg )这些图表可以打印成任意尺寸,并根据需要进行排列。SFRreg 图表有很多有趣的用途。建议使用 4:1 或 10:1 的对比度。 | ![]() |
将 PNG(位图)文件与 SVG 文件一起保存
从 Imatest 2021.1 版本开始,可以同时保存位图 (PNG) 文件和 SVG 文件。大多数情况下无需这样做,但在某些情况下位图图像很有用,例如,在完整的成像系统仿真(开发中)中对图像传感器进行建模。以下是您需要遵循的步骤。
- 下载并安装Inkscape (它是免费的,非常适合编辑和打印 SVG 文件)。如果您使用的是旧版本(1.0.1 之前的版本),我们建议您先将其卸载。Inkscape 提供 Windows、Macintosh 和 Linux 版本。请记下 inkscape.exe 的安装文件夹(Windows 默认位置为 C:\Program Files\Inkscape\bin)。

- 点击“设置” ,然后进入 inkscape.exe 文件夹。
- 点击“创建测试图表”后,要保存为 PNG 文件,请勾选“保存 PNG(位图)文件”选项,并选择 PNG(图像)的高度(以像素为单位)。宽度将按比例缩放。 “?”会打开指向此页面的链接。
位图 (PNG) 转换是通过发出系统命令来完成的,其语法在Inkscape 手册页中有所描述。对于名为“chart_temp.svg”的 SVG 文件, 在典型的 Windows 系统中, 如果图像高度指定为 640 像素,则系统命令为:
"C:\Program Files\Inkscape\bin\inkscape.exe" --export-type=png -h 640 "C:\imatest\Graphics\chart_temp.svg"
PNG 是Inkscape 导出类型列表中唯一包含的标准位图文件格式,其他导出类型包括:svg、png、ps、eps、pdf、emf、wmf 和 xaml。几乎所有图像编辑器都可以将 PNG 文件转换为其他位图文件格式。我们经常使用Irfanview ,它是一款免费且功能强大的图像编辑器。
打印SVG图表
您可以直接从Inkscape打印 SVG 图表。图像也可以转换为位图 (PNG) 格式(不建议用于打印),或保存为 PDF 格式(从 Inkscape 导出),然后使用 Adobe Acrobat 或Foxit Reader 等 PDF 查看器进行打印。
在发出最终打印命令之前,务必先预览打印图像。
使用 Inkscape 进行打印
- 下载并安装Inkscape 。要访问其内置的优秀教程,请打开 Inkscape 并单击 、 。
- 运行Imatest 测试图表以创建 SVG 图表。请务必选择合适的文件夹和文件名。文件扩展名为 svg。
- 使用 Inkscape 打开保存的 SVG 文件。您可能需要进行一些编辑。例如,要创建镜像图像,请选择图表图像,然后单击 ,再单击 。您也可以右键单击选定的图表,单击“取消组合”,然后重新排列图表以满足您的需求。
- 设置打印选项。正确的打印设置比较复杂。
点击“文件”> “文档属性…”打开“文档属性”窗口(如右图所示)。显示“页面”选项卡。在“格式”下,您可以选择标准页面尺寸,例如美式信纸、A4 等,也可以选择自定义页面尺寸。大多数大幅面喷墨打印机需要自定义页面尺寸。例如,对于 13x19 英寸的打印件,请在“宽度”中输入19.00 , “高度”中输入13.00 ,并在“宽度”右侧的单位框中输入“英寸” 。页面方向应设置为“横向”。选择完页面尺寸后,点击右上角的“X”关闭窗口。
在Inkscape窗口(如下图所示)中,选中图形,点击W和H之间的小锁图标锁定宽高比,然后将W或H设置为所需尺寸。另一个尺寸会自动调整。将X设置为左边距, Y设置为下边距。图中所示的值( X = 0.5, Y = 0.25, W = 10, H = 8 英寸)可将图像居中显示在 8.5 x 11 英寸的美国信纸尺寸上。或者,您也可以按住 Ctrl 键并拖动其中一个角箭头来放大图像,以保持宽高比。

- 单击 > 打开“打印”对话框。然后单击打开打印机“属性”对话框。务必使用高质量的打印设置和纸张。将方向设置为“横向” 。如果未使用 ICC 色彩管理且打印机驱动程序可以选择伽玛值,请确保使用与创建色卡时相同的伽玛值(通常建议使用 2.2)。
- 右图显示的是爱普生 R2400 打印机的打印对话框,由于 Inkscape 不兼容 ICC 标准(无法识别 ICC 配置文件),因此已将色彩管理设置为在打印机驱动程序中进行。使用色彩管理/ICC 配置文件可获得最准确的色调响应:对比度将最接近您的预期。
- 如果您拥有 ICC 打印机配置文件,则可以在打印机驱动程序窗口中应用它。制造商提供的配置文件通常就足够了;当色调值至关重要时,自定义配置文件则更为理想。SilverFast 8.5 – 打印机校准是一种无需分光光度计即可获取 ICC 打印机配置文件的出色低成本方法——它使用经 It8.7 图表校准的平板扫描仪即可完成。
推荐使用 Adobe RGB (1998) 输入配置文件,因为它的伽玛值精确为 2.2(sRGB 的伽玛值仅约为 2.2)。相对比色渲染意图的线性响应应优于感知渲染意图(参见黑点补偿)。务必检查打印预览,因为只有上述所有设置完全正确,打印尺寸才能准确——Inkscape 对打印尺寸设置的要求非常严格。预览速度可能较慢。
- 在“属性”窗口中单击 ,然后在“打印”对话框中 。打印会在处理延迟后开始,延迟时间可能相当长,具体取决于计算机的内存和速度——通常超过一分钟。
从图像编辑器打印位图文件
我们通常不建议采用这种方法,部分原因是超大图表需要巨大的文件体积,而且很可能出现像素化。如果可以,请直接从 SVG 或 PDF 文件打印。
- 按照上述步骤 1-4 操作:安装 Inkscape,创建 SVG 测试图表,保存它,在 Inkscape 中打开它,选择图表图像,然后使用“文档属性”窗口设置页面和图像大小,并使用图表图像角落的控制柄设置图像大小。
- 单击“文件”>“导出位图...”打开“导出位图”窗口(如右图所示)。根据需要将单位设置为英寸或厘米。“宽度”(右上角)是要打印的图表图像的宽度(即柱状图的长度)。“高度”略大于打印图像的可见高度,因为柱状图的上下方留有空白区域。
- 对于佳能或惠普打印机,请将位图尺寸的dpi 设置为 300 或 600;对于爱普生打印机,请设置为 360 或 720。较小的图表(宽度小于 24 英寸)在较高的 dpi 设置下可能会略微更清晰,但差异几乎无法察觉。对于非常大的打印件(宽度 30 英寸或更宽),建议使用较低的 dpi 设置以节省内存。“宽度”和“高度”显示的是最终文件的像素大小(请勿更改这些设置)。
- 将文件名设置为所需位置。保留 PNG 格式。PNG 格式是无损压缩的,而且对于这种类型的简单图像来说,压缩率很高。然后点击“导出”。
- 将图像加载到图像编辑器中。使用与“文档属性”中指定的纸张尺寸相同的纸张尺寸,以及与“导出位图”窗口中指定的宽度相同的纸张尺寸进行打印。如果您使用色彩管理工作流程(强烈建议),请将文件配置文件设置为 Adobe RGB(无需更改数据)。Adobe RGB 比 Windows 标准 sRGB 色彩空间更精确,因为它具有精确的伽玛值 2.2(sRGB 仅为近似值)。将渲染意图设置为“相对比色”,并关闭“黑点补偿” 。
使用 Foxit 阅读器打印 PDF 文件
我们在使用 Inkscape 0.46 进行打印时遇到问题,因此开发了这种方法。
- 我们采用这种方法取得了非常好的效果,但如果您尝试这样做,您应该知道如何设置打印机驱动程序以执行颜色管理。
- 按照上述步骤 1-4 操作:安装 Inkscape,创建 SVG 测试图表,保存它,在 Inkscape 中打开它,选择图表图像,然后使用“文档属性”窗口设置页面和图像大小,并使用图表图像角落的控制柄设置图像大小。
- 单击“文件”,然后单击“另存为...”。在“保存类型”对话框中,选择“便携式文档格式 (*.pdf)” ,然后保存文件。
- 使用Foxit Reader等PDF阅读器打开文件。
- 点击“文件”、“打印…”或打印图标。右侧将显示对话框(以 Foxit Reader 为例)。
- 请确保尺寸和打印机驱动程序设置正确。右侧显示的设置仅供参考,实际情况可能有所不同。色彩管理需要由打印机驱动程序启用。右侧显示的是典型设置。然后单击“确定”。强烈建议您尽可能预览打印效果。
测量和校准图表
测量测试图表中的灰阶和色块的步骤在“测量测试图表色块”一节中给出。这些测量生成的 CGATS 文件可以被任何分析颜色或灰阶图表的 Imatest 模块读取,例如: Color/Tone Interactive 、 Colorcheck 、 Stepchart 、 Rescharts (SFRplus)或MultiTest 。










