图像统计是一个交互式实用程序,可用于检查图像的多个属性,包括
- 垂直和水平横截面厚度可调。增加厚度可以减轻噪声的影响。可以绘制像素级或一维傅里叶频谱。
- 矩形或正方形(吸管)区域的属性,包括矩形位置、R、G、B 和 Y(亮度)通道的平均值、Log 10 (平均值/最大值)、噪声(σ)、非均匀性校正噪声、SNR(信号/噪声)、SNR dB 和平均 L*a*b*(当已输入颜色空间时)。
- 面积大于 250 像素的矩形区域的直方图(主要为亮度通道:可包含 R、G 和 B 通道)。
- 横截面(1D)或大于 80x80 像素的矩形区域(2D)的线性或对数轴的傅里叶频谱。
- 包含空间像素级信息的3D 表面图( Imatest 5.2+ )
- 低于或高于指定值的点分别用蓝色和/或红色表示。
- 原始图像中各点之间的距离。
- EXIF 数据——存储在图像文件中的元数据
图像统计功能适用于任何图像,而不仅仅是测试图表。它有很多实用的应用,例如:
- 对于颜色/色调设置、颜色/色调自动和阶梯图,您可以确定图像的黑电平(像素)偏移量(添加到像素级别的固定数字)和饱和度级别。
- 应用黑电平偏移后,图像中可能会添加噪声。因此,最小像素电平可能与偏移量不符。直方图峰值是更好的指标。
- 饱和度通常是位深度对应的最大值:8 位(24 位颜色)为 255,16 位(48 位颜色)为 65535,但并非总是如此。我们见过一些 8 位图像,其饱和度在 220-235 左右就达到饱和(像素级不再随色块亮度增加而增加)。
您可以放大或调亮图像,以便查看原本可能忽略的细节。放大图像可以更轻松地选择狭小的矩形区域。它还可以限制横截面显示的范围(以便仅显示感兴趣的区域)。调亮图像不会影响数值结果。支持位深度为 8 位和 16 位的图像。
运行映像统计信息
可以从以下位置打开图像统计信息
- 实用工具菜单,
- 您可以从“文件”下拉菜单或右侧控制区域中未用于其他用途时出现的按钮,选择“Rescharts” 、 “颜色/色调设置”或“均匀性交互式”选项。
- 从“分析”下拉菜单中选择“图像处理” 。如果同时存在输入图像和输出图像,则可以快速切换这两个图像进行比较。
打开图像统计信息会弹出以下窗口。图像下方显示了简要说明。
窗口会显示未裁剪的图像,并保持其原始亮度(除非在之前的运行中更改过)。文件名位于顶部,左侧是控制区域。在执行图像分析之前,您可以执行以下几项操作。
- 您可以使用“调整大图像大小”下拉菜单(左上角)对图像进行降采样,从而加快运算速度(尤其是横截面分析)。建议选择设置1:不调整大小或2:调整大图像大小 (imresize) 。如果需要分析噪声或频谱,则不建议进行降采样。通常不建议使用设置 3 及更高版本(通过跳过像素来调整大小)。这些设置曾被用于诊断一些异常的去马赛克行为。
- 您可以通过点击并拖动鼠标来缩放图像。您可以通过点击“全屏视图”(缩小)或双击图像(但双击并非总是有效)来恢复图像原状。这可以更轻松地选择小的矩形区域或限制横截面的范围,例如,您可以观察深阴影中的物体行为。
- 您可以通过点击左上角的下拉菜单(上方显示“原始图像”)来更改图像外观,例如提亮、增加饱和度、调整色调等等。选项显示在右侧。提亮图像(有多种方法)可以让您看到在暗图像中不可见的阴影细节。更改图像外观不会影响任何数值或图形分析结果。
- 您可以点击“显示像素 < 或 > 设置级别”面板中的相应设置,将低于设定值的像素显示为蓝色,高于设定值的像素显示为红色。将复选框设置为 0 可实现正常显示。
图像外观选择。它们不会影响数值结果。
当选择除“原始图像”以外的任何图像时,背景将显示为黄色。
下图为放大并提亮后的图像,其中像素值低于 4(满分 255)的像素显示为蓝色,高于 252 的像素显示为红色。在执行横截面、矩形/吸管等操作时,图像缩放比例保持不变。点击“全屏视图”(缩小)即可查看完整图像。

横截面
在“横截面”面板中,按下“X 横截面”或“Y 横截面”按钮即可启用十字线,用于选择水平或垂直横截面。您只需在图像中单击一个点即可选择所需的横截面,该横截面将显示在两条红线之间(如下图所示,垂直线位于图像中心左侧)。在横截面模式下,拖动鼠标无效。单击图像外部的点(但不要单击已激活的按钮或文本)或按 Esc 键可关闭十字线并返回正常模式。请注意,在横截面模式下,大多数按钮将被禁用或隐藏。您需要在按下“X横截面”或“Y 横截面”按钮之前进行设置。(当然,您可以随时更改设置。)
建议在按下横截面按钮之前,先放大图像(相当于裁剪图像)。

该文件的位深度为 16,比位深度为 8 的文件显示更多阴影细节。
通过观察垂直截面图(采用对数y轴),我们能够了解该图表/相机组合在极暗区域的表现,而这在肉眼下很难实现(我们观察到短距离的耀斑光会影响结果)。相对较宽的线条有助于降低深阴影区域的高噪声。
横截面设置横截面选择和绘图有多种选项。
- “线宽 (Line W)”下拉菜单允许您选择横截面的宽度。设置值包括 1、3、5、7、9、11、13、15、21 或 25 像素。增加默认值 1 的值可以降低噪声(宽度每增加一倍,噪声降低 3 dB)。通常情况下,应在感兴趣的特征范围内尽可能增大线宽。横截面宽度包含在两条垂直或水平红线之间。
- “平滑 (Sm)”下拉菜单允许您选择使用 1、3、5、11 或 15 像素的矩形核进行平滑处理。这可以进一步降低噪声。请注意,平滑处理会在傅里叶频谱中 1/Sm(周期/像素)处产生一个零点:下图显示了当 Sm = 3 时,零点为 0.333 C/P。
- “绘图类型”下拉菜单允许您在三个像素横截面图(1-3)和六个一维 (1D) 傅里叶频谱图(4-9;Imatest 2021.2 版本新增)之间进行选择。一维频谱图对于倾斜边缘尤为重要,其导数(图 7-9)对应于边缘扩展函数,如下所示。二维傅里叶频谱图位于“矩形分析”中,如下所示。选择项显示在右侧。
- y(纵轴)下拉菜单允许您选择:(1)线性 y 轴,(2)以10 为底的对数 y 轴(未归一化),或(3)以10为底的对数 y 轴(已归一化)。当在“绘图类型”中选择像素横截面图时启用(傅里叶频谱图禁用)。具体选择取决于应用场景:上图的步长为对数(由密度单位定义),因此选择了以10为底的对数 y 轴。
横截面图
(1)绘制 RGBY(等权重)
(2)绘制 RGBY(Y 轴强调)(默认;推荐横截面)
(3)仅绘制 Y(亮度)图。
(4)|傅里叶频谱(Y)|线性(1D)
(5)|傅里叶频谱(Y)|对数-对数(1D)
(6)|傅里叶频谱(Y)|半对数Y(1D)
(7)|傅里叶频谱(Y 导数)|线性(1D)
(8)|傅里叶频谱(Y 导数)|对数-对数(1D)
(9)|傅里叶频谱(Y导数)|半对数Y(1D)

该图类似于边缘MTF图,但对噪声更为敏感。Sm = 3 会导致零点位于 0.333 C/P 处。
矩形/滴管分析
此分析功能允许您检查矩形区域(通过单击并拖动鼠标选择)或方形吸管区域(通过单击鼠标选择,无需拖动)的多个属性。您可以查看基本统计信息,包括均值、噪声(未进行和已进行非均匀性校正)、CIELAB L*a*b* 值等。或者,您可以查看区域的直方图或频谱图。单击图像外部即可关闭矩形/吸管选择功能。矩形和结果将保持可见,直到进行下一次选择。以下是设置说明。
| 选拔 | 测量 |
| 标准统计 | 矩形的位置、大小和对角线长度 RGBY 平均值、噪声(校正和未校正)、信噪比、CIELAB L*a*b* 值。 注意:RMS噪声与标准偏差( σ )相同。 |
| 直方图(Y)全 x 轴 直方图(Y)扩展 x 轴 直方图(Y轴)+RGB全轴 直方图(Y)+RGB 扩展 x 轴 | 以柱状图形式显示亮度 (Y) 通道的log10 (出现次数+1) 直方图。最小区域大小 = 250 像素。均值用菱形 ◊(Y 通道)和星号* (R、G 和 B 通道)显示。 完整的 x 轴是图像的最小值到最大值(0 到 1、255 或 65535,具体取决于图像来源和位深度)。 “扩展 x 轴”选项使用数据的上下限来确定 x 轴。“+RGB”选项会在直方图中添加 RGB 通道的阶梯图。示例如下。 |
| 傅里叶频谱线性(>80x80) 傅里叶频谱对数-对数(>80x80) 傅里叶频谱符号学(>80x80) | 绘制区域的二维傅里叶频谱图,横坐标可以是线性坐标(x轴和y轴),纵坐标可以是对数坐标(x'轴),横坐标可以是半对数坐标(x轴线性,y轴对数)。最小区域尺寸为80x80像素。这对于像“散落的硬币”这样的图案尤为重要,因为这类图案的设计目标是获得1/ f的二维傅里叶频谱。示例如下。 |
| 3D曲面图(慢速) 3D曲面图(额外平滑处理) | 3D 图,显示像素级别随 x、y 坐标的变化。可旋转。选择新区域前必须先关闭再重新打开。警告:处理大型图像时速度可能非常慢。建议先缩放(裁剪)图像。额外平滑处理速度会稍快一些(但仍然可能较慢)。 |
| 二维码(如果显示URL则打开) | 2021.2 新增功能:读取二维码或条形码。我们建议您先放大(裁剪)图像,尤其是在图像包含多个二维码或条形码的情况下。如果代码包含网址,则会打开相应的网页。 |
其他设置包括
- 吸管大小。设置值分别为 1、3、5、7、9、11、13、15、21 或 25(边长以像素为单位)。
- 用于计算 CIELAB L*a*b* 值的色彩空间(下拉菜单)。提供最常用的色彩空间:默认为 sRGB(Windows/互联网标准)。
标准统计

直方图

从图中可以明显看出,随着曝光指数的增加,噪声发生了变化。
傅里叶变换/频谱

使用高品质手机摄像头在 900 勒克斯(强光;低噪点)下拍摄。
图中用一条细黑虚线表示了数据曲线(数据点下三分之一)指数的一阶对数拟合结果。对于这种模式,拟合值与频率成正比-0.989 。原始图表的设计目标是获得一个尺度不变的 1/f (频率-1 ) 频谱——与拟合结果非常接近。图像未进行降采样,即“调整大图像大小”选项未勾选,这会影响结果。
该图可让您快速观察任何图像的频谱。
- 您可以查看各种枯叶图和(Imatest)散币图的高质量图像。我们发现,Imatest散币图的指数非常接近-1,这确保了真正的尺度不变性。其他市售枯叶图的指数则更接近0.9。
- 一个“平均场景”(如果真有神话般的存在的话*)的指数应该在-1左右。这是设计“枯叶与散落硬币”图表的部分依据(以及尺度不变性)。你可以查看任何场景(或场景的一部分)的光谱来验证这一点。
在科罗拉多州博尔德,很难找到一个“普通”的场景,因为这里的一切都高于平均水平(更不用说人了)。
(向加里森·凯勒致歉。)“高于平均水平”场景的光谱响应从未被研究过。这或许可以成为一个不错的博士论文选题。
三维曲面图(空间分析)
3D 曲面图( Imatest 5.2+ )显示所选区域的空间像素信息。要查看此图,请在“矩形分析”按钮正下方的下拉菜单中选择“3D 曲面图(标准或额外平滑)”,然后点击“矩形分析” ,再选择要显示的区域。您可以使用鼠标拖动来旋转该图。由于所选区域通常会被曲面图覆盖,因此会在左侧显示所选区域的副本。要分析不同的区域,请点击左侧的“恢复控制按钮和原始图像”按钮,然后再次点击“矩形分析” 。(这与其他矩形分析略有不同,在其他矩形分析中,您可以直接选择新区域。)
三维曲面图,显示像素级别随位置的变化
对于随机噪声低但量化噪声明显的 8 位(256 级)图像
此图显示了空间信息。在本例中,我们可以清楚地看到有限的数字电平数(0-255)如何影响噪声测量。
其他控制
全屏视图(缩小)恢复原始全图像视图:它会缩小图像(双击通常不起作用)。
数据光标功能允许您在点击图像时显示数据光标。右侧示例展示了此功能。点击数据光标(切换按钮,激活时背景为黄色)即可启用或禁用此功能。右键点击数据光标即可将其移除。
EXIF会在图像下方显示选定的 EXIF 数据(文件中包含的元数据)。要查看完整的 EXIF 数据,请使用“文件”下拉菜单(必须安装并选择Phil Harvey 的 EXIFtool )。
文件下拉菜单允许您从剪贴板粘贴图像、查看所有 EXIF 数据、保存/显示屏幕或关闭程序。
图片下拉菜单包含多个实用工具。大多数工具的功能都一目了然。我们建议您尝试一下。

