Imatestが失敗した場合の対処法
事故報告
Imatestがクラッシュし、明らかな解決策がない場合は、クラッシュを弊社にご報告いただくことを強くお勧めします。クラッシュを報告する方法は2つあります。
1. エラー報告ウィンドウを使用してクラッシュレポートを送信します。
ほとんどのエラーでは、下図に示すエラー報告ウィンドウが開きます。

| 以前は正常に動作していたモジュールが、現在は動作しなくなった場合に、多くのエラーが発生します。このようなエラーは、INI ファイル (imatest-v2.ini) から該当モジュールに対応するセクションを削除することで解決できる場合が多くあります。この手法については、以下で簡単に説明し、 「以前は正常に動作していたモジュールが動作しなくなった」でより詳しく説明します。 |
Imatestの実行を妨げるエラーが発生し、簡単に解決できない場合は、 「エラーレポートを送信」ボタンを押してエラー内容を弊社までお送りください。このボタンを押すと、メールアドレス(弊社からの連絡用)とエラーの説明を入力できるウィンドウが開きます。入力後、このウィンドウで「エラーレポートを送信」ボタンを押してください。

画像の解析中にエラーが発生した場合は、画像を弊社までお送りください。Imatestヘルプセンターで作成したチケットに画像を添付していただくのが最も簡単です。画像の不備やフレーミング不良が原因で発生するエラーを迅速に特定できます。説明書をよく読んでおくことは決して無駄ではありません。
画像の解析中にエラーが発生した場合は、画像を弊社までお送りください。最も簡単な方法は、 Imatestヘルプセンターで作成した問題に画像を添付することです。不適切な画像やフレーミングの悪い画像が原因で発生するエラーを迅速に特定できます。説明書をよく読んでおくことは決して無駄ではありません。 画面キャプチャ画像(右側に表示)を送信するよりも、上記の手順に従ってエラーレポートを送信する方がはるかに効果的です。画面キャプチャには、問題の診断に必要な情報がすべて含まれているわけではありません。英語を話さないお客様は、この点で苦労することがよくあります。(右側に中国語のウィンドウが表示されています。)エラーを報告するには、赤い楕円で囲まれた下中央のボタンを押してください。 |
2. コピーして貼り付け、 Imatestヘルプセンターに送信してください。
この方法は、上記に示したエラー報告ウィンドウが開かないという、まれなエラーの場合にのみ使用してください。
- Imatestで、 「ファイル」 → 「現在のセッションをコピー」を選択します。これにより、エラーメッセージを含むセッションの内容がクリップボードにコピーされます。
- Imatestヘルプセンターに問い合わせをしてください。概要欄に問題の内容を説明し、クリップボードの内容を説明欄に貼り付けてください。
- あなたが
- imatest-v2.ini ファイルを問題に添付してください。ファイルの場所は、 [ファイル] 、 [INI ファイルフォルダを開く]を押すと確認できます。
- または - - INIファイルの内容は、 「INIファイル」 → 「Imatest設定のコピー」 →「atta」の順に押してクリップボードにコピーしてください。セッションテキストとは明確に区別されていることを確認してください。
- imatest-v2.ini ファイルを問題に添付してください。ファイルの場所は、 [ファイル] 、 [INI ファイルフォルダを開く]を押すと確認できます。
クラッシュによってImatestウィンドウが閉じてしまった場合は、コマンド (DOS) ウィンドウ(下記)でエラーを報告するための追加の手順があります。
バージョン
可能であれば、最新のImatestバージョンを実行することをお勧めします。ライセンスで許可されている最新バージョンを常に実行してください(購入日から1年以内のバージョンをアクティベートできます。変更履歴を参照してください)。新しいバージョンには、以前のバージョンで見つかったバグの修正と機能強化が含まれています。
バージョン番号はメインウィンドウの上部バーに表示され、ビルド日(ベータ版を使用している場合に特に重要)は「ヘルプ」 →「バージョン情報」を選択すると表示されます。お使いのバージョンが変更履歴に表示されている最新バージョンよりも古い場合は、最新バージョンをダウンロード、インストール、実行することをお勧めします。通常、以前のバージョンをアンインストールする必要はありません。
Imatest が動作しなくなった場合、多くの場合、問題は imatest-v2.ini ( Imatest 4.2より前のバージョンでは imatest.ini) のエントリの誤りです。これについては後述します。Imatestをアンインストールしても、問題解決にはほとんど役立ちません。再インストールしても、システム ファイルが欠落しているようなまれなケースでのみ効果があります。Imatest -v2.ini の問題は、常に最初に解決する必要があります。ユーティリティメニューからを開くと、以下のウィンドウが開きます。このウィンドウには、エラーの対処方法に関する簡潔な説明と、直接リンクが表示されます。

エラー報告とトラブルシューティングのウィンドウには、簡潔な手順と直接リンクが記載されています。
インストール
通常、アップデートのインストールでは以前のバージョンのアンインストールは必要ありませんが、問題が発生した場合は、Imatest をアンインストールして再インストールすることをお勧めします。アンインストーラーは、スタート メニュー (スタート、すべてのプログラム、Imatest、アンインストール) またはコントロール パネルの[プログラムの追加と削除] からアクセスできます。アンインストーラーでは、Matlab ランタイム ライブラリ アーカイブ (バージョン 3.6 より前のバージョンではImatest-lib.exe ) を保持するか削除するかを選択できます (保持がデフォルトです。削除するには、チェックボックスをオンにする必要があります)。保持しておくと、再インストールが速くなります。Imatest を再インストールする予定がない場合、または破損している可能性があると疑われる場合 (まれなケース) にのみ削除してください。インストール手順の詳細については、こちらをクリックしてください。
Imatest 3.6+ の重要な変更点
Imatestの最新バージョンは64ビットコンピュータでのみ動作します。Matlabのバージョン履歴はWikipediaに記載されていますが、一部欠落している箇所があります。
Imatest バージョン 3.6 以降では、旧バージョンの R13 コンパイラ (バージョン 3.0.1) に代わり、新しい Matlab コンパイラ (バージョン 4.11 以降) が使用されています。新しいコンパイラでは、約 200MB のMatlab Compiler Runtime (MCR) (一種の仮想マシン) という、より大規模なライブラリのダウンロードが必要です。Imatestは通常 32 ビット アプリケーションとしてコンパイルされ、32 ビットおよび 64 ビットのコンピュータで動作します。(64 ビット アプリケーションはパフォーマンス上の利点はほとんどなく、32 ビット コンピュータでは動作しません。)
| イマテスト バージョン | コンパイラ/ライブラリ | 一般的な場所(64ビット英語版インストール時の環境変数とファイル名) [32ビットコンピュータの場合は、C:\Program FilesをC:\Program Files (x86)に置き換えてください。] |
| 2020.2 | R2020a 9.8 | |
| 2020.1 | R2019b 9.7 | |
| 5.2 | R2019a 9.6 | |
| 5.1 | R2017b 9.3 | |
| 3.10、4.0+ | コンパイラ 4.18 V81 | %ProgramFiles%\MATLAB\MATLAB Compiler Runtime\v81 [C:Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v81] |
| 3.7~3.9 | コンパイラ 4.14 V714 | %ProgramFiles%\MATLAB\MATLAB Compiler Runtime\v714 []C:Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v714 |
| 3.6 | コンパイラ 4.11 V711 | %ProgramFiles%\MATLAB\MATLAB Compiler Runtime\v711 [C:Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v711] |
| 3.6以前 | コンパイラ3 | %ProgramFiles%\Imatest\toolbox\matlab [C:Program Files (x86)\Imatest\toolbox\matlab] |
| 注:MATLABの命名規則は非常に紛らわしい場合があります。例えば、MATLAB R2010b (7.11) は、MATLABコンポーネントランタイム7.14とコンパイラ4.14を使用しています。詳細は、 http://www.mathworks.com/support/solutions/en/data/1-4GSNCF/ ?solution=1-4GSNCF を参照してください。 | ||
インストールが完了したら、
- MCR は、32 ビット システムでは %ProgramFiles%\MATLAB\MATLAB Compiler Runtime\v714 (Imatest 3.7 以降の場合。3.6 の場合は ...V711) に、64 ビット システムでは %ProgramFiles(x86)%\MATLAB\MATLAB Compiler Runtime\v714 (または ...V711) に配置されます (英語の Win64 インストールでは %ProgramFiles(x86)% は C:Program Files (x86) です)。
- Imatest は、32 ビット システムでは %ProgramFiles%\Imatest\Imatest にあります (英語の Win32 インストールでは %ProgramFiles は C:\Program Files です)。64 ビット システムでは %ProgramFiles(x86)%\Imatest\Imatest にあります (英語の Win64 インストールでは %ProgramFiles(x86) は C:\Program Files (x86) です)。
新しいライブラリ(V7111、V714など)を使用してImatest 3.6以降を初めてインストールする場合は、 「コンポーネントの選択」ウィンドウで「Matlabライブラリ」がチェックされていることを確認してください。ライブラリのインストールには数分かかります。お使いのバージョンに適したMCRがインストールされたら、 Imatestをアップデートする際にこのチェックボックスをオンにする必要はありません。
MCRをインストールする前にImatestを実行しようとすると、次のメッセージが表示される場合があります。Matlabライブラリのチェックボックスをオンにして再インストールすると、問題は解決します。
mclmcrrt714.dll が見つからなかったため、このアプリケーションは起動できませんでした。
インストール中に問題が発生しました
インストールまたは登録が失敗する可能性がある場合
- お使いのコンピューターには管理者権限がありません。管理者権限がない場合、次のようなメッセージが表示されることがあります。
書き込み用のファイルを開く際にエラーが発生しました C:\Program files(x86)\Imatest\Master\imatest.exe
書き込み用のファイルを開く際にエラーが発生しました。C:\Program files (x86)\Imatest\Master\dcraw.exe など。 - お使いのコンピューターは、強力な企業ファイアウォールの内側にあります。
| バージョン3.6以前:このメッセージは、ファイアウォールが強力なシステムで時折表示されます。通常は、ダウンロードページから入手できるMatlabランタイムライブラリ「Imatest-lib.exe」がImatestのインストールファイルと同じフォルダにあることを確認することで解決できます。場合によっては、ファイアウォールを一時的に無効にして、ライブラリファイルを手動でダウンロードする必要があるかもしれません。 | ![]() |
| 強力なファイアウォールが原因で発生した別のエラーメッセージを以下に示します。お客様は自宅からダウンロードした際には問題なく動作していました。解決策:オフィス外でImatestをダウンロードし、CDまたはUSBメモリをオフィスに持参してください。 | ![]() |
「DNS エラー」の表示が出た場合 (非常にまれです)、 、[ファイル名を指定して実行]をクリックし、 [開く]ボックスにipconfig /flushdnsと入力して、 ] をクリックしてください。
インストール後に発生する問題
エラー: MCR のバージョン mn が見つかりませんでした。
このエラーは、MCR (Matlab Compiler Runtime、つまりライブラリ) のインストール失敗、またはImatestを実行するバッチファイル内のパスの問題が原因である可能性があります。これは、 Imatest 3.7 および 3.8 の初期ビルドで発生する可能性が最も高いです。
- このバージョンのImatest を初めてインストールした際に、Matlab ライブラリが正しくインストールされませんでした。コンポーネントの選択ウィンドウでMatlab ライブラリにチェックを入れて、 Imatest を再インストールする必要があります (通常は最初のインストール時に一度だけ実行すれば十分です)。この方法でもうまくいかなかった顧客が MCR (ライブラリ) フォルダ (場所については下記およびこちらを参照) を削除し、この手順を繰り返したところ、正常に動作しました。
-
MCRのインストール時に、システムに保留中のWindowsアップデートがありました。インストールを再度実行する前に、すべてのアップデートが完了していることを確認してください。 - Imatest が、別のバージョンの Matlab がインストールされているシステムにインストールされています。(これはまれにしか問題になりません。)ご使用のバージョンの Imatest を実行するために使用するフォルダ内のバッチファイル (run_imatest.bat と run_diagnostics.bat) を確認し、パスが正しい MCR の場所を指していることを確認してください。
一般的な64ビット版Windows 7(英語版)の場合、 ImatestのインストールフォルダはC:\Program Files (x86)\Imatest\Masterです。このフォルダは、 Imatestのバージョン、オペレーティングシステム、言語によって異なる場合があります。ご使用のシステムでフォルダの場所をご確認ください。
パスは、 Imatestインストールフォルダ内のファイル run_imatest.bat (または run_diagnostics.bat) で設定されています。変更を保存するには、管理者権限でファイルを開く必要があります。パス情報を含む重要な行 (私のシステムの場合) は次のとおりです。
@path="C:Program Files (x86)\Imatest\Master_3.8;C:Program Files (x86)\Imatest\Master_3.8bin; C:Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v714runtimewin32 ; C:Program Files (x86\)MATLAB\MATLAB Compiler Runtime\v714 ;%path%"
この行で強調表示されている項目は、Matlab Compiler Runtime (MCR) フォルダーです。これらのフォルダーの内容を確認してください。フォルダーC:\Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v714 (またはシステム上の同等のフォルダー) がこの行にない場合 (Imatest 3.8 より前のバージョンでのみ発生する問題)、追加する必要があります。
3.6: 「mclmcrrt711.dll が見つからなかったため、このアプリケーションは起動できませんでした」のようなメッセージが表示された場合は、 Matlab ランタイムライブラリ (MCR) を含むフルバージョンをダウンロードしてインストールする必要があります。Imatest 3.6では、この操作は一度だけ行えば済みます。ダウンロードとインストールにはそれぞれ数分かかる場合があります。アップグレード版のダウンロードとインストールははるかに高速です。
3.6+: mllapack.dll プロシージャが見つかりません( mllapack.dll La procédure spécifiée est introuvable en Français) Imatest は正常に起動しますが、このメッセージがボックスに表示されて終了します。この問題は 2 回発生しました。原因を特定するのは容易ではありませんでした。ある顧客に対しては有効だった (ただし、多少の手間がかかった) 解決策が、 この Google の投稿の最後とこの Matlab Central の投稿で見つかりました。
「予想通り、エラーの原因はDLLのバージョン問題でした。古いバージョンの「libmmd.dll」がwindows/system32ディレクトリに存在していました。MATLABランタイムのbin/win32ディレクトリに含まれているバージョンは使用されていませんでした。古いバージョンを削除したところ、問題は解決しました。なぜそこに存在していたのか、またvcredistのインストール時にwindowsディレクトリで更新されない理由はまだ解明できていません。本当に面倒です。」
もしこれがうまくいかない場合は、もう一つ試してみる価値のあるアドバイスがあります。 このMATLABの投稿には、「クラッシュはMATLABとCPUの互換性の問題が原因です。これは、プロセッサがSSE2命令セットをサポートしていない場合(例えば、Athlon XP 2200+ CPUなど)に発生する可能性があります。」と書かれています。この問題は、2003年以降に製造されたコンピュータでは発生しないはずです。
3.6 以前:最も一般的なインストール問題は、Matlab ランタイム ライブラリImatest-lib.exeのダウンロードまたはインストールが正しく行われないことです。その結果、次のようなエラー メッセージが表示されます。
「プロシージャのエントリポイントがダイナミックリンクライブラリ….dll内で見つかりませんでした。」
このようなメッセージが表示された場合は、 Imatest-lib.exeファイルが正しくダウンロードされているか確認してください。また、ファイアウォールの状態も確認してください。強力なファイアウォールがこの問題の原因となっている場合があります。
- インストール中に自動的にダウンロードされた場合は、Imatest のインストールフォルダ(一般的な Win32 英語版のインストールでは C:\Program files\Imatest\Imatest)にコピーが存在するはずです。
- 手動でダウンロードした場合(ファイアウォールのあるシステムでは通常必要です)、Imatestインストーラープログラムと同じフォルダにコピー(Imatest- xx.exe )が存在するはずです。
Windows XPのエクスプローラーではファイルサイズが8,513KBと表示されますが、ファイル名にカーソルを合わせると表示されるツールチップでは8.31MBと表示されます(不思議ですね)。ダウンロードが失敗した場合は、より小さいサイズが表示されることがあります。
Imatest-lib.exe が見つからない場合、またはダウンロードが正しく行われなかったと思われる場合は、ここまたはこのセクションのいずれかのリンクを右クリックしてダウンロードし、Imatestを再インストールしてください。Imatest-lib.exe は自己解凍型の zip ファイルで、Matlab ランタイム ライブラリを Imatest インストール フォルダーのサブフォルダー binwin32 および toolbox\matlab に配置します。問題が解決しない場合は、これらのフォルダーにファイルが格納されていることを確認し、DOS ウィンドウに表示されるエラー メッセージ(存在する場合)を添えてImatest サポートにメールを送信してください。
- Imatest 3.1以降では、4つのファイルはImatestのインストールフォルダとサブフォルダの両方にインストールされます。これらのファイルが見つからない場合は、サブフォルダ(toolbox\matlab\iofun\private、英語版インストールの場合はC:\Program Files\Imatest\toolbox\matlab\iofun\private)にコピーしてください。
- 以前のバージョンについては、 jpegdlls.zipをダウンロードして、その内容をサブフォルダにコピーしてください。
実行時エラー
画像ファイルが読み取れません。
Matlabは、標準以外のヘッダーを持つ画像ファイルや、ファイル拡張子が間違っている(例えば、PNGファイルなのにBMPになっているなど)といったその他の不具合のある画像ファイルを読み込めないことがよくあります。このようなファイルは市販のカメラではまれですが、プロトタイプや開発システムでは発生する可能性があります。Irfanviewを使えば、多くの場合、これらのファイルを「修正」できます。IrfanviewはIrfanview.comから無料でダウンロードできます。非常に便利なユーティリティです。ファイルをIrfanviewに読み込み、保存してください。(元のファイルを保持する必要がある場合は、別のファイル名を使用できます。)
地域選択を行った後、Imatestが動作を停止する(フリーズまたはクラッシュする)。
この問題は、Youdao Dictionaryなどの自動翻訳ソフトウェアが原因である可能性があります。
解決:
ROI選択中は、翻訳ソフトウェアを一時的に無効にしてください。この問題に関する詳細は、「領域選択バグの回避策」をご覧ください。
Imatestがクラッシュするか、期待どおりに動作しない
この場合、通常は最小化されているコマンド(DOS)ウィンドウに、デバッグに役立つエラーメッセージが表示されることがあります。その内容を表示するには、
- Imatestコマンドウィンドウのアイコンをクリックします。
タスクバーに。 - 「ファイル」 → 「現在のセッションを表示」をクリックすると、セッションの内容がエディタ(通常はメモ帳)で開きます。また、 「ファイル」 → 「現在のセッションをコピー」をクリックして、任意のエディタに貼り付けるか、 Imatestサポートに問い合わせることもできます。
- Imatest が完全にクラッシュして終了した場合は、再起動してから、 [ファイル] 、 [表示] (または[コピー] ) 、[最後のセッション]をクリックします。
ほとんどの問題は、以下のカテゴリーに分類されます。
- バグが見つかりました。多くのバグは、最新バージョンのImatestをダウンロードしてインストールすることで修正できます。それでも解決しない場合は、上記のコマンドウィンドウの内容、必要に応じてINIファイルとイメージを添えて、ヘルプセンターに問題を報告してください。詳細はこちらをご覧ください。
- 保存された設定を保存するファイルであるImatest-v2.ini ( Imatest 4.2より前のバージョンでは imatest.ini) が破損し、読み取れなくなりました。説明と修正方法については、下記の「破損した INI ファイル」を参照してください。
- 以前は正常に動作していたモジュールが動作しなくなりました。これは多くの場合、Imatest-v2.ini ファイルの該当モジュールに対応するセクションに誤ったエントリがあることが原因です。詳しくは、「以前は正常に動作していたモジュールが動作しなくなりました(下記)」を参照してください。
Imatest 3.7+ではimatest-v2.iniの正確な場所を知る必要はありません。Imatestには、その場所を特定、編集、保存、読み込むためのユーティリティ一式が備わっているからです。正確な場所は次のとおりです。
$APPDATA$\Imatest\imatest-v2.ini
ここで、$APPDATA$ は、Windows Vista/7 (英語) の C:Users user_name\ AppData\Roaming に相当する環境変数です。英語の Vista/7-10 における imatest-v2.ini の完全なパス名は、C:Users\ user_name\ AppData\Roaming\Imatest\imatest.ini です。他のオペレーティングシステムや言語では、名前が異なる場合があります。
破損したiniファイルこのエラーは、Imatest 4.2 より前のバージョンで、非ラテン文字 (中国語、韓国語、日本語、ヘブライ語など) を含むフォルダやファイルが存在するシステムで時折発生していましたが、Imatest 4.2 では完全に修正されています。DOS ウィンドウに表示される典型的なメッセージは次の形式です。 キーのファイル解析エラー: C:\Doc ... Imatest\imatest.ini: 508 行目で inifile>findkeys を使用した際のエラー この問題のほとんどは、2012 年 6 月 15 日以降にリリースされた Imatest 3.9+ のビルドで解消されています。これらの新しいビルドでは、ini ファイルに UTF-8 文字エンコーディングが使用されており、非ラテン文字を処理できるはずです。画面に表示される推奨事項に従って、修復手順を一度実行する必要がある場合があります。問題が再発した場合 (これは非常にまれなケースです)
Imatestバージョン3.7より前のバージョンでこの問題が発生する場合は、以下のINI ファイル修正の手順に従ってください。 Imatest 3.7以降の場合、以下のいずれかのウィンドウが開きます。 Imatest 3.7 で、imatest.ini メッセージ (2 行目) が破損しています。 このメッセージは、2行目にエラーがあることを示しています。 を押すと、iniファイルがメモ帳で開きます。問題のある行を削除または修正し(下記の説明を参照)、ファイルを保存してください。メモ帳を閉じて、 Imatestを再起動してください。 ![]() このメッセージは、26行目にエラーがあることを示しています。OKを押すと、破損した行を検出し、内容を確認してから修正したファイルを保存できる特別なエディタが開きます。
INIファイルのスキャンと修復ウィンドウ。Imatest 3.8以降で解析エラー発生後に表示されます。 INIファイルの修正: Imatest.ini (およびrescharts.ini、multicharts.iniなど)には、Imatestの実行時に使用される保存済み設定が含まれています。これらのファイルは、Imatestが最初に実行されたときに作成されます。設定には、関心領域(ROI)、プロットの選択、プロットのスケール、計算手法などが含まれます。 iniファイルは、各行が次のようにフォーマットされたテキストファイルです。
行がこの構造に準拠していない場合、エラーが検出されます。最も一般的な原因は、等号 (=) が欠落していることです。エラー メッセージが表示された場合は、上記の「スキャンと修復」ウィンドウの指示に従ってください。
根本原因は?問題はロケール設定に関連していると思われます。MATLAB プロセスがロケール設定をどのように使用するかについては、以下を参照してください。
国際化とI18nメッセージおよび設定のトラブルシューティングも参照してください。そこには次のような興味深い記述があります。「Microsoft Windowsプラットフォームでは、ユーザーロケールとシステムロケールは同じ値である必要があります。これらの値が一致しない場合、文字化けや誤った文字が表示される可能性があります。」 |
バージョン 3.7 以前: Imatest がクラッシュし、「ERROR: Error in parsing the file for keys: C:」のようなメッセージが表示される場合、imatest.ini が破損しています。標準の ini ファイル形式に対応していないテキストが含まれている可能性があります。imatest.ini (場所は以下のとおり) を開いて、問題のあるコードを削除する必要があります。問題のあるテキストが見つからない場合は、削除 (または名前を変更) してください。iniファイルが破損していると思われる場合は、いくつかの対処法があります。
|
以前は正常に動作していたモジュールが動作しなくなりました
| この手法の詳細な説明(破損した設定が含まれている可能性のあるINIファイルセクションを削除する方法)は、 以前は正常に動作していたモジュールが動作しなくなりました。 |
これは多くの場合、imatest-v2.ini( Imatest 4.2より前のバージョンでは imatest.ini、rescharts.ini、または multicharts.ini)内のモジュールのセクションを削除することで解決できます。
INIファイル設定、 INIファイルエディタの順にクリックして、下図に示すINIファイルエディタを開きます。注:Imatestを再インストールしても、この種の問題が解決することはほとんどありません。

iniファイルエディタは、ini(設定)ファイルを編集するための非常に強力なツールです。
壊れた(ただし以前は動作していた)モジュールは、次のセクションを選択することで修復できる場合が多いです。
モジュールに対応して、クリックします。
セクションドロップダウンメニュー(上部付近)から、表示または削除するセクションを選択できます。個々の行を編集するには、大きなウィンドウでその行を選択し、大きなウィンドウのすぐ上にある編集ウィンドウで変更を加えてから、Enter キーを押します。選択範囲全体を削除するには、[セクションのを押します。変更を保存する準備ができたら、 キーを押します(変更が反映されるまではグレー表示されています)。変更をキャンセルする場合は、 キーまたはキーを押します。
エラー処理と報告
問題が解決しない場合は、 Imatestサポートにメールを送信してください。送信方法の詳細は、ユーティリティメニューのをご覧ください。
- エラーメッセージを含めてください。通常、コマンド(DOS)ウィンドウに表示されます。(明らかに無関係な部分は編集で削除できます。)コマンドウィンドウの内容を取得するには、
- ファイルをクリックし、現在のセッションをコピーして、 Imatest ヘルプセンターで作成した問題に貼り付けます。
- Imatestが完全にクラッシュして終了した場合は、再起動してから、 [ファイル] 、 [最後のセッションのコピー]をクリックします。
- 旧バージョンの場合は、Imatestコマンドウィンドウのアイコンをクリックしてください。
タスクバーに表示されます。内容のコピー方法については、下の灰色の枠内をご覧ください。
- お使いのオペレーティングシステムを教えてください( Imatest 3.9以降では、コマンド(DOS)ウィンドウに含まれています)。
- 問題の診断に役立つ情報が含まれている可能性があるため、 imatest.ini ( Imatest 4.2より前のバージョンでは multicharts.ini または rescharts.ini) の内容を含めてください。Imatest 3.6以降では、 [INI ファイル設定] 、 [設定のコピー (ini ファイル)] をクリックすると、内容を直接クリップボードにコピーできます。 [INI ファイル設定] 、[設定の表示 (ini ファイル)]をクリックすると、テキストエディタ (通常はメモ帳) で内容を表示できます。
- エラーによって Imatest コマンド ウィンドウが閉じない限り、実際の ini ファイルのフォルダの場所を知る必要はありません。一般的な英語バージョンの Windows Vista/7 では、 C:\Users\ your name\ AppData\Roamingにあります。[ini ファイルは %AppData%\Imatest にあります。ここで %AppData% はコマンド環境変数であり、コマンド ウィンドウでdir "%AppData%"と入力するとファイル名を確認できます。]
- 画像に問題があると思われる場合(一部の画像は正常に表示され、一部は表示されない場合など)、その画像を問題報告に添付してください。
コマンド(DOS)ウィンドウImatest は通常最小化されたままのコマンド ウィンドウ (従来の DOS ウィンドウに似ています) から実行されます。実行が予期せず終了したり、停止したりした場合、コマンド ウィンドウにはデバッグに役立つ情報が含まれている可能性があります。コマンド ウィンドウの内容を表示またはコピーするには、 3.6以降:Imatestコマンド(DOS)ウィンドウからセッションを直接表示またはコピーできます。
バージョン3.6以前:手順1:テキストのコピー&ペースト(簡単だが、少しコツがいる)
バージョン3.6以前:手順2:画面ダンプ画像をコピー&ペーストする(複雑だが確実)
|
診断実行
Imatest エラーで DOS ウィンドウが閉じてしまう場合 (これはまれになっています)、または追加の診断結果が問題の特定に役立つ可能性がある場合、
- Imatestフォルダ(一般的なwin32英語インストールではC:\Program files\Imatest\Imatest)からDiagnosticsをダブルクリックしてImatestを実行します。
(またはdiagnostics.bat)。これにより、Imatestが終了した後もDOSウィンドウが開いたままになり、エラーメッセージを確認できます。 - 上記のエラー報告手順に従って、エラーメッセージをImatestサポートにメールで送信してください。
場合によっては、imatest-v2.ini を削除する(または名前を変更する。記録が残るため、名前を変更する方が良い)ことで問題を解決できます。手順はこちらをご覧ください。
他のバージョンのMATLABがインストールされている場合、パスの競合が発生します。
| Xプロシージャエントリポイント svDoubleSclarRemW は ダイナミックリンクライブラリlibmwservices.dll内にあります。 |
お使いのシステムに、 Imatest (6.5.1) で使用されているバージョンとは異なるバージョンのMatlab がインストールされている場合、パスの競合が発生し、同様のエラー メッセージが表示されるか、 Imatest が実行に失敗する可能性がごくわずかにあります。Imatestを起動するバッチ ファイルでパスが設定されるため、このような問題はめったに発生しません。パスの問題とその解決策については、 Imatest IT EXE の説明書を参照してください。
バグとか色々
バージョン3.6以前:データを保存しようとすると、DOSウィンドウに以下のメッセージが複数回表示されます。
関数「get_param」はスタンドアロンモードでは実装されていません。
これは保存された画像には影響せず、DOSウィンドウがバックグラウンドで表示されるため、ほとんど目立ちません。Matlabはこの問題について、今後のリリースで修正予定であることをこちらで説明しています。
詳細なドキュメント
Imatestの各モジュールに関する手順は、Imatestドキュメントページに記載されています。






