Imatest 테스트가 실패했을 때 해야 할 일
사고 신고
Imatest가 충돌하고 명확한 해결 방법이 없는 경우, 저희에게 충돌을 보고해 주시기 바랍니다. 충돌 보고 방법은 두 가지가 있습니다.
1. 오류 보고 창을 사용하여 충돌 보고서를 보내십시오.
대부분의 오류의 경우 아래 그림과 같은 오류 보고 창이 열립니다.

| 이전에는 정상적으로 작동했지만 현재는 작동하지 않는 모듈을 실행할 때 많은 오류가 발생합니다. 이러한 오류는 INI 파일(imatest-v2.ini)에서 해당 모듈에 해당하는 섹션을 제거하면 해결되는 경우가 많습니다. 이 방법은 아래에 간략하게 설명되어 있으며, "이전에 정상적으로 작동했던 모듈이 작동을 멈췄습니다" 문서에서 더 자세히 확인할 수 있습니다. |
Imatest 실행을 방해하는 오류가 발생했고, 쉽게 해결할 수 없는 경우, "오류 보고 보내기 " 버튼을 눌러 오류를 보내주시기 바랍니다. 이 버튼을 누르면 두 번째 창이 열리는데, 여기에 이메일 주소(연락을 위한 주소)와 오류 설명을 입력해 주세요. 입력 후, 해당 창에서 "오류 보고 보내기" 버튼을 누르시면 됩니다.

이미지 분석 중 오류가 발생하면 이미지를 보내주시기 바랍니다. 가장 쉬운 방법은 Imatest 고객 지원 센터 에서 티켓을 생성하고 이미지를 첨부하는 것입니다. 잘못된 이미지 또는 프레임으로 인해 발생하는 오류를 신속하게 찾아낼 수 있습니다. 사용 설명서를 읽어보는 것도 도움이 될 수 있습니다.
이미지 분석 중 오류가 발생하면 이미지를 보내주시기 바랍니다. 가장 쉬운 방법은 Imatest 고객 지원 센터 에 문제 보고서를 작성하고 이미지를 첨부하는 것입니다. 잘못된 이미지나 부적절한 구도로 인해 발생하는 오류를 신속하게 찾아낼 수 있습니다. 사용 설명서를 읽어보는 것도 도움이 될 수 있습니다. 오른쪽에 표시된 화면 캡처 이미지를 보내는 것보다 위에서 설명한 절차 에 따라 오류 보고서를 보내는 것이 문제 해결에 더 도움이 됩니다 . 화면 캡처 이미지에는 문제 진단에 필요한 모든 정보가 포함되어 있지 않으며, 영어를 사용하지 않는 고객은 이 과정에서 어려움을 겪는 경우가 많습니다. (오른쪽에는 중국어 창이 표시되어 있습니다.) 오류를 보고하려면 빨간색 타원 안에 있는 하단 가운데 버튼을 누르십시오. |
2. 복사하여 붙여넣은 후 Imatest 고객 지원 센터 로 보내주세요.
이 방법은 위에 표시된 오류 보고 창이 열리지 않는 드문 경우에만 사용해야 합니다.
- Imatest에서 [파일] > [현재 세션 복사]를 누르세요. 그러면 오류 메시지를 포함한 세션 내용이 클립보드에 복사됩니다.
- Imatest 고객 지원 센터에 문의를 제출하세요. 요약란에 문제를 설명한 다음, 클립보드 내용을 설명란에 붙여넣으세요.
- 다음과 같은 경우 도움이 될 수 있습니다.
- imatest-v2.ini 파일을 문제에 첨부해 주세요. 파일 메뉴 에서 INI 파일 폴더 열기를 누르면 해당 파일의 위치를 찾을 수 있습니다.
- 또는 - - [INI 파일] , [Imatest 설정 복사] , [첨부]를 차례로 눌러 ini 파일 텍스트를 클립보드에 복사하세요. 세션 텍스트와 명확하게 구분되도록 하십시오.
- imatest-v2.ini 파일을 문제에 첨부해 주세요. 파일 메뉴 에서 INI 파일 폴더 열기를 누르면 해당 파일의 위치를 찾을 수 있습니다.
만약 충돌로 인해 Imatest 창이 닫혔다면, 명령(DOS) 창 (아래 참조) 에서 오류를 보고하는 추가적인 절차가 있습니다.
버전
가능하면 최신 Imatest 버전을 실행해 보시기 바랍니다. 라이선스에 따라 항상 최신 버전을 실행해야 합니다(구매일로부터 최대 1년 이내에 출시된 버전을 활성화 할 수 있습니다. 변경 로그를 참조하십시오). 최신 버전에는 이전 버전에서 발견된 버그 수정 및 기능 개선 사항이 포함되어 있습니다.
버전 번호는 메인 창 상단 표시줄에 나타나며, 빌드 날짜(베타 버전을 실행 중인 경우 가장 중요함)는 도움말 > 정보 를 누르면 표시됩니다. 사용 중인 버전이 변경 로그 에 표시된 최신 버전보다 이전 버전인 경우, 최신 버전을 다운로드 , 설치 및 실행하는 것이 좋습니다. 일반적으로 이전 버전을 제거할 필요는 없습니다.
Imatest가 작동을 멈추는 경우, 문제는 종종 imatest-v2.ini( Imatest 4.2 이전 버전의 imatest.ini) 파일의 잘못된 항목 때문이며, 자세한 내용은 아래를 참조하십시오. Imatest를 제거해 도 문제가 해결되는 경우는 드물며, 재설치는 시스템 파일이 누락된 극히 드문 경우에만 도움이 됩니다. 따라서 항상 imatest-v2.ini 파일 문제를 먼저 해결해야 합니다. 유틸리티 메뉴에서 열면 아래와 같은 창이 나타나며, 오류 처리 방법에 대한 간략한 지침과 관련 링크가 제공됩니다.

오류 보고 및 문제 해결 창에는 간결한 지침과 바로가기 링크가 있습니다.
설치
일반적으로 업데이트 설치 시 이전 버전을 제거할 필요는 없지만 , 문제가 발생할 경우 Imatest를 제거하고 다시 설치하는 것이 좋습니다. 제거 프로그램은 시작 메뉴( 시작, 모든 프로그램, Imatest, 제거 ) 또는 제어판의 프로그램 추가/제거 에서 이용할 수 있습니다. 제거 프로그램에서는 MATLAB 런타임 라이브러리 아카이브(3.6 이전 버전에서는Imatest-lib.exe )를 유지할지 제거할지 선택할 수 있습니다. (기본값은 유지이며, 제거하려면 확인란을 선택해야 합니다.) 유지하면 재설치 속도가 빨라집니다. Imatest를 다시 설치할 계획이 없거나 파일이 손상되었을 가능성이 있는 경우(드문 경우임)에만 제거하십시오. 전체 설치 지침을 보려면 여기를 클릭하십시오.
Imatest 3.6+에서 중요한 변경 사항
최근 버전의 Imatest는 64비트 컴퓨터에서만 작동합니다. MATLAB 버전 기록은 위키피디아 에서 확인할 수 있지만, 일부 내용이 누락되어 있습니다.
Imatest 버전 3.6 이상에서는 기존의 R13 컴파일러(버전 3.0.1) 대신 새로운 MATLAB 컴파일러(버전 4.11 이상)를 사용합니다. 새로운 컴파일러를 사용하려면 약 200MB 크기의 MATLAB 컴파일러 런타임(MCR, 일종의 가상 머신)이라는 훨씬 더 큰 라이브러리를 다운로드해야 합니다. Imatest 는 일반적으로 32비트 애플리케이션으로 컴파일되며, 32비트 및 64비트 컴퓨터에서 실행됩니다. (64비트 애플리케이션은 성능 면에서 큰 이점이 없으며 32비트 컴퓨터에서는 실행되지 않습니다.)
| 이마스테트 버전 | 컴파일러/라이브러리 | 일반적인 위치 (64비트 영어 설치 시 환경 변수 및 파일 이름) [32비트 컴퓨터에서는 C:Program files (x86) 대신 C:Program Files를 입력하십시오.] |
| 2020.2 | R2020a 9.8 | |
| 2020.1 | R2019b 9.7 | |
| 5.2 | R2019a 9.6 | |
| 5.1 | R2017b 9.3 | |
| 3.10, 4.0+ | 컴파일러 4.18 V81 | %ProgramFiles%\MATLAB\MATLAB Compiler Runtime\v81 [C:Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v81] |
| 3.7-3.9 | 컴파일러 4.14 V714 | %ProgramFiles%\MATLAB\MATLAB Compiler Runtime\v714 []C:Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v714 |
| 3.6 | 컴파일러 4.11 V711 | %ProgramFiles%\MATLAB\MATLAB Compiler Runtime\v711 [C:Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v711] |
| 3.6 이전 | 컴파일러 3 | %ProgramFiles%\Imatest\toolbox\matlab [C:Program Files (x86)\Imatest\toolbox\matlab] |
| 참고: MATLAB의 명칭은 매우 혼란스러울 수 있습니다. 예를 들어, MATLAB R2010b(7.11)는 MATLAB 컴포넌트 런타임 7.14와 컴파일러 4.14를 사용합니다. 자세한 내용 은 http://www.mathworks.com/support/solutions/en/data/1-4GSNCF/?solution=1-4GSNCF 를 참조하십시오. | ||
설치가 완료되면,
- MCR은 32비트 시스템(영어권 Win32 설치 환경에서 %ProgramFiles%는 C:Program Files)에서는 %ProgramFiles%\MATLAB\MATLAB Compiler Runtime\v714(Imatest 3.7 이상 버전의 경우, 3.6 버전의 경우 ...V711)에, 64비트 시스템(영어권 Win64 설치 환경에서 %ProgramFiles(x86)%는 C:Program Files (x86))에서는 %ProgramFiles(x86)%\MATLAB\MATLAB Compiler Runtime\v714(또는 ...V711)에 위치해야 합니다.
- Imatest 는 32비트 시스템에서는 %ProgramFiles%\Imatest\Imatest(영어권 Win32 설치 환경에서 %ProgramFiles는 C:Program Files)에, 64비트 시스템에서는 %ProgramFiles(x86)%\Imatest\Imatest(영어권 Win64 설치 환경에서 %ProgramFiles(x86)은 C:Program Files (x86))에 있습니다.
새로운 라이브러리(V7111, V714 등)를 사용하여 Imatest 3.6 이상 버전을 처음 설치할 때는 '구성 요소 선택' 창에서 'Matlab 라이브러리'가 선택되어 있는지 확인해야 합니다. 라이브러리 설치에는 몇 분 정도 소요됩니다. 사용 중인 버전에 맞는 MCR이 설치되면 Imatest를 업데이트할 때 이 확인란을 선택할 필요가 없습니다.
MCR이 설치되기 전에 Imatest를 실행하면 다음과 같은 메시지가 나타날 수 있습니다. Matlab 라이브러리 상자를 선택하여 다시 설치하면 문제가 해결됩니다.
mclmcrrt714.dll 파일을 찾을 수 없어 이 애플리케이션을 시작하지 못했습니다.
설치 중 문제 발생
설치 또는 등록이 실패할 수 있는 경우는 다음과 같습니다.
- 컴퓨터에 관리자 권한이 없습니다. 관리자 권한이 없으면 다음과 같은 메시지가 표시될 수 있습니다.
C:Program files(x86)\Imatest\Master\imatest.exe 파일을 쓰기 위해 열려고 하면 오류가 발생했습니다.
C:Program files (x86)\Imatest\Master\dcraw.exe 등의 파일을 쓰기 위해 열려고 하면 오류가 발생합니다. - 귀하의 컴퓨터는 강력한 회사 방화벽 뒤에 있습니다.
| 3.6 이전 버전: 이 메시지는 방화벽이 강력한 시스템에서 가끔 나타납니다. 일반적으로 다운로드 페이지 에서 구할 수 있는 MATLAB 런타임 라이브러리인 Imatest-lib.exe 가 Imatest 설치 파일과 같은 폴더에 있는지 확인하면 해결할 수 있습니다. 경우에 따라 방화벽을 일시적으로 비활성화하고 라이브러리 파일을 수동으로 다운로드해야 할 수도 있습니다. | ![]() |
| 강력한 방화벽 때문에 발생한 또 다른 오류 메시지입니다. 고객은 집에서 다운로드할 때는 문제가 없었습니다. 해결 방법은 다음과 같습니다. 사무실 밖에서 Imatest를 다운로드한 후 CD 또는 USB 장치를 사무실로 가져오십시오. | ![]() |
"DNS 오류" 메시지가 표시되는 경우(매우 드물지만), , 실행을 차례로 클릭하고 열기 상자에 ipconfig /flushdns를 입력한 다음 클릭해 보세요.
설치 후 발생하는 문제
오류: MCR의 버전 mn을 찾을 수 없습니다.
이 오류는MCR(Matlab 컴파일러 런타임, 즉 라이브러리) 설치 실패 또는 Imatest를 실행하는 배치 파일의 경로 문제로 인해 발생할 수 있습니다. 이 오류는 Imatest 3.7 및 3.8 초기 빌드에서 발생할 가능성이 가장 높습니다.
- 이 버전의 Imatest를 처음 설치할 때 MATLAB 라이브러리가 제대로 설치되지 않았습니다. 구성 요소 선택 창에서 MATLAB 라이브러리를 선택하여 Imatest를 다시 설치해야 합니다. (일반적으로 처음 설치할 때 한 번만 수행하면 됩니다.) 한 고객의 경우 이 방법으로 문제가 해결되지 않아 MCR(라이브러리) 폴더(위치는 아래 및 여기 참조)를 삭제한 후 다시 설치했더니 정상적으로 작동했습니다.
-
MCR 설치를 시도했을 때 시스템에 보류 중인 Windows 업데이트가 있었습니다. 설치를 다시 시도하기 전에 모든 업데이트가 완료되었는지 확인하십시오. - Imatest가 다른 버전의 MATLAB이 설치된 시스템에 설치되었습니다. (이러한 경우는 드물게 문제를 일으킵니다.) Imatest를 실행하는 데 사용한 폴더에 있는 배치 파일(run_imatest.bat 및 run_diagnostics.bat)을 확인하여 경로가 올바른 MCR 위치를 가리키는지 확인하십시오.
일반적인 64비트 Windows 7 영문 설치 환경에서 Imatest 설치 폴더는 C:Program Files (x86)\Imatest\Master입니다. 이 폴더는 Imatest 버전, 운영 체제 및 언어에 따라 다를 수 있으므로 시스템에서 해당 폴더를 찾으십시오.
경로는 Imatest 설치 폴더에 있는 run_imatest.bat 파일(또는 run_diagnostics.bat 파일)에 설정되어 있습니다. 변경 사항을 저장하려면 관리자 권한으로 파일을 열어야 합니다. (제 시스템에서) 경로 정보가 포함된 핵심 줄은 다음과 같습니다.
@path="C:Program Files (x86)\Imatest\Master_3.8;C:Program Files (x86)\Imatest\Master_3.8bin; C:Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v714runtimewin32 ; C:Program Files (x86\)MATLAB\MATLAB Compiler Runtime\v714 ;%path%"
이 줄에서 강조 표시된 항목은 MATLAB 컴파일러 런타임(MCR) 폴더입니다. 이 폴더의 내용을 확인해야 합니다. 만약 C:Program Files (x86)MATLABMATLAB Compiler Runtimev714 폴더(또는 시스템에 따라 이에 해당하는 폴더)가 이 줄에 없다면(Imatest 3.8 이전 버전에서만 발생하는 문제), 해당 폴더를 추가해야 합니다.
3.6: "mclmcrrt711.dll 파일을 찾을 수 없어 이 응용 프로그램을 시작하지 못했습니다."와 유사한 메시지가 표시 되면 MATLAB 런타임 라이브러리(MCR)가 포함된 전체 버전을 다운로드 하여 설치해야 합니다. Imatest 3.6 의 경우 이 작업은 한 번만 수행하면 됩니다. 다운로드 및 설치에는 각각 몇 분 정도 소요될 수 있습니다. 업그레이드 다운로드 및 설치는 훨씬 빠릅니다.
3.6+: mllapack.dll 프로시저를 찾을 수 없습니다 ( mllapack.dll La procédure spécifiée est introuvable en Français). Imatest는 정상적으로 시작되지만, 이 메시지가 상자에 표시되면서 종료됩니다. 이 문제는 두 번 발생했습니다. 원인을 찾는 데 어려움을 겪었습니다. 한 고객에게 효과가 있었던 해결책(다소 노력이 필요했지만) 은 이 Google 게시물 과 이 Matlab Central 게시물 의 끝부분에서 찾았습니다.
"오류의 원인은 예상대로 DLL 버전 문제였습니다. windows/system32 디렉터리에 이전 버전의 "libmmd.dll" 파일이 있었습니다. MATLAB 런타임의 bin/win32 디렉터리에 있는 최신 버전은 사용되지 않았습니다. 이전 버전을 삭제하니 문제가 해결되었습니다. 왜 그 파일이 거기에 있었는지, 그리고 vcredist를 설치할 때 왜 windows 디렉터리에서 최신 버전으로 업데이트되지 않는지는 아직 알아내지 못했습니다. 정말 골치 아프네요."
만약 이 방법이 효과가 없다면, 다른 해결책을 고려해 보는 것도 좋습니다. MATLAB 게시물에 따르면 "이 충돌은 MATLAB과 CPU 간의 호환성 문제로 발생합니다. 예를 들어, 프로세서가 SSE2 명령어 세트를 지원하지 않는 경우, 즉 Athlon XP 2200+ CPU에서 이러한 문제가 발생할 수 있습니다." 이 문제는 2003년 이후에 제조된 컴퓨터에서는 발생하지 않아야 합니다.
3.6 이전 버전: 가장 흔한 설치 문제는 MATLAB 런타임 라이브러리인 Imatest-lib.exe 가 제대로 다운로드되거나 설치되지 않는 것입니다. 이로 인해 다음과 같은 오류 메시지가 표시됩니다.
"프로시저 진입점 ...을 동적 링크 라이브러리 ... .dll에서 찾을 수 없습니다."
이러한 메시지가 표시되면 Imatest-lib.exe 파일이 제대로 다운로드되었는지 확인하십시오. 또한 방화벽 상태도 확인하십시오. 강력한 방화벽이 이 문제를 일으킬 수 있습니다.
- 만약 설치 중에 자동으로 다운로드되었다면, Imatest 설치 폴더(일반적인 Win32 영어 설치 환경에서는 C:Program files\Imatest\Imatest)에 해당 파일이 있을 것입니다.
- 수동으로 다운로드한 경우(일반적으로 방화벽이 있는 시스템에서 필요함), Imatest 설치 프로그램(Imatest- xx.exe )과 동일한 폴더에 사본이 있어야 합니다.
Windows XP 탐색기는 파일 크기를 8,513kB로 표시하지만, 마우스 커서를 파일 이름 위로 가져가면 나타나는 툴팁에는 8.31MB로 표시됩니다(참 이상하죠). 다운로드가 실패한 경우 더 작은 크기가 표시될 수 있습니다.
Imatest-lib.exe 파일을 찾을 수 없거나 잘못 다운로드되었다고 생각되면, 여기 또는 이 섹션의 링크를 마우스 오른쪽 버튼으로 클릭하여 다운로드한 다음 Imatest를 다시 설치하십시오 . Imatest-lib.exe는 압축 해제되는 zip 파일로, Matlab 런타임 라이브러리를 Imatest 설치 폴더의 binwin32 및 toolbox\matlab 하위 폴더에 배치합니다. 문제가 지속되면 해당 폴더에 파일이 있는지 확인한 후, DOS 창에 표시되는 오류 메시지(있는 경우)를 첨부하여 Imatest 지원팀 에 이메일을 보내주십시오.
- Imatest 3.1 이상 버전 에서는 네 개의 파일이 Imatest 설치 폴더와 하위 폴더에 설치됩니다. 파일이 없는 경우 하위 폴더(영어 버전 설치 시 C:Program Files\Imatest\toolbox\matlab\iofun\private)에 복사할 수 있습니다.
- 이전 버전을 사용하려면 jpegdlls.zip 파일을 다운로드하고 그 내용을 하위 폴더에 복사하세요.
런타임 오류
이미지 파일을 읽을 수 없습니다.
MATLAB은 비표준 헤더나 잘못된 파일 확장자(예: PNG 파일에 BMP)와 같은 불규칙성을 가진 이미지 파일을 읽지 못하는 경우가 종종 있습니다. 이러한 파일은 상용 카메라에서는 드물지만 프로토타입이나 개발 시스템에서 나타날 수 있습니다. Irfanview를 사용하면 이러한 파일을 "정리"할 수 있습니다. Irfanview는 Irfanview.com 에서 무료로 다운로드할 수 있는 유용한 유틸리티입니다! 파일을 Irfanview 로 불러온 다음 저장하세요. (원본 파일을 보관해야 하는 경우 다른 파일 이름을 사용할 수 있습니다.)
Imatest에서 지역을 선택한 후 작동이 중단됩니다(멈추거나 충돌함).
이 문제는 유다오 사전 과 같은 자동 번역 소프트웨어로 인해 발생했을 수 있습니다.
해결책:
ROI를 선택하는 동안 번역 소프트웨어를 일시적으로 비활성화하십시오. 이 문제에 대한 자세한 내용은 영역 선택 버그 해결 방법을 참조하십시오.
Imatest가 충돌하거나 예상대로 실행되지 않습니다.
이런 상황이 발생하면 평소에는 최소화되어 있는 명령(DOS) 창에 디버깅에 유용한 오류 메시지가 표시될 수 있습니다. 해당 내용을 보려면 다음을 수행하십시오.
- Imatest 명령 창 아이콘을 클릭하세요.
작업 표시줄에 있습니다. - [파일] > [현재 세션 보기] 를 클릭하면 세션 내용이 편집기(일반적으로 메모장)에서 열립니다. 또는 [파일] > [현재 세션 복사]를 클릭한 다음 원하는 편집기에 붙여넣거나 Imatest 지원팀에 문의 할 수 있습니다.
- Imatest가 완전히 충돌하여 종료된 경우, 다시 시작한 다음 파일 , 보기 (또는 복사 ) > 마지막 세션을 클릭하십시오.
대부분의 문제는 다음 범주에 속합니다.
- 버그를 발견하셨습니다. 많은 버그는 최신 Imatest 버전을 다운로드하여 설치하면 해결될 수 있습니다. 그래도 문제가 해결되지 않으면 (위에서 설명한 대로) 명령 창 내용과 함께 INI 파일 및 이미지를 첨부하여 고객 지원 센터에 문의해 주세요 . 자세한 내용은 여기를 참조하세요.
- 저장된 설정이 포함된 파일인 Imatest-v2.ini( Imatest 4.2 이전 버전에서는 imatest.ini)가 손상되어 읽을 수 없습니다. 손상에 대한 설명과 해결 방법은 아래의 "손상된 INI 파일" 섹션을 참조하십시오.
- 이전에는 정상적으로 작동하던 모듈이 작동을 멈췄습니다. 이는 대부분 Imatest-v2.ini 파일의 해당 모듈 섹션에 잘못된 항목이 입력되어 있기 때문입니다. 자세한 설명과 해결 방법은 아래의 " 이전에 정상적으로 작동하던 모듈이 작동을 멈췄습니다 " 섹션을 참조하십시오.
Imatest 3.7 이상 버전에서는 imatest-v2.ini 파일의 정확한 위치를 알 필요가 없습니다. Imatest에는 해당 파일을 찾고, 편집하고, 저장하고, 불러오는 데 필요한 모든 유틸리티가 포함되어 있기 때문입니다 . 정확한 위치는 다음과 같습니다.
$APPDATA$\Imatest\imatest-v2.ini
여기서 $APPDATA$는 Windows Vista/7(영어 버전)에서 C:Users \user_name\ AppData\Roaming에 해당하는 환경 변수입니다. imatest-v2.ini의 전체 경로명은 Windows Vista/7-10에서 C:Users\ user_name\ AppData\Roaming\Imatest\imatest.ini입니다. 다른 운영 체제 및 언어에서는 경로명이 다를 수 있습니다.
손상된 ini 파일이 오류는 Imatest 4.2 이전 버전에서 라틴 문자가 아닌 문자(중국어, 한국어, 일본어, 히브리어 등)가 포함된 폴더나 파일이 있는 시스템에서 간혹 발생하며, 해당 버전에서는 완전히 수정되었습니다 . DOS 창에 표시되는 일반적인 메시지는 다음과 같습니다. 파일에서 키를 구문 분석하는 중 오류 발생: C:\Doc ... Imatest\imatest.ini: inifile>findkeys 사용 중 오류 발생 (508번째 줄) 이 문제는 2012년 6월 15일 이후에 출시된 Imatest 3.9 이상 버전에서 대부분 해결되었습니다. 새로운 빌드에서는 ini 파일에 UTF-8 문자 인코딩을 사용하므로 비라틴 문자를 처리할 수 있습니다. 화면에 나타나는 권장 사항에 따라 복구 절차를 한 번 수행해야 할 수도 있습니다. 문제가 다시 발생하는 경우(매우 드물겠지만)
이 문제가 Imatest 3.7 이전 버전에서 발생하는 경우, 아래의 INI 파일 수정 지침을 따르십시오. Imatest 3.7 이상 버전에서는 아래 그림과 같은 창 중 하나가 열립니다. Imatest 3.7에서 imatest.ini 파일(2번째 줄)에 손상 메시지가 나타납니다. 이 메시지는 2번째 줄에 오류가 있음을 나타냅니다. 누르면 ini 파일이 메모장에서 열립니다. 오류가 있는 줄을 삭제하거나 수정한 후(아래 설명 참조) 파일을 저장하십시오. 메모장을 닫고 Imatest를 다시 시작할 수 있습니다. ![]() 이 메시지는 26번째 줄에 오류가 있음을 나타냅니다. 누르면 오류가 있는 줄을 감지하고 검토한 후 수정된 파일을 저장할 수 있는 특수 편집기가 열립니다.
INI 파일 검사 및 복구 창이 나타납니다. Imatest 3.8 이상 버전에서 구문 분석 오류 후에 표시됩니다. INI 파일 수정: Imatest.ini (및 rescharts.ini, multicharts.ini 등) 파일에는 Imatest 실행에 사용되는 저장된 설정이 포함되어 있습니다. 이 파일들은 Imatest가 처음 실행될 때 생성됩니다. 설정에는 관심 영역(ROI), 플롯 선택, 플롯 배율, 계산 기법 등이 포함됩니다. ini 파일은 각 줄이 다음과 같이 형식이 지정된 텍스트 파일입니다.
줄이 이 구조를 따르지 않으면 오류가 감지됩니다. 가장 흔한 원인은 등호(=)가 누락된 경우입니다. 오류 메시지가 표시되면 위의 검사 및 복구 창에 있는 지침을 따르거나
근본 원인은 무엇일까요? 저희는 문제가 로케일 설정 과 관련이 있다고 생각합니다. MATLAB 프로세스에서 로케일 설정을 사용하는 방법 에 대한 몇 가지 항목을 참조하십시오.
국제화 및 I18n 메시지 및 설정 문제 해결 섹션 도 참조하십시오. 여기에는 다음과 같은 흥미로운 내용이 포함되어 있습니다. "Microsoft Windows 플랫폼에서는 사용자 로캘과 시스템 로캘 값이 동일해야 합니다. 이 값이 같지 않으면 텍스트가 깨지거나 잘못된 문자가 표시될 수 있습니다." |
3.7 이전 버전: Imatest가 충돌하고 "ERROR: Error in parsing the file for keys: C:"와 유사한 메시지가 표시되면 imatest.ini 파일이 손상된 것입니다. 이 파일에는 표준 ini 파일 형식에 맞지 않는 텍스트가 포함되어 있을 수 있습니다. 아래에 표시된 위치에 있는 imatest.ini 파일을 열고 문제가 되는 코드를 제거해야 합니다. 문제가 되는 텍스트를 찾을 수 없는 경우 파일을 삭제(또는 이름을 변경)하십시오. ini 파일이 손상된 것으로 의심되는 경우 수행할 수 있는 몇 가지 작업이 있습니다.
|
이전에는 정상적으로 작동하던 모듈이 작동을 멈췄습니다.
| 이 기법에 대한 전체 설명, 즉 손상된 설정이 포함될 수 있는 INI 파일 섹션을 제거하는 방법은 다음과 같습니다. "이전에 정상적으로 작동했던 모듈이 작동을 멈췄습니다 ."라는 메시지가 표시됩니다. |
이 문제는 imatest-v2.ini 파일(imatest.ini, rescharts.ini 또는 Imatest 4.2 이전 버전의 multicharts.ini 파일)에서 해당 모듈에 대한 섹션을 제거하면 해결되는 경우가 많습니다.
아래 그림과 같이 INI 파일 편집기를 열려면 [INI 파일 설정] , [INI 파일 편집기]를 클릭하십시오. 참고: Imatest를 다시 설치해도 이러한 유형의 문제는 해결되지 않는 경우가 많습니다.

ini 파일 편집기는 ini(설정) 파일을 편집하는 데 매우 강력한 도구입니다.
이전에는 정상적으로 작동했지만 현재는 작동하지 않는 모듈은 해당 섹션을 선택하여 복구할 수 있는 경우가 많습니다.
해당 모듈에 대해 클릭합니다.
상단에 있는 '섹션 ' 드롭다운 메뉴에서 보고 싶은 섹션을 선택하거나 삭제할 수 있습니다. 개별 줄을 편집하려면 큰 창에서 해당 줄을 선택하고, 큰 창 바로 위에 있는 편집 창에서 변경한 다음 Enter 키를 누르세요. 선택한 섹션 전체를 삭제하려면 '를 누르세요. 변경 사항을 저장하려면 ' '을 누르세요. '저장' 버튼은 변경하기 전까지는 비활성화되어 있습니다. 변경 사항을 취소하려면 또는 누르세요.
오류 처리 및 보고
문제를 해결할 수 없는 경우 Imatest 지원팀 에 이메일을 보내주세요. 이메일 제출 방법은 유틸리티 메뉴의 에서 확인할 수 있습니다.
- 오류 메시지를 포함시키세요 . 오류 메시지는 일반적으로 명령(DOS) 창에 표시됩니다. (명백히 관련 없는 부분은 삭제해도 됩니다.) 명령 창 내용을 얻으려면 다음을 참조하세요.
- [파일]을 클릭하고 [현재 세션 복사]를 선택한 다음, Imatest 도움말 센터 에 생성한 문제에 붙여넣으세요.
- Imatest가 완전히 충돌하여 종료된 경우, 다시 시작한 다음 파일 > 마지막 세션 복사를 클릭하십시오.
- 이전 버전을 사용하려면 Imatest 명령 창 아이콘을 클릭하십시오.
작업 표시줄에 있습니다. 내용 복사 방법은 아래 회색 상자를 참조하세요.
- 사용 중인 운영 체제를 알려주세요( Imatest 3.9 이상 버전의 명령 프롬프트(DOS) 창에 표시되어 있습니다).
- 문제 진단에 도움이 될 수 있는 imatest.ini 파일( Imatest 4.2 이전 버전에서는 multicharts.ini 또는 rescharts.ini 파일) 의 내용을 첨부해 주세요 . Imatest 3.6 이상 버전에서는 [INI 파일 설정] > [설정 복사(ini 파일)]를 클릭하여 내용을 클립보드에 직접 복사할 수 있습니다. [INI 파일 설정] > [설정 보기(ini 파일)] 를 클릭하면 텍스트 편집기(일반적으로 메모장)에서 내용을 볼 수 있습니다.
- 오류로 인해 Imatest 명령 창이 닫히지 않는 한, 실제 ini 파일 폴더 위치를 알 필요는 없습니다. 일반적인 영어권 Windows Vista/7 시스템의 위치는 C:Users\사용자 이름\ AppData\Roaming 입니다. [ini 파일은 %AppData%\Imatest 폴더에 있으며, %AppData%는 명령 환경 변수로, 명령 창에서 dir "%AppData%"를 입력하면 파일 이름을 확인할 수 있습니다.]
- 이미지에 문제가 있다고 의심되는 경우 (일부 이미지는 정상적으로 실행되고 일부 이미지는 그렇지 않은 경우), 해당 이미지를 문제 보고서에 첨부해 주세요.
명령(DOS) 창 Imatest는 일반적으로 최소화된 상태를 유지하는 명령 창(기존 DOS 창과 유사)에서 실행됩니다. 실행이 예기치 않게 종료되거나 멈추는 경우 명령 창에 유용한 디버깅 정보가 포함될 수 있습니다. 명령 창의 내용을 보거나 복사하려면 다음을 수행하십시오. 3.6 이상: Imatest 명령(DOS) 창에서 세션을 직접 보거나 복사할 수 있습니다.
3.6 이전: 절차 1: 텍스트 복사 및 붙여넣기 (간단하지만 약간 까다로움)
3.6 이전 버전: 절차 2: 화면 캡처 이미지를 복사하여 붙여넣기 (복잡하지만 신뢰할 수 있음)
|
진단 실행
DOS 창이 닫히는 Imatest 오류가 발생하거나(요즘은 드물지만) 추가 진단 결과가 문제 해결에 도움이 될 수 있는 경우,
- 일반적인 Windows 32 영어 설치 환경에서는 C:Program files\Imatest\Imatest 폴더에 있는 Imatest 폴더에서 Diagnostics 파일을 두 번 클릭하여 Imatest를 실행하십시오.
(또는 diagnostics.bat). 이렇게 하면 Imatest가 종료된 후에도 DOS 창이 열린 상태로 유지되어 오류 메시지를 볼 수 있습니다. - 위의 오류 보고 지침에 따라 오류 메시지를 Imatest 지원팀에 이메일로 보내주십시오 .
경우에 따라 imatest-v2.ini 파일을 삭제하거나 이름을 변경하면 문제를 해결할 수 있습니다(이름을 변경하는 것이 기록을 남기므로 더 좋습니다). 자세한 지침은 여기를 참조하세요.
다른 버전의 MATLAB이 설치되어 있을 때 경로 충돌이 발생합니다.
| X 프로시저 진입점 svDoubleSclarRemW를 찾을 수 없습니다. 동적 링크 라이브러리 libmwservices.dll에 위치합니다. |
시스템에 Imatest (6.5.1)에 사용된 MATLAB 버전과 다른 버전이 설치되어 있는 경우, 경로 충돌로 인해 유사한 오류 메시지가 발생하거나 Imatest가 실행되지 않을 가능성이 있습니다. 하지만 Imatest를 실행하는 배치 파일이 경로를 설정하기 때문에 이러한 문제는 드물게 발생합니다 . 경로 문제 및 해결 방법 은 Imatest IT EXE 설명서를 참조하십시오.
벌레 등등
3.6 이전 버전: 데이터를 저장하려고 하면 DOS 창에 다음 메시지가 여러 번 나타납니다.
'get_param' 함수는 독립 실행형 모드에서 구현되지 않았습니다.
이 문제는 저장된 이미지에는 영향을 미치지 않으며, DOS 창이 배경에 계속 표시되므로 거의 눈에 띄지 않습니다. MATLAB은 이 문제를 향후 릴리스에서 수정할 예정이라고 여기에서 설명했습니다.
추가 문서
Imatest 의 각 모듈에 대한 지침은 Imatest 문서 페이지 에서 확인할 수 있습니다.






