故障排除

Imatest 失败时该怎么办

报告崩溃

如果Imatest崩溃且没有明显的解决方法,我们强烈建议您向我们报告崩溃情况。有两种方法可以报告崩溃。

1. 使用错误报告窗口发送崩溃报告

对于大多数错误,将打开如下所示的错误报告窗口。

错误报告窗口
错误报告窗口
许多模块在运行过程中会出现错误,这些模块以前可以正常工作,但现在却无法运行。通常可以通过从 INI 文件(imatest-v2.ini)中删除与该模块对应的部分来解决此类错误。以下简要介绍此方法,更详细的介绍请参见“以前可以正常工作的模块停止工作了” 。

如果您遇到导致Imatest无法运行的错误(且您无法自行解决),我们建议您点击“发送错误报告”按钮将错误信息发送给我们。点击此按钮后,将打开一个新窗口,您可以在其中输入您的电子邮件地址(以便我们与您联系)以及错误描述。完成后,请点击该窗口中的“发送错误报告”按钮。

提交错误报告窗口:用于发送您的电子邮件地址和错误描述。
提交错误报告窗口:用于发送您的电子邮件地址和错误描述。

如果在分析图像时出现错误,我们建议您将图像发送给我们,最简单的方法是在Imatest 帮助中心创建工单并附上图像。我们可以快速找到由图像构图不正确或构图不佳导致的错误。阅读使用说明总是有益的。

备注:

如果在分析图像时出现错误,我们建议您将图像发送给我们,最简单的方法是将其作为附件添加到Imatest 帮助中心创建的问题中。我们可以快速找到由图像构图不正确或构图不佳导致的错误。阅读使用说明总是有益的。

发送屏幕截图(如右图所示)不如按照上述步骤发送错误报告有效。屏幕截图无法提供诊断问题所需的所有信息,非英语用户通常难以理解。(右图显示的是中文窗口)。要报告错误,请按底部中间的按钮(红色椭圆内所示)。

2. 复制、粘贴并发送到Imatest 帮助中心

此方法仅适用于极少数情况下,即上面所示的错误报告窗口无法打开时。

  1. 在 Imatest 中,按“文件” ,然后选择“复制当前会话” 。这会将会话内容(包括错误消息)复制到剪贴板。
  2. 请在Imatest 帮助中心提交问题。在摘要中描述问题,然后将剪贴板的内容粘贴到描述中。
  3. 如果你这样做,可能会有所帮助。
    1. 请将 imatest-v2.ini 文件附加到问题中。您可以通过按“文件” > “打开 INI 文件文件夹”找到它的位置。
      - 或者 -
    2. 按INI 文件、复制 Imatest 设置、然后按 atta,将 ini 文件文本复制到剪贴板。确保将其与会话文本完全分开。

如果崩溃导致Imatest窗口关闭,则在命令(DOS)窗口(如下)中还有一些其他程序可以报告错误。

版本

如果可以,我们建议您运行最新版本的Imatest 。您应该始终运行许可证允许的最新版本(您可以激活购买日期后一年内发布的版本:请参阅变更日志)。新版本修复了早期版本中发现的错误并进行了功能增强。

版本号显示在主窗口顶部的栏中,构建日期(如果您运行的是 Beta 版本,则尤为重要)会在您点击“帮助” > “关于”时显示。如果您的版本比“更新日志”中显示的最新版本旧,我们建议您下载、安装并运行最新版本。通常情况下,无需卸载旧版本。

如果Imatest停止工作,问题通常是 imatest-v2.ini 文件( Imatest 4.2之前的版本为 imatest.ini)中的某个条目错误,具体说明如下。卸载Imatest通常无济于事,重新安装也仅在系统文件丢失等极少数情况下有效。应始终首先解决 Imatest-v2.ini 文件的问题。从“实用工具”菜单打开“错误报告”会打开如下所示的窗口,其中包含有关如何处理错误的简明说明以及直接链接。

从 “实用工具” 菜单打开 “错误报告” 错误报告和故障排除窗口,其中包含简明的说明和直接链接。
从“实用工具”菜单打开“错误报告”
错误报告和故障排除窗口,其中包含简明的说明和直接链接。

安装

通常情况下,更新安装无需卸载旧版本,但如果您遇到问题,可以卸载并重新安装 Imatest。您可以从“开始”菜单( “开始”>“所有程序”>“Imatest”>“卸载”)或控制面板的“添加或删除程序”功能访问卸载程序。卸载程序允许您选择保留或删除 Matlab 运行时库存档(3.6 之前的版本中为Imatest-lib.exe )。(默认选择“保留”;您需要选中相应的复选框才能将其删除。)保留该存档可以加快重新安装速度。仅当您不打算重新安装 Imatest 或有充分理由怀疑该存档可能已损坏(这种情况很少见)时才应将其删除。点击此处查看完整的安装说明。

Imatest 3.6+ 的重要变更

最新版本的 Imatest 仅支持 64 位计算机。Matlab 的版本历史记录可在维基百科上找到,但其中存在一些遗漏。

Imatest 3.6 及更高版本使用新的 Matlab 编译器(4.11 及更高版本)取代了旧的 R13 编译器(3.0.1 版本)。新编译器需要下载更大的库:约 200MB 的Matlab 编译器运行时 (MCR) (一种虚拟机)。Imatest 通常编译为 32 位应用程序,可在 32 位和 64 位计算机上运行。(64 位应用程序的性能优势不大,且无法在 32 位计算机上运行。)

Imatest Matlab 版本和库 (MCR) 位置
测试
版本
编译器/库典型位置(64 位英文安装的环境变量和文件名)
[在 32 位计算机上,请将 C:\Program Files 替换为 C:\Program Files (x86)。]
2020.2 R2020a 9.8 
2020.1 R2019b 9.7 
5.2 R2019a 9.6 
5.1 R2017b 9.3 
3.10、4.0+编译器 4.18 V81 %ProgramFiles%\MATLAB\MATLAB Compiler Runtime\v81 [C:\Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v81]
3.7-3.9编译器 4.14 V714 %ProgramFiles%\MATLAB\MATLAB Compiler Runtime\v714 []C:\Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v714
3.6编译器 4.11 V711 %ProgramFiles%\MATLAB\MATLAB Compiler Runtime\v711 [C:\Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v711]
3.6 版本之前编译器 3 %ProgramFiles%\Imatest\toolbox\matlab [C:\Program Files (x86)\Imatest\toolbox\matlab]
注意:Matlab 的命名规则可能非常令人困惑。例如,Matlab R2010b (7.11) 使用的是 Matlab Component Runtime 7.14 和 Compiler 4.14,请参阅http://www.mathworks.com/support/solutions/en/data/1-4GSNCF/?solution=1-4GSNCF

安装完成后,

  • MCR 应该位于 32 位系统中的 %ProgramFiles%\MATLAB\MATLAB Compiler Runtime\v714(适用于 Imatest 3.7+;...V711 适用于 3.6)(在英文版 Win32 安装中,%ProgramFiles% 为 C:\Program Files);或者位于 64 位系统中的 %ProgramFiles(x86)%\MATLAB\MATLAB Compiler Runtime\v714(或 ...V711)(在英文版 Win64 安装中,%ProgramFiles(x86)% 为 C:\Program Files (x86))。
  • 在 32 位系统中, Imatest位于 %ProgramFiles%\Imatest\Imatest(在英文版 Win32 系统中,%ProgramFiles 即 C:\Program Files);在 64 位系统中,Imatest 位于 %ProgramFiles(x86)%\Imatest\Imatest(在英文版 Win64 系统中,%ProgramFiles(x86) 即 C:\Program Files (x86))。

首次安装包含新库(例如 V7111、V714 等)的Imatest 3.6+ 时,请确保在“选择组件”窗口中选中“Matlab 库” 。库安装需要几分钟时间。安装与您的版本匹配的 MCR 后,更新Imatest时无需再选中此复选框。

如果在安装 MCR 之前尝试运行Imatest ,可能会出现以下消息。选中“Matlab 库”复选框重新安装即可解决此问题。

由于找不到 mclmcrrt714.dll,此应用程序无法启动。

安装过程中出现问题

如果出现以下情况,安装或注册可能会失败:

  • 您的计算机没有管理员权限。如果没有管理员权限,您可能会看到类似这样的消息:
    打开文件写入时出错 C:\Program files(x86)\Imatest\Master\imatest.exe
    打开写入文件时出错 C:\Program files (x86)\Imatest\Master\dcraw.exe 等。
  • 您的计算机位于强大的企业防火墙之后。
3.6 版本之前:此消息有时会在防火墙配置较高的系统中出现。通常可以通过确保从下载页面获取的 Matlab 运行时库Imatest-lib.exe与 Imatest 安装文件位于同一文件夹中来解决此问题。您可能需要暂时禁用防火墙并手动下载库文件。
安装错误
这是由于防火墙设置过强而出现的另一个错误信息。客户在家下载时没有遇到任何问题。解决方法:在办公室外下载 Imatest,然后携带光盘或 U 盘到办公室。

如果您收到“DNS 错误”的提示(这种情况非常罕见),请尝试点击“开始” 、 “运行...” ,在“打开...”框中输入ipconfig /flushdns ,然后点击“确定” 。

安装后出现问题

错误:找不到 MCR 的版本 mn。

此错误可能是由于MCR(Matlab 编译器运行时,即库)安装失败或运行Imatest的批处理文件中的路径问题引起的。它最有可能出现在Imatest 3.7 和 3.8 的早期版本中。

  • 您首次安装此版本Imatest时,Matlab 库未正确安装。您需要重新安装Imatest ,并在“选择组件”窗口中选中“Matlab 库” 。(通常只需在首次安装时执行一次)。一位客户尝试后仍然无法解决问题,他删除了 MCR(库)文件夹(位置如下及此处所述),然后重复上述步骤,最终成功解决问题。
  • 尝试安装 MCR 时,您的系统存在待处理的 Windows 更新。请确保所有更新完成后再重新安装。
  • Imatest已安装在已安装其他版本 Matlab 的系统上。(这种情况很少会造成问题。)请检查运行 Imatest 版本所在文件夹中的 bat 文件(run_imatest.bat 和 run_diagnostics.bat),确保路径指向正确的 MCR 位置。

在典型的 64 位 Windows 7 英文版系统中, Imatest 的安装文件夹位于 C:\Program Files (x86)\Imatest\Master。不同版本的Imatest 、操作系统和语言的安装文件夹位置可能有所不同。您需要在系统中查找该文件夹。

路径设置在Imatest安装文件夹中的 run_imatest.bat 文件(以及 run_diagnostics.bat 文件)中。如果您想保存更改,需要以管理员权限打开该文件。包含路径信息的关键行(在我的系统中)是:

@path="C:\Program Files (x86)\Imatest\Master_3.8;C:\Program Files (x86)\Imatest\Master_3.8\bin; C:\Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v714\runtime\win32 ; C:\Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v714 ;%path%"

此行中高亮显示的条目是 Matlab 编译器运行时 (MCR) 文件夹。您应该检查这些文件夹的内容。如果C:\Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v714文件夹(或您系统中对应的文件夹)不在此行中(仅在 Imatest 3.8 之前的版本中存在此问题),则应将其添加进去。


3.6:如果您收到类似“由于找不到 mclmcrrt711.dll,此应用程序无法启动”的消息,则需要下载并安装完整版本,其中包含 Matlab 运行时库 (MCR)。Imatest 3.6只需执行一次此操作。下载和安装可能各需要几分钟时间。升级下载和安装速度要快得多。


3.6+:找不到 mllapack.dll 程序( mllapack.dll La procédure spécifiée est introuvable en Français)。Imatest启动正常,但随后会弹出一个对话框显示此错误信息并终止。我们已经遇到过两次这个问题,而且很难找到原因。最终,我们在这篇 Google 帖子和这篇 Matlab Central 帖子的末尾找到了一个对一位客户有效的解决方案(但需要花费一些精力)。

“我发现错误源于 DLL 版本问题(正如我所怀疑的)。windows/system32 目录下存在一个旧版本的“libmmd.dll”。而 MATLAB Runtime bin/win32 目录下的版本并没有被使用。删除旧版本后问题就解决了。我还没弄明白它为什么会出现在那里,以及为什么在安装 vcredist 时它没有被更新到 windows 目录下。真是太麻烦了。”

如果上述方法无效,或许可以尝试另一种方法。 这篇 Matlab 帖子指出:“崩溃是由 MATLAB 与 CPU 不兼容引起的。例如,如果处理器不支持SSE2 指令集,例如 Athlon XP 2200+ CPU,就会发生这种情况。” 2003 年之后生产的计算机应该不会出现此问题。


3.6 版本之前:最常见的安装问题是 Matlab 运行时库Imatest-lib.exe无法正确下载或安装。这会导致出现如下形式的错误消息:

“无法在动态链接库.dll文件中找到程序入口点……”

如果收到此类消息,请检查文件Imatest-lib.exe是否已正确下载。此外,请检查防火墙状态。配置过高的防火墙可能会导致此问题。

  • 如果是自动下载的(在安装过程中),则在 Imatest 安装文件夹(在典型的 win32 英文安装中为 C:\Program files\Imatest\Imatest)中应该有一个副本。
  • 如果您是手动下载的(通常在有防火墙的系统中需要这样做),则在与 Imatest 安装程序相同的文件夹中应该有一个副本,即 Imatest- xx.exe 。

Windows XP 资源管理器显示文件大小为 8,513 KB,但将光标悬停在文件名上时出现的工具提示却显示文件大小为 8.31 MB(真是奇怪)。如果下载失败,则显示的文件大小可能会更小。

如果您找不到 Imatest-lib.exe,或者怀疑下载不正确,请右键单击此处或本节中的任何链接进行下载,然后重新安装Imatest。Imatest-lib.exe 是一个自解压 zip 文件,它会将 Matlab 运行时库放置在 Imatest 安装文件夹的 binwin32 和 toolbox\matlab 子文件夹中。如果问题仍然存在,请检查这些文件夹是否已存在,然后将 DOS 窗口中显示的任何错误消息文本通过电子邮件发送给Imatest 支持团队。


3.6 版本之前:缺少 DLL 文件在极少数情况下,Imatest 安装文件夹的 toolbox\matlab\iofun\private 子文件夹中可能缺少四个 DLL 文件:jpeg_depth.dll、dataread.dll、imjpg8.dll 和 rjpg8c.dll。由于它们未包含在Imatest-lib.exe中,因此需要使用不同的安装方法,这种方法的失败率低于 1%。如果您收到提示信息,表明这些文件可能缺失,请检查该子文件夹,如果找不到,请手动安装。
  • 在Imatest 3.1 或更高版本中,这四个文件会安装到 Imatest 安装文件夹及其子文件夹中。如果这些文件缺失,可以将它们复制到子文件夹(toolbox\matlab\iofun\private;英文版安装路径为 C:\Program Files\Imatest\toolbox\matlab\iofun\private)。
  • 对于早期版本,您可以下载jpegdlls.zip并将内容复制到子文件夹中。

运行时错误

无法读取图像文件。

Matlab通常无法读取具有非标准文件头或其他异常(例如文件扩展名错误,如 PNG 文件被错误地扩展为 BMP)的图像文件。这类文件在商用相机中很少见,但在原型或开发系统中可能会出现。您通常可以使用Irfanview来“清洗”它们,您可以从Irfanview.com免费下载 Irfanview。它是一款非常实用的工具!将文件导入Irfanview ,然后保存。(如果您需要保留原始文件,可以使用不同的文件名。)

选择区域后,Imatest 停止工作(卡死或崩溃)。

这个问题可能是由有道词典等自动翻译软件引起的。

解决方案:

在进行 ROI 选择时,暂时禁用翻译软件。有关此问题的更多信息,请参阅“区域选择错误解决方法” 。

Imatest崩溃或运行异常

发生这种情况时,通常保持最小化的命令(DOS)窗口可能会包含一条有助于调试的错误消息。要查看其内容,

  • 点击 Imatest 命令窗口图标在任务栏中。
  • 点击“文件” > “查看当前会话” ,即可在编辑器(通常是记事本)中打开会话内容。您也可以点击“文件” > “复制当前会话” ,然后将其粘贴到您选择的编辑器中,或者提交给Imatest支持团队。
  • 如果Imatest完全崩溃并关闭,请重新启动它,然后单击“文件”、 “查看(或复制)上次会话” 。

大多数问题都属于以下几类。

  1. 您发现了一个错误。许多错误可以通过下载并安装最新版本的Imatest来修复。如果问题仍然存在,请在帮助中心提交一个问题,并附上命令窗口的内容(如上所述),如果适用,还需附上 INI 文件和镜像文件。详情请点击此处。
  2. 用于存储已保存设置的Imatest-v2.ini 文件( Imatest 4.2之前的版本为 imatest.ini)已损坏,无法读取。请参阅下文“损坏的 INI 文件”部分,了解原因和解决方法。
  3. 之前运行正常的模块现在无法正常工作了。这通常是由于 Imatest-v2.ini 文件中与该模块对应的部分存在错误配置造成的。请参阅下文“之前运行正常的模块现在无法正常工作”部分,了解具体原因和可能的解决方法。

在 Imatest 3.7 及更高版本中,您无需知道 imatest-v2.ini 的确切位置,因为 Imatest 提供了一整套用于查找、编辑、保存和加载该文件的实用工具。它的确切位置是:

$APPDATA$\Imatest\imatest-v2.ini

其中,$APPDATA$ 是一个环境变量,相当于 Windows Vista/7(英文版)中的 C:\Users\用户名\ AppData\Roaming。imatest-v2.ini 的完整英文版 Vista/7-10 路径为 C:\Users\用户名\ AppData\Roaming\Imatest\imatest.ini。在其他操作系统和语言中,路径名称可能有所不同。

ini 文件损坏

在 Imatest 4.2 之前的版本中,如果系统中存在包含非拉丁字符(中文、韩文、日文、希伯来文等)的文件夹或文件,偶尔会出现此错误。在 Imatest 4.2 中,此错误已完全修复。DOS 窗口中的典型错误信息格式如下:

解析文件查找键时出错:C:\Doc ... Imatest\imatest.ini:使用 ==> inifile>findkeys 时出错,位于 508
第 38 行出现未知字符串
上面标记的错误行位于 imatest.ini 文件中。

在 2012 年 6 月 15 日之后发布的 Imatest 3.9+ 版本中,此问题的大部分情况已得到解决。这些新版本对 ini 文件使用 UTF-8 字符编码,应该能够处理非拉丁字符。您可能需要按照屏幕上的提示执行一次修复程序。如果问题再次出现(这种情况应该非常罕见),

  • 如果可以,请将所有图像文件名更改为仅包含拉丁字符(26 个字符,AZ)。
  • 按下 INI 文件设置,重置默认值,彻底删除 imatest.ini 文件可能会有所帮助。

如果在3.7之前的Imatest版本中出现这种情况,请按照下面的INI 文件修复说明进行操作。

对于Imatest 3.7+,应该会打开下面显示的其中一个窗口。

Ini 文件错误信息

Imatest 3.7 中出现“imatest.ini 文件损坏”的错误信息(第 2 行)。

该消息表明第 2 行存在错误。单击“确定”后,ini 文件将在记事本中打开。删除或更正出错的行(参见下文说明),然后保存文件。您可以关闭记事本并重新启动Imatest 。

Imatest 3.9+ 版本中出现“imatest.ini 文件损坏”的错误信息(第 26 行)。
Imatest 3.9+ 版本中出现“imatest.ini 文件损坏”的错误信息(第 26 行)。

该消息表明第 26 行有错误。按下“确定”后,将打开一个特殊的编辑器,该编辑器会检测损坏的行,让您查看它们,然后保存更正后的文件。

扫描并修复 INI 文件窗口。在 Imatest 3.8 及更高版本中解析错误后出现。
点击左下角的粉色横条即可解决问题,最好是预防此问题。
避免在文件名中使用非拉丁字符。

INI 文件修复: Imatest.ini (以及 rescharts.ini、multicharts.ini 等)包含 Imatest 运行中使用的已保存设置。这些文件在 Imatest 首次运行时创建。设置包括感兴趣区域 (ROI)、绘图选择、绘图比例尺、计算方法等等。

ini 文件是文本文件,其格式为每行

  • 是用方括号 ( [...]) 括起来的章节标题,例如 [sfr] 或
  • 格式为,名称 = 值,例如,nwid_save = 2601。

当一行代码不符合此结构时,系统会检测到错误。最常见的原因是缺少等号 (=)。如果您收到错误消息,请按照“扫描和修复”窗口(上方)中的说明进行操作。

  1. 接近Imatest
  2. 任何一个
    1. 删除INI 文件,该文件通常位于此处: %USERPROFILE%AppDataRoamingImatestimatest.ini实际文件名可能因操作系统和语言而异。
    2. 使用文本编辑器从 INI 文件中删除错误行(通常缺少 = 符号)。
  3. 重启Imatest
  4. 保存结果时,请确保使用不包含非拉丁字符(中文、希伯来文等)的文件夹名称,例如“结果”。

根本原因?我们怀疑问题与区域设置有关。以下是MATLAB 进程如何使用区域设置的一些内容:

  • 默认区域设置— 如果用户指定的区域设置不受支持,MATLAB 将使用默认区域设置 en_US.US-ASCII。 (这可能会导致非拉丁字符出现问题。)
  • 用户界面语言设置——用户界面语言设置应设置为与用户指定的区域设置相同的语言,或设置为美国英语。否则,非7位ASCII字符可能无法正确显示。
  • 支持的字符集— MATLAB 支持用户区域设置中指定的字符集。但是,MATLAB 可能无法正确处理大于 2 字节的字符代码。
  • 脚本兼容性— 以一种区域设置创建的 MATLAB 脚本中的非 7 位 ASCII 字符可能与另一种区域设置不兼容。

另请参阅“国际化和I18n 消息及设置故障排除” ,其中包含以下有趣的声明:“在 Microsoft Windows 平台上,用户区域设置和系统区域设置必须相同。如果这些值不同,您可能会看到乱码或错误字符。”

3.7 版本之前:如果 Imatest 崩溃并出现类似“错误:解析文件密钥 C: 时出错”的错误信息,则 imatest.ini 文件已损坏。它可能包含一些不符合标准 ini 文件格式的文本。您需要打开 imatest.ini 文件(位置如下)并删除错误代码。如果您找不到错误文本,则可以将其删除(或重命名)。如果您怀疑 ini 文件已损坏,可以尝试以下几种方法。
  • 在“设置” (或在 Rescharts 或 Multicharts 窗口中),单击“重置默认值(全部)” 。这将删除 imatest.ini 文件,然后使用一些默认值重新创建它。模块运行时,各个部分将重新填充这些值。由于所有设置都会丢失,因此建议仅在万不得已的情况下才使用此方法。
  • 点击“设置”,然后点击“查看设置(ini 文件)”。这将在一个简单的编辑器(记事本)中打开 imatest.ini 文件(如果您正在运行 rescharts.ini 或 multicharts.ini 模块,则可能是这些文件)。您可以编辑该文件(如果您知道要更改什么),然后按 Ctrl+S 保存。您也可以复制其内容并将其粘贴到Imatest 帮助中心创建的问题中。
  • Imatest 3.6+ :点击“设置”,选择“复制设置(ini 文件)”。这会将 ini 文件复制到剪贴板。

之前运行正常的模块现在停止工作了。

该技术的完整描述——如何删除可能包含损坏设置的 INI 文件部分——
呈现方式: 一个以前运行正常的模块停止工作了。

通常可以通过删除 imatest-v2.ini 中的模块部分(在Imatest 4.2之前为 imatest.ini、rescharts.ini 或 multicharts.ini)来解决此问题。

点击“INI 文件设置” > “INI 文件编辑器”打开 INI 文件编辑器,如下图所示。注意:重新安装 Imatest 很少能解决此类问题。

ini 文件编辑器是一个功能极其强大的工具,用于编辑 ini(设置)文件。
通常可以通过选择该部分来修复损坏的(但以前可以正常工作的)模块。
对应模块,然后单击“删除部分”,保存。

您可以从“章节”下拉菜单(位于顶部附近)选择要查看或删除的章节。要编辑单行,请在大窗口中选中该行,然后在大窗口上方的编辑窗口中进行更改,然后按 Enter 键。要删除整个选定内容,请按“删除章节” 。准备好保存更改后,请按“保存”按钮(在进行更改之前该按钮呈灰色)。如果您想取消更改,请按“重新加载 ini 文件”或“关闭” 。

错误处理和报告

如果问题无法解决,请发送电子邮件至Imatest 支持团队。有关如何操作的详细信息,请参阅“实用工具”菜单中的“错误报告”部分。

  • 请提供错误信息,该信息通常显示在命令(DOS)窗口中。(您可以编辑掉明显无关的部分。)要获取命令窗口的内容,
    • 点击“文件” ,复制当前会话,然后将其粘贴到Imatest 帮助中心创建的问题中。
    • 如果 Imatest 完全崩溃并关闭,请重新启动它,然后单击“文件” 、 “复制上次会话” 。
    • 对于旧版本,请单击 Imatest 命令窗口图标在任务栏中。请参阅下方灰色框中的说明,了解如何复制内容。
  • 请告诉我们您的操作系统(包含在Imatest 3.9+ 的命令(DOS)窗口中)。
  • 请提供 imatest.ini 文件( Imatest 4.2之前的版本为 multicharts.ini 或 rescharts.ini)的内容,其中可能包含有助于诊断问题的信息。在Imatest 3.6 及更高版本中,您可以点击“INI 文件设置” > “复制设置(ini 文件)”直接将内容复制到剪贴板。您也可以点击“INI 文件设置” > “查看设置(ini 文件)”在文本编辑器(通常是记事本)中查看内容。
  • 除非错误导致 Imatest 命令窗口关闭,否则您无需知道 ini 文件的实际位置。典型的英文版 Windows Vista/7 位置是C:\Users\您的用户名\ AppData\Roaming 。[ini 文件位于 %AppData%\Imatest 目录下,其中 %AppData% 是一个命令环境变量,您可以通过在命令窗口中输入dir "%AppData%"来确定其文件名。]
  • 如果您怀疑图像存在问题(例如,某些图像可以正常显示,而某些图像则无法显示),请将其附加到问题中。

命令(DOS)窗口

Imatest 运行于一个命令窗口(类似于传统的 DOS 窗口)中,该窗口通常保持最小化状态。当程序意外终止或卡住时,命令窗口可能包含有用的调试信息。要查看或复制命令窗口的内容,

3.6+:直接从 Imatest 命令(DOS)窗口查看或复制会话。

  • 如果崩溃后 Imatest 窗口仍然打开,请点击“文件” 、 “查看当前会话”或“文件”、“复制当前会话”,将其复制到剪贴板以便粘贴到帮助中心问题中。
  • 如果崩溃导致 Imatest 窗口关闭,请重新打开 Imatest,然后单击“文件” 、 “查看上一个会话”或“文件”、“复制上一个会话”,将其复制到剪贴板以便粘贴到帮助中心问题中。

3.6 版本之前:步骤 1:复制粘贴文本(简单,但有点技巧)

  • 点击 Imatest 命令窗口图标在任务栏中(通常在屏幕底部)。
  • 在命令窗口中单击鼠标右键,然后在上下文菜单中单击“全选” 。
  • 或者,您可以点击窗口左上角的图标,点击“编辑”,点击“标记”,然后拖动光标选择要复制的文本。
  • 按下键盘上的回车键(或Return键)。这相当于Windows系统中的Ctrl-C(复制)(但在命令窗口中不起作用)。
  • 使用标准的 Windows 粘贴命令(Ctrl-V 或编辑,粘贴)将文本粘贴到您的电子邮件中。
  • 在发送电子邮件之前,删除明显无关的文本是可以的。

3.6 版本之前:方法二:复制并粘贴屏幕截图(复杂但可靠)

  • 点击 Imatest 命令窗口图标在任务栏中(通常在屏幕底部)。
  • 根据键盘布局,按下Alt-PrtSc或Alt-PrintScreen 键。
  • 将图片(从剪贴板)粘贴到图像编辑器中。在大多数图像编辑器中(例如, IrfanView ,一款优秀的免费工具),单击“编辑”、“粘贴”或按 Ctrl+V。
  • 将图像保存为 GIF 或 PNG 文件(比 TIFF 或 BMP 文件小得多,比 JPEG 文件更清晰)。
  • 将文件作为附件添加到电子邮件中(或将其直接嵌入到邮件正文中)。

诊断运行

对于导致 DOS 窗口关闭的 Imatest 错误(这种情况已很少见),或者需要额外诊断结果来帮助定位问题的情况,

在某些情况下,您可以通过删除 imatest-v2.ini 文件(或者重命名它,后者更好,因为这样可以保留记录)来解决问题。操作说明请点击此处。

安装其他版本的 Matlab 时出现路径冲突

X过程入口点 svDoubleSclarRemW 无法
位于动态链接库 libmwservices.dll 中

如果您的系统上安装了与Imatest (6.5.1) 所用版本不同的Matlab版本,则极少数情况下可能会遇到路径冲突,导致类似的错误消息,或者Imatest可能根本无法运行。这种情况很少发生,因为启动Imatest的批处理文件会设置路径。有关路径问题及其解决方案,请参阅Imatest IT EXE 说明。

虫子什么的

3.6 版本之前:尝试保存数据时,DOS 窗口中会多次出现以下消息。

函数“get_param”未在独立模式下实现。

这不会影响已保存的图像,而且由于 DOS 窗口始终在后台运行,因此很少会注意到这个问题。Matlab 已在此处描述了该问题,并将在未来的版本中修复。

更多文档

各个Imatest模块的使用说明可以在Imatest 文档页面中找到。