困難排解

Imatest 失敗時該怎麼辦

報告崩潰

如果Imatest崩潰且沒有明顯的解決方法,我們強烈建議您向我們報告崩潰情況。有兩種方法可以報告崩潰。

1. 使用「錯誤報告」視窗傳送崩潰報告

對於大多數錯誤,將開啟如下所示的錯誤報告視窗。

錯誤報告視窗
錯誤報告視窗
許多模組在運行過程中會出現錯誤,這些模組以前可以正常工作,但現在卻無法運行。通常可以透過從 INI 檔案(imatest-v2.ini)中刪除與該模組對應的部分來解決此類錯誤。以下簡要介紹此方法,更詳細的介紹請參閱「以前可以正常工作的模組停止運作了」 。

如果您遇到導致Imatest無法運作的錯誤(且您無法自行解決),我們建議您點擊「傳送錯誤報告」按鈕將錯誤訊息傳送給我們。點擊此按鈕後,將打開一個新窗口,您可以在其中輸入您的電子郵件地址(以便我們與您聯繫)以及錯誤描述。完成後,請點選該視窗中的「傳送錯誤報告」按鈕。

提交錯誤報告視窗:用於發送您的電子郵件地址和錯誤描述。
提交錯誤報告視窗:用於發送您的電子郵件地址和錯誤描述。

如果在分析影像時出現錯誤,我們建議您將影像傳送給我們,最簡單的方法是在Imatest 幫助中心建立工單並附上影像。我們可以快速找到由影像構圖不正確或構圖不佳導致的錯誤。閱讀使用說明總是有益的。

備註:

如果在分析映像時出現錯誤,我們建議您將映像傳送給我們,最簡單的方法是將其作為附件新增至Imatest 幫助中心建立的問題中。我們可以快速找到由影像構圖不正確或構圖不佳導致的錯誤。閱讀使用說明總是有益的。

傳送螢幕截圖(如右圖所示)不如依照上述步驟傳送錯誤報告有效。螢幕截圖無法提供診斷問題所需的所有信息,非英語用戶通常難以理解。 (右圖顯示的是中文視窗)。若要回報錯誤,請按下底部中間的按鈕(紅色橢圓內所示)。

2. 複製、貼上並傳送到Imatest 幫助中心

此方法僅適用於極少數情況下,即上面所示的錯誤報告視窗無法開啟時。

  1. 在 Imatest 中,按「檔案」 ,然後選擇「複製目前會話」 。這會將會話內容(包括錯誤訊息)複製到剪貼簿。
  2. 請在Imatest 幫助中心提交問題。在摘要中描述問題,然後將剪貼簿的內容貼到描述中。
  3. 如果你這樣做,可能會有所幫助。
    1. 請將 imatest-v2.ini 檔案附加到問題中。您可以按下「檔案」 > 「開啟 INI 檔案資料夾」來找到它的位置。
      - 或者 -
    2. 按INI 檔案、複製 Imatest 設定、然後按 atta,將 ini 檔案文字複製到剪貼簿。確保將其與會話文字完全分開。

如果當機導致Imatest視窗關閉,在命令(DOS)視窗(如下)中還有一些其他程式可以報告錯誤。

版本

如果可以,我們建議您執行最新版本的Imatest 。您應該始終執行許可證允許的最新版本(您可以啟動購買日期後一年內發布的版本:請參閱變更日誌)。新版本修復了早期版本中發現的錯誤並進行了功能增強。

版本號碼顯示在主視窗頂部的欄中,建置日期(如果您執行的是 Beta 版本,則特別重要)會在您點擊「幫助」 > 「關於」時顯示。如果您的版本比「更新日誌」中顯示的最新版本舊,我們建議您下載、安裝並執行最新版本。通常情況下,無需卸載舊版本。

如果Imatest停止運作,問題通常是 imatest-v2.ini 檔案( Imatest 4.2之前的版本為 imatest.ini)中的某個條目錯誤,具體說明如下。卸載Imatest通常無濟於事,重新安裝也僅在系統檔案遺失等極少數情況下有效。應始終先解決 Imatest-v2.ini 檔案的問題。從「實用工具」功能表開啟「錯誤報告」會開啟如下所示的窗口,其中包含有關如何處理錯誤的簡明說明以及直接連結。

從 “實用工具” 功能表開啟 “錯誤報告” 錯誤報告和故障排除窗口,其中包含簡潔的說明和直接連結。
從“實用工具”功能表開啟“錯誤報告”
錯誤報告和故障排除窗口,其中包含簡潔的說明和直接連結。

安裝

通常情況下,更新安裝無需卸載舊版本,但如果您遇到問題,可以解除安裝並重新安裝 Imatest。您可以從「開始」功能表( 「開始」>「所有程式」>「Imatest」>「解除安裝」)或控制台的「新增或移除程式」功能存取卸載程式。卸載程式可讓您選擇保留或刪除 Matlab 執行時間庫存檔(3.6 之前的版本中為Imatest-lib.exe )。 (預設選擇「保留」;您需要選取相應的複選框才能將其刪除。)保留該存檔可以加快重新安裝速度。只有當您不打算重新安裝 Imatest 或有充分理由懷疑該檔案可能已損壞(這種情況很少見)時才應將其刪除。點擊此處查看完整的安裝說明。

Imatest 3.6+ 的重要變更

最新版本的 Imatest 僅支援 64 位元電腦。 Matlab 的版本歷史記錄可在維基百科上找到,但其中存在一些遺漏。

Imatest 3.6 及更高版本使用新的 Matlab 編譯器(4.11 及更高版本)取代了舊的 R13 編譯器(3.0.1 版本)。新編譯器需要下載更大的函式庫:約 200MB 的Matlab 編譯器執行時間 (MCR) (一種虛擬機器)。 Imatest 通常編譯為 32 位元應用程序,可在 32 位元和 64 位元電腦上執行。 (64 位元應用程式的效能優勢不大,且無法在 32 位元電腦上運作。)

Imatest Matlab 版本和函式庫 (MCR) 位置
測試
版本
編譯器/函式庫典型位置(64 位元英文安裝的環境變數和檔名)
[在 32 位元電腦上,請將 C:\Program Files 替換為 C:\Program Files (x86)。 ]
2020.2 R2020a 9.8 
2020.1 R2019b 9.7 
5.2 R2019a 9.6 
5.1 R2017b 9.3 
3.10、4.0+編譯器 4.18 V81 %ProgramFiles%\MATLAB\MATLAB Compiler Runtime\v81 [C:\Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v81]
3.7-3.9編譯器 4.14 V714 %ProgramFiles%\MATLAB\MATLAB Compiler Runtime\v714 []C:\Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v714
3.6編譯器 4.11 V711 %ProgramFiles%\MATLAB\MATLAB Compiler Runtime\v711 [C:\Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v711]
3.6 版本之前編譯器 3 %ProgramFiles%\Imatest\toolbox\matlab [C:\Program Files (x86)\Imatest\toolbox\matlab]
注意:Matlab 的命名規則可能非常令人困惑。例如,Matlab R2010b (7.11) 使用的是 Matlab Component Runtime 7.14 和 Compiler 4.14,請參閱http://www.mathworks.com/support/solutions/en/data/1-4GSNCF/?solution=1-4GSNCF

安裝完成後,

  • MCR 應該位於 32 位元系統中的 %ProgramFiles%\MATLAB\MATLAB Compiler Runtime\v714(適用於 Imatest 3.7+;...V711 適用於 3.6)(在英文版 Win32 安裝中,%ProgramFiles% 為 C:\Program Files);或位於 64 Compiler Runtime\v714(或 ...V711)(在英文版 Win64 安裝中,%ProgramFiles(x86)% 為 C:\Program Files (x86))。
  • 在 32 位元系統中, Imatest位於 %ProgramFiles%\Imatest\Imatest(在英文版 Win32 系統中,%ProgramFiles 即 C:\Program Files);在 64 位元系統中,Imatest 位於 %ProgramFiles(x86)%\Imatest\Imatest(在英文版 Win圖4 (x86))。

首次安裝包含新庫(例如 V7111、V714 等)的Imatest 3.6+ 時,請確保在「選擇元件」視窗中選取「Matlab 庫」 。庫安裝需要幾分鐘。安裝與您的版本相符的 MCR 後,更新Imatest時無需再選取此複選框。

如果在安裝 MCR 之前嘗試執行Imatest ,可能會出現以下訊息。重新安裝並勾選“Matlab 庫”複選框即可解決此問題。

由於找不到 mclmcrrt714.dll,此應用程式無法啟動。

安裝過程中出現問題

如果出現以下情況,安裝或註冊可能會失敗:

  • 您的電腦沒有管理員權限。如果沒有管理員權限,您可能會看到類似這樣的訊息:
    開啟檔案寫入時發生錯誤 C:\Program files(x86)\Imatest\Master\imatest.exe
    開啟寫入檔案時發生錯誤 C:\Program files (x86)\Imatest\Master\dcraw.exe 等。
  • 您的電腦位於強大的企業防火牆之後。
3.6 版本之前:此訊息有時會在防火牆配置較高的系統中出現。通常可以透過確保從下載頁面取得的 Matlab 執行階段庫Imatest-lib.exe與 Imatest 安裝檔案位於同一資料夾中來解決此問題。您可能需要暫時停用防火牆並手動下載庫檔案。
安裝錯誤
這是由於防火牆設定過強而出現的另一個錯誤訊息。客戶在家下載時沒有遇到任何問題。解決方法:在辦公室外下載 Imatest,然後攜帶光碟或 USB 到辦公室。

如果您收到「DNS 錯誤」的提示(這種情況非常罕見),請嘗試點擊「開始」 、 「執行...」 ,在「開啟...」方塊中輸入ipconfig /flushdns ,然後點擊「確定」 。

安裝後出現問題

錯誤:找不到 MCR 的版本 mn。

此錯誤可能是由於MCR(Matlab 編譯器執行時,即函式庫)安裝失敗或執行Imatest的批次檔中的路徑問題所引起的。它最有可能出現在Imatest 3.7 和 3.8 的早期版本。

  • 您首次安裝此版本Imatest時,Matlab 程式庫未正確安裝。您需要重新安裝Imatest ,並在「選擇元件」視窗中選取「Matlab 庫」 。 (通常只需在首次安裝時執行一次)。一位客戶嘗試後仍然無法解決問題,他刪除了 MCR(庫)資料夾(位置如下及此處所述),然後重複上述步驟,最終成功解決問題。
  • 嘗試安裝 MCR 時,您的系統存在待處理的 Windows 更新。請確保所有更新完成後再重新安裝。
  • Imatest已安裝在已安裝其他版本 Matlab 的系統上。 (這種情況很少會造成問題。)請檢查執行 Imatest 版本所在資料夾中的 bat 檔案(run_imatest.bat 和 run_diagnostics.bat),確保路徑指向正確的 MCR 位置。

在典型的 64 位元 Windows 7 英文版系統中, Imatest 的安裝資料夾位於 C:\Program Files (x86)\Imatest\Master。不同版本的Imatest 、作業系統和語言的安裝資料夾位置可能有所不同。您需要在系統中尋找該資料夾。

路徑設定在Imatest安裝資料夾中的 run_imatest.bat 檔案(以及 run_diagnostics.bat 檔案)。如果您想要儲存更改,需要以管理員權限開啟該檔案。包含路徑資訊的關鍵行(在我的系統中)是:

@path="C:\Program Files (x86)\Imatest\Master_3.8;C:\Program Files (x86)\Imatest\Master_3.8\bin; C:\Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v714\runtime \win32)\ ;%path%"

此行中高亮顯示的項目是 Matlab 編譯器執行時期 (MCR) 資料夾。您應該檢查這些資料夾的內容。如果C:\Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v714資料夾(或您系統中對應的資料夾)不在此行中(僅在 Imatest 3.8 之前的版本中存在此問題),則應將其加入。


3.6:如果您收到類似「由於找不到 mclmcrrt711.dll,此應用程式無法啟動」的訊息,則需要下載並安裝完整版本,其中包含 Matlab 運行時庫 (MCR)。 Imatest 3.6只需執行一次此操作。下載和安裝可能各需要幾分鐘。升級下載和安裝速度快得多。


3.6+:找不到 mllapack.dll 程式( mllapack.dll La procédure spécifiée est introuvable en Français)。 Imatest啟動正常,但隨後會彈出一個對話框顯示此錯誤訊息並終止。我們已經遇到過兩次這個問題,很難找到原因。最終,我們在這篇 Google 文章和這篇 Matlab Central 文章的末尾找到了一個對一位客戶有效的解決方案(但需要花費一些精力)。

「我發現錯誤源自於 DLL 版本問題(正如我所懷疑的)。windows/system32 目錄下存在一個舊版本的「libmmd.dll」。而 MATLAB Runtime bin/win32 目錄下的版本並沒有被使用。刪除舊版本後問題就解決了。我還沒明白它是因為它們時會出現在那裡,以及為什麼在安裝時太麻煩」。

如果上述方法無效,或許可以再嘗試另一種方法。 這篇 Matlab 文章指出:「崩潰是由 MATLAB 與 CPU 不相容引起的。例如,如果處理器不支援SSE2 指令集,例如 Athlon XP 2200+ CPU,就會發生這種情況。」2003 年之後生產的電腦應該不會出現此問題。


3.6 版本之前:最常見的安裝問題是 Matlab 運行時庫Imatest-lib.exe無法正確下載或安裝。這會導致出現如下形式的錯誤訊息:

“無法在動態連結庫.dll檔案中找到程式入口點…”

如果收到此類訊息,請檢查檔案Imatest-lib.exe是否已正確下載。此外,請檢查防火牆狀態。過強的防火牆可能會導致此問題。

  • 如果是自動下載的(在安裝過程中),則在 Imatest 安裝資料夾(在典型的 win32 英文安裝中為 C:\Program files\Imatest\Imatest)中應該有一個副本。
  • 如果您是手動下載的(通常在有防火牆的系統中需要這樣做),則在與 Imatest 安裝程式相同的資料夾中應該有一個副本,即 Imatest- xx.exe 。

Windows XP 資源管理器顯示檔案大小為 8,513 KB,但將遊標停留在檔案名稱上時出現的工具提示顯示檔案大小為 8.31 MB(真是奇怪)。如果下載失敗,則顯示的檔案大小可能會更小。

如果您找不到 Imatest-lib.exe,或懷疑下載不正確,請右鍵單擊此處或本節中的任何連結進行下載,然後重新安裝Imatest。 Imatest-lib.exe 是一個自解壓縮 zip 文件,它會將 Matlab 運行時庫放置在 Imatest 安裝資料夾的 binwin32 和 toolbox\matlab 子資料夾中。如果問題仍然存在,請檢查這些資料夾是否已存在,然後將 DOS 視窗中顯示的任何錯誤訊息文字透過電子郵件傳送給Imatest 支援團隊。


3.6 版本之前:缺少 DLL 檔案在極少數情況下,Imatest 安裝資料夾的 toolbox\matlab\iofun\private 子資料夾中可能缺少四個 DLL 檔案:jpeg_depth.dll、dataread.dll、imjpg8.dll 和 rjpg8c.dll。由於它們未包含在Imatest-lib.exe中,因此需要使用不同的安裝方法,此方法的失敗率低於 1%。如果您收到提示訊息,表示這些檔案可能缺失,請檢查該子資料夾,如果找不到,請手動安裝。
  • 在Imatest 3.1 或更高版本中,這四個檔案會安裝到 Imatest 安裝資料夾及其子資料夾中。如果這些檔案缺失,可以將它們複製到子資料夾(toolbox\matlab\iofun\private;英文版安裝路徑為 C:\Program Files\Imatest\toolbox\matlab\iofun\private)。
  • 對於早期版本,您可以下載jpegdlls.zip並將內容複製到子資料夾中。

運行時錯誤

無法讀取映像檔。

Matlab通常無法讀取具有非標準檔案頭或其他異常(例如檔案副檔名錯誤,如 PNG 檔案被錯誤地擴展為 BMP)的映像檔。這類文件在商用相機中很少見,但在原型或開發系統中可能會出現。您通常可以使用Irfanview來「清洗」它們,您可以從Irfanview.com免費下載 Irfanview。它是一款非常實用的工具!將檔案匯入Irfanview ,然後儲存。 (如果您需要保留原始文件,可以使用不同的文件名稱。)

選擇區域後,Imatest 停止工作(卡死或崩潰)。

這個問題可能是由有道字典等自動翻譯軟體引起的。

解決方案:

在進行 ROI 選擇時,暫時停用翻譯軟體。有關此問題的更多信息,請參閱“區域選擇錯誤解決方法” 。

Imatest崩潰或運行異常

發生這種情況時,通常保持最小化的命令(DOS)視窗可能會包含一條有助於偵錯的錯誤訊息。要查看其內容,

  • 點擊 Imatest 命令視窗圖標在工作列中。
  • 點選「檔案」 > 「查看目前會話」 ,即可在編輯器(通常是記事本)中開啟會話內容。您也可以點選「檔案」 > “複製目前工作階段」 ,然後將其貼上到您選擇的編輯器中,或提交給Imatest支援團隊。
  • 如果Imatest完全崩潰並關閉,請重新啟動它,然後按一下「檔案」、 「檢視(或複製)上次會話」 。

大多數問題都屬於以下幾類。

  1. 您發現了一個錯誤。許多錯誤可以透過下載並安裝最新版本的Imatest來修復。如果問題仍然存在,請在幫助中心提交一個問題,並附上命令視窗的內容(如上所述),如果適用,還需附上 INI 文件和鏡像文件。詳情請點擊此處。
  2. 用於儲存已儲存設定的Imatest-v2.ini 檔案( Imatest 4.2之前的版本為 imatest.ini)已損壞,無法讀取。請參閱下文「損壞的 INI 檔案」部分,以了解原因和解決方法。
  3. 之前運行正常的模組現在無法正常工作了。這通常是由於 Imatest-v2.ini 檔案中與該模組對應的部分存在錯誤配置所造成的。請參閱下文「先前運作正常的模組現在無法正常運作」部分,以了解具體原因和可能的解決方法。

在 Imatest 3.7 及更高版本中,您無需知道 imatest-v2.ini 的確切位置,因為 Imatest 提供了一整套用於查找、編輯、保存和加載該文件的實用工具。它的確切位置是:

$APPDATA$\Imatest\imatest-v2.ini

其中,$APPDATA$ 是一個環境變量,相當於 Windows Vista/7(英文版)中的 C:\Users\使用者名稱\ AppData\Roaming。 imatest-v2.ini 的完整英文版 Vista/7-10 路徑為 C:\Users\使用者名稱\ AppData\Roaming\Imatest\imatest.ini。在其他作業系統和語言中,路徑名稱可能有所不同。

ini 檔案損壞

在 Imatest 4.2 之前的版本中,如果系統中存在包含非拉丁字元(中文、韓文、日文、希伯來文等)的資料夾或文件,偶爾會出現此錯誤。在 Imatest 4.2 中,此錯誤已完全修復。 DOS 視窗中的典型錯誤訊息格式如下:

解析檔案尋找鍵時發生錯誤:C:\Doc ... Imatest\imatest.ini:使用 ==> inifile>findkeys 時出錯,位於 508
第 38 行出現未知字串
上面標記的錯誤行位於 imatest.ini 檔案中。

在 2012 年 6 月 15 日之後發布的 Imatest 3.9+ 版本中,此問題的大部分情況已解決。這些新版本對 ini 檔案使用 UTF-8 字元編碼,應該能夠處理非拉丁字元。您可能需要按照螢幕上的指示執行一次修復程序。如果問題再次出現(這種情況應該非常罕見),

  • 如果可以,請將所有圖像檔案名稱更改為僅包含拉丁字符(26 個字符,AZ)。
  • 按下 INI 檔案設置,重置預設值,徹底刪除 imatest.ini 檔案可能會有所幫助。

如果在3.7之前的Imatest版本中出現這種情況,請按照下面的INI 檔案修復說明進行操作。

對於Imatest 3.7+,應該會開啟下面顯示的其中一個視窗。

Ini 檔案錯誤訊息

Imatest 3.7 中出現「imatest.ini 檔案損壞」的錯誤訊息(第 2 行)。

該訊息表明第 2 行存在錯誤。按一下「確定」後,ini 檔案將在記事本中開啟。刪除或更正出錯的行(請參閱下文說明),然後儲存檔案。您可以關閉記事本並重新啟動Imatest 。

Imatest 3.9+ 版本中出現「imatest.ini 檔案損壞」的錯誤訊息(第 26 行)。
Imatest 3.9+ 版本中出現「imatest.ini 檔案損壞」的錯誤訊息(第 26 行)。

該訊息表明第 26 行有錯誤。按下「確定」後,將開啟一個特殊的編輯器,該編輯器可以偵測損壞的行,讓您查看它們,然後儲存更正後的檔案。

掃描並修復 INI 檔案視窗。在 Imatest 3.8 及更高版本中解析錯誤後出現。
點擊左下角的粉紅色橫條即可解決問題,最好是預防此問題。
避免在檔案名稱中使用非拉丁字元。

INI 檔案修復: Imatest.ini (以及 rescharts.ini、multicharts.ini 等)包含 Imatest 運行中使用的已儲存設定。這些檔案在 Imatest 首次運行時會建立。設定包括感興趣區域 (ROI)、繪圖選擇、繪圖比例尺、計算方法等等。

ini 文件是文字文件,其格式為每行

  • 是用方括號 ( [...]) 括起來的章節標題,例如 [sfr] 或
  • 格式為,名稱 = 值,例如,nwid_save = 2601。

當一行程式碼不符合此結構時,系統會偵測到錯誤。最常見的原因是缺少等號 (=)。如果您收到錯誤訊息,請按照「掃描和修復」視窗(上方)中的指示進行操作。

  1. 接近Imatest
  2. 任何一個
    1. 刪除INI 文件,該文件通常位於此處: %USERPROFILE%AppDataRoamingImatestimatest.ini實際文件名稱可能因作業系統和語言而異。
    2. 使用文字編輯器從 INI 檔案中刪除錯誤行(通常缺少 = 符號)。
  3. 重啟Imatest
  4. 儲存結果時,請確保使用不包含非拉丁字元(中文、希伯來文等)的資料夾名稱,例如「結果」。

根本原因?我們懷疑問題與區域設置有關。以下是MATLAB 流程如何使用區域設定的一些內容:

  • 預設區域設定— 如果使用者指定的區域設定不受支持,MATLAB 將使用預設區域設定 en_US.US-ASCII。 (這可能會導致非拉丁字元出現問題。)
  • 使用者介面語言設定-使用者介面語言設定應設定為與使用者指定的區域設定相同的語言,或設定為美國英語。否則,非7位元ASCII字元可能無法正確顯示。
  • 支援的字元集— MATLAB 支援使用者區域設定中指定的字元集。但是,MATLAB 可能無法正確處理大於 2 位元組的字元代碼。
  • 腳本相容性— 以一種區域設定建立的 MATLAB 腳本中的非 7 位元 ASCII 字元可能與另一種區域設定不相容。

另請參閱“國際化和I18n 訊息及設定故障排除” ,其中包含以下有趣的聲明:“在 Microsoft Windows 平台上,用戶區域設定和系統區域設定必須相同。如果這些值不同,您可能會看到亂碼或錯誤字元。”

3.7 版本之前:如果 Imatest 崩潰並出現類似「錯誤:解析檔案金鑰 C: 時發生錯誤」的錯誤訊息,則 imatest.ini 檔案已損壞。它可能包含一些不符合標準 ini 檔案格式的文字。您需要打開 imatest.ini 檔案(位置如下)並刪除錯誤代碼。如果您找不到錯誤文本,則可以將其刪除(或重新命名)。如果您懷疑 ini 檔案已損壞,可以嘗試以下幾種方法。
  • 在「設定」 (或在 Rescharts 或 Multicharts 視窗中),按一下「重設預設值(全部)」 。這將刪除 imatest.ini 文件,然後使用一些預設值重新建立它。模組運作時,各個部分將重新填充這些值。由於所有設定都會遺失,因此建議僅在萬不得已的情況下才使用此方法。
  • 點擊“設定”,然後點擊“查看設定(ini 檔案)”。這將在一個簡單的編輯器(記事本)中開啟 imatest.ini 檔案(如果您正在執行 rescharts.ini 或 multicharts.ini 模組,則可能是這些檔案)。您可以編輯該檔案(如果您知道要更改什麼),然後按 Ctrl+S 儲存。您也可以複製其內容並將其貼上到Imatest 幫助中心創建的問題中。
  • Imatest 3.6+ :點選“設定”,選擇“複製設定(ini 檔案)”。這會將 ini 檔案複製到剪貼簿。

之前運行正常的模組現在停止工作了。

該技術的完整描述——如何刪除可能包含損壞設定的 INI 檔案部分——
呈現方式: 一個以前運作正常的模組停止運作了。

通常可以透過刪除 imatest-v2.ini 中的模組部分(在Imatest 4.2之前為 imatest.ini、rescharts.ini 或 multicharts.ini)來解決此問題。

點選「INI 檔案設定」 > “INI 檔案編輯器」開啟 INI 檔案編輯器,如下圖所示。注意:重新安裝 Imatest 很少能解決這類問題。

ini 檔案編輯器是一個功能極其強大的工具,用於編輯 ini(設定)檔案。
通常可以透過選擇該部分來修復損壞的(但以前可以正常工作的)模組。
對應模組,然後按一下“刪除部分”,儲存。

您可以從「章節」下拉式選單(位於頂部附近)選擇要查看或刪除的章節。若要編輯單行,請在大視窗中選取該行,然後在大視窗上方的編輯視窗中進行更改,然後按 Enter 鍵。若要刪除整個選取內容,請按「刪除章節」 。準備好儲存變更後,請按下「儲存」按鈕(在進行變更之前該按鈕呈灰色)。如果您想取消更改,請按下「重新載入 ini 檔案」或「關閉」 。

錯誤處理和報告

如果問題無法解決,請發送電子郵件至Imatest 支援團隊。有關如何操作的詳細信息,請參閱“實用工具”功能表中的“錯誤報告”部分。

  • 請提供錯誤訊息,該訊息通常顯示在命令(DOS)視窗中。 (您可以編輯掉明顯無關的部分。)要取得命令視窗的內容,
    • 點擊「檔案」 ,複製目前會話,然後將其貼到Imatest 幫助中心建立的問題中。
    • 如果 Imatest 完全崩潰並關閉,請重新啟動它,然後按一下「檔案」 、 「複製上次會話」 。
    • 對於舊版本,請按一下 Imatest 命令視窗圖標在工作列中。請參閱下方灰色框中的說明,以了解如何複製內容。
  • 請告訴我們您的作業系統(包含在Imatest 3.9+ 的命令(DOS)視窗中)。
  • 請提供 imatest.ini 檔案( Imatest 4.2之前的版本為 multicharts.ini 或 rescharts.ini)的內容,其中可能包含有助於診斷問題的資訊。在Imatest 3.6 及更高版本中,您可以點選「INI 檔案設定」 > 「複製設定(ini 檔案)」直接將內容複製到剪貼簿。您也可以點擊「INI 檔案設定」 > 「檢視設定(ini 檔案)」在文字編輯器(通常是記事本)中查看內容。
  • 除非錯誤導致 Imatest 命令視窗關閉,否則您無需知道 ini 檔案的實際位置。典型的英文版 Windows Vista/7 位置是C:\Users\您的使用者名稱\ AppData\Roaming 。 [ini 檔案位於 %AppData%\Imatest 目錄下,其中 %AppData% 是一個命令環境變量,您可以透過在命令視窗中輸入dir "%AppData%"來確定其檔案名稱。 ]
  • 如果您懷疑影像有問題(例如,某些影像可以正常顯示,而某些影像則無法顯示),請將其附加到問題中。

命令(DOS)視窗

Imatest 運行於一個命令視窗(類似於傳統的 DOS 視窗)中,該視窗通常保持最小化狀態。當程式意外終止或卡住時,命令視窗可能包含有用的偵錯資訊。若要查看或複製命令視窗的內容,

3.6+:直接從 Imatest 指令(DOS)視窗查看或複製會話。

  • 如果當機後 Imatest 視窗仍然打開,請點擊“檔案” 、 “查看目前工作階段”或“檔案”、“複製目前工作階段”,將其複製到剪貼簿以便貼上到說明中心問題中。
  • 如果當機導致 Imatest 視窗關閉,請重新開啟 Imatest,然後按一下“檔案” 、 “查看上一個工作階段”或“檔案”、“複製上一個工作階段”,將其複製到剪貼簿以便貼上到說明中心問題中。

3.6 版本之前:步驟 1:複製貼上文字(簡單,但有點技巧)

  • 點擊 Imatest 命令視窗圖標在工作列中(通常在螢幕底部)。
  • 在命令視窗中按滑鼠右鍵,然後在上下文功能表中按一下「全選」 。
  • 或者,您可以點擊視窗左上角的圖標,點擊“編輯”,點擊“標記”,然後拖曳遊標選擇要複製的文字。
  • 按下鍵盤上的回車鍵(或Return鍵)。這相當於Windows系統中的Ctrl-C(複製)(但在命令視窗中不起作用)。
  • 使用標準的 Windows 貼上命令(Ctrl-V 或編輯,貼上)將文字貼到您的電子郵件中。
  • 在發送電子郵件之前,刪除明顯無關的文字是可以的。

3.6 版本之前:方法二:複製並貼上螢幕截圖(複雜但可靠)

  • 點擊 Imatest 命令視窗圖標在工作列中(通常在螢幕底部)。
  • 根據鍵盤佈局,按下Alt-PrtSc或Alt-PrintScreen 鍵。
  • 將圖片(從剪貼簿)貼到影像編輯器中。在大多數圖像編輯器中(例如, IrfanView ,一款優秀的免費工具),按一下「編輯」、「貼上」或按 Ctrl+V。
  • 將影像儲存為 GIF 或 PNG 檔案(比 TIFF 或 BMP 檔案小得多,比 JPEG 檔案更清晰)。
  • 將文件作為附件新增至電子郵件(或將其直接嵌入郵件正文中)。

診斷運行

對於導致 DOS 視窗關閉的 Imatest 錯誤(這種情況很少見),或者需要額外診斷結果來幫助定位問題的情況,

在某些情況下,您可以透過刪除 imatest-v2.ini 檔案(或重新命名它,後者更好,因為這樣可以保留記錄)來解決問題。操作說明請點選此處。

安裝其他版本的 Matlab 時出現路徑衝突

X流程入口點 svDoubleSclarRemW 無法
位於動態連結庫 libmwservices.dll 中

如果您的系統上安裝了與Imatest (6.5.1) 所用版本不同的Matlab版本,則極少數情況下可能會遇到路徑衝突,導致類似的錯誤訊息,或者Imatest可能根本無法運作。這種情況很少發生,因為啟動Imatest的批次檔會設定路徑。有關路徑問題及其解決方案,請參閱Imatest IT EXE 說明。

蟲子什麼的

3.6 版本之前:嘗試儲存資料時,DOS 視窗中會多次出現以下訊息。

函數“get_param”未在獨立模式下實現。

這不會影響已儲存的影像,而且由於 DOS 視窗始終在背景運行,因此很少會注意到這個問題。 Matlab 已在此處描述了該問題,並將在未來的版本中修復。

更多文檔

各個Imatest模組的使用說明可以在Imatest 文件頁面中找到。