平坦场地分析

渐晕和传感器不均匀性的测量

本页面介绍如何运行平场分析以及控制该分析的设置,包括交互式界面和自动界面。使用选择器可在两种界面之间切换:选择将应用于整个页面。测量结果的详细说明请参见“平场结果”部分。

Flatfield-Interactive通过交互式界面测量图像不均匀性,这种不均匀性可能由镜头、传感器和光照引起——这些参数与Flatfield测量的参数相同——该界面可以近乎实时地更新。它还可以测量源自EMVA 1288 标准的光响应不均匀性 (PRNU)、 ISO 18844 眩光(薄雾状眩光)等等。

Flatfield-Interactive可以显示像素和颜色阴影轮廓图、像素级直方图、热像素和坏像素、网格和网格轮廓图等等。下表列出了所有显示内容。许多功能在文档中也有描述。  使用 Flatfield和  使用 Flatfield 第 2 部分。

图像准备| 运行| 控制| 设置窗口| 结果
亮度等值线图| 光圈等值线图| 网格等值线图| CSV 和 JSON 输出| 保存结果

用于图像质量测试的 Imatest LED 灯箱,具有均匀的光源指示

为了准备用于平场分析的图像,

以下方法——使用液晶显示器(大多数存在闪烁或表面纹理细腻的问题)或平面反射板(难以均匀照明)——已不再推荐。我们保留这些说明仅供参考。

空白屏幕模块
Imatest屏幕图案显示
  • 如果您使用的是无闪烁显示器,可以使用右侧所示的Imatest屏幕图案模块,在距离显示器 2-8 厘米(1-3 英寸)处拍摄显示器照片,使屏幕充满均匀的白色图像。点击Imatest主窗口右侧的“屏幕图案” ,然后最大化屏幕。您可以根据需要调整色相、饱和度和亮度(H、S 和 L,默认值分别为 0、0、1)。此方法不适用于笔记本电脑,因为笔记本电脑屏幕容易闪烁。
  • 建议使用额外的扩散器,尤其是在使用超广角镜头或可视角度有限的笔记本电脑屏幕时。我们推荐使用安装在镜头附近的乳白色扩散玻璃。乳白色玻璃可从美国的Edmund Optics 公司购买。
  • (这种方法很难获得均匀的照明。)拍摄一张光线均匀的光滑哑光纸(白色或灰色)。注意不要遮挡光线。户外照明(阴影)有时能提供非常均匀的照明。使用超广角镜头获得均匀照明可能是一个挑战;几乎不可能避免遮挡部分纸张。强烈建议使用乳白色漫射玻璃。

图像准备

ITI_lightbox_front

为了获得均匀照明

我们推荐使用Imatest LED 灯箱或灯板。该灯箱具有出色的照明均匀性(97%),调光范围达 300:1,色温可选(通常为 3100K 和 5100K),并且可以与Imatest 动态范围测试图和其他透射式测试图配合使用。灯箱对比信息请点击此处查看。

使用积分球(Imatest 不出售)可以获得最均匀的照明,但 Imatest 灯箱和面板对于大多数应用来说应该绰绰有余,因为它们通常离相机很近。

空白屏幕模块
虽然使用灯箱效果更佳,但配备漫射器的无闪烁显示器也能提供均匀的照明。注意:许多笔记本电脑屏幕采用时分复用技术,也就是说,它们会闪烁。
  • 获得均匀图像的最简单方法之一是使用Imatest 的屏幕图案模块(如图右所示),在 2-8 厘米(1-3 英寸)的距离拍摄显示器。从“实用工具”菜单打开“屏幕图案”模块,然后最大化屏幕。如有需要,您可以调整色相、饱和度和亮度(H、S 和 L,默认值分别为 0、0、1)。此方法最适用于可视角度广的液晶显示器(不适用于笔记本电脑)。
  • 使用漫射器去除屏幕像素。我们推荐使用乳白色漫射玻璃,美国Edmund Optics公司有售。

运行分析

在新主窗口中运行 Flatfield 分析:

从经典界面运行 Flatfield 分析:

关于文件的更多信息:

Imatest Master中的输入对话框

以下描述的设置可在Imatest Studio中使用,即它们存在于所有Imatest版本中。其他设置请参见“使用平面场,第 2 部分” 。

  • 标题默认为文件名。您可以根据需要更改它。
  • 等高线图(绘图区域;默认开启)。通常设置为显示像素和光圈等高线(两个图),但也可以关闭或设置为仅显示。可用设置有:
没有等高线图
显示像素和光圈轮廓
仅显示像素轮廓
仅显示光圈轮廓
  • 等高线图显示选项提供八种显示选项。通常不建议使用 3D 图,因为它们运行速度可能较慢。“归一化”仅指第一层(水平)图(而非显示的数值结果)。
图像上叠加的轮廓(未归一化)
叠加在图像上的轮廓(归一化为 1)
带色条的伪彩色(未归一化)
带色条的伪彩色(归一化为 1)
3D伪彩色带色条(未归一化)
3D伪彩色(带色条,归一化为1)
3D伪彩色着色(带颜色条,未归一化)
3D伪彩色着色(带颜色条,归一化为1)
  • 缩放选项
自动或手动缩放:在缩放设置中设置。缩放比例由缩放按钮设置。
缩放比例:0 - 1 或 255:-4 - 0 光圈值固定缩放:亮度像素图为 0 - 1 或 255;光圈图为 -4 - 0 档光圈值。
缩放(最小值 - 最大值)全自动缩放。
  • 等高线图缩放窗口

    等高线图的手动缩放

    等高线图缩放比例:缩放至 1 或缩放至 255

    设置像素级(第一个)轮廓图的缩放比例。

  • 缩放:打开一个对话框,允许您为两个等高线图选择手动或自动缩放。 “最小值”和“最大值”用于在取消选中“自动缩放”时设置缩放比例。
  • 额外平滑功能会对等高线图施加额外的平滑处理,使其不易受噪声影响(且绘制速度更快)。强烈建议启用此功能。仅当需要兼容旧版本结果时才取消选中此复选框。
  • 启用加速功能后,如果未选择相应的图表,则不会计算某些结果(需要大量计算时间的结果),因此也不会将其保存到 CSV 输出文件中。这可以在生产环境中节省大量时间。如果您需要使用加速功能,请分别在启用和禁用加速功能的情况下运行Flat Field ,并检查 CSV 输出文件,以确认其中是否包含所需的结果。
  • 边角区域(默认 32 x 32 像素)允许您选择要分析的图像边角区域。这些区域会影响图表下方的数值读数(例如:边角:最差 = ...)。可选区域大小包括 10 x 10 像素、32 x 32 像素、1%(最小 10 x 10)、2%(最小 10 x 10)、5% 和 10%。
  • 位置:以图像高度为单位的角部和侧部区域的位置(0、1%、2%、5%、10%、15%、20%)。在Imatest 3.8之前,0% 始终是隐含的(角部和侧部区域始终与图像边界相邻)。
  • 伽玛值(设置区域)。伽玛值的默认值为 0.5,这在数码相机中很常见。伽玛值会影响第二个数值(以光圈值衡量的光线衰减),但对第一个数值没有影响。可以使用Stepchart 软件,通过几种常用的阶梯图来测量伽玛值。(反射图最容易使用,但也可以使用透射图来测量动态范围。)第二个数值下方将讨论计算伽玛值时遇到的一些问题。
  • 裁剪图像边缘附近的像素(左、右、上、下) ( “设置”区域)。仅当在“设置”中选中“不询问裁剪”(使用 LF 输入对话框中的“裁剪...边缘设置”)时可用。如果选中,图像将沿左、右、上、下边缘裁剪指定数量的像素。
  • 裁剪图像边缘附近的像素(左、右、上、下) (此功能通常处于禁用状态。)仅当在“选项 I”中选中“不询问裁剪”(使用 LF 输入对话框中的“裁剪...边缘设置”)时启用。如果选中,图像将沿左、右、上、下边缘裁剪指定数量的像素。

    区域选择的两种方法

    待分析区域(ROI)通常在粗调和精调区域窗口中设置,ROI 是相对于左上角定义的,而不是相对于每个边缘定义的。因此,如果您希望多张图像的 ROI 边界保持一致(例如,您希望 ROI 边界距离图像边缘 4 个像素),则必须针对每种图像尺寸单独设置 ROI。

    瑕疵检测提供了一种指定相对于图像边界的 ROI 的替代方法:crop_borders。当在“选项 I”中选中“使用 LF 输入对话框中的裁剪...边界设置”并勾选“裁剪像素... ”复选框时,该参数会在“均匀性”(或“瑕疵”)窗口底部附近的“裁剪边界附近的像素”中进行设置。否则,crop_borders 将被忽略,而使用标准的 ROI 选择方式。

以下选项在Flat Field 说明中有详细讨论:Imatest Master 。

  • 通道(设置区域)您可以选择红色、蓝色、绿色和 Y(亮度)通道。
  • 热像素和坏像素(设置区域)选中相应的复选框,即可显示热像素(红色x )和/或坏像素(蓝色• )。热像素的定义是绝对的:数值接近或等于传感器的最大值(8 位文件中为 255),而坏像素的数值接近或等于 0。热像素的定义也可以是相对的。您可以选择在任意通道、所有通道或选定通道中检测热像素/坏像素。 dialog_HotDead由于信号处理(尤其是 JPEG 压缩)会导致这些值发生偏移,您可以使用滑块将热像素的检测阈值设置为 6-255 像素,将死像素的检测阈值设置为 0-249 像素。(极端值适用于在白色或黑色背景上进行的测量。)单击滑块末端的<或>可将阈值调整 1 个单位。默认值分别为 252 和 4。设置会在运行之间保存。要使此功能正常工作,JPEG 文件必须以最高质量级别保存;在较低质量级别下,孤立的热像素和死像素往往会模糊不清。详细信息请参见“平场校正”第 2 部分。
  • (地块面积)
    • 颜色渐变显示颜色不均匀的情况。有多种选项可供选择。
    • 颜色均匀性配置文件沿对角线以及水平和垂直中心线显示 R、G 和 B 值(或比率 - 有多种选项)。
    • 显示直方图显示 R、G 和 B 通道的直方图。
    • 精细细节图显示了噪声和传感器均匀性的详细数据,并可选择进行斑点检测。计算速度可能较慢且占用大量内存。在很大程度上,它已被瑕疵检测功能所取代。详情请参阅《平场:Imatest Master》 。

Flatfield Interactive - 文件选择:

非常大的文件(高度x宽度x颜色超过 40 MB)有时会导致较旧的 32 位系统出现内存溢出问题。超过 40 或 80 MB 的文件可以通过在“设置”中的“大文件”(平面、瑕疵等)进行相应的设置,自动线性缩小一半(使用 1/4 的内存)。

在Imatest Master中,可以使用标准的 Windows 操作方式(Shift+单击或 Control+单击)选择多个文件。这样就可以合并(平均)多个文件。( Flatfield-Interactive不支持批量模式。)
合并(平均)文件可用于测量固定模式噪声(建议至少拍摄 8 张相同的低 ISO 感光度图像)。合并后的文件可以保存。其名称与第一个选定的文件相同,并附加后缀“_comb_ n” ,其中n为合并的文件数量。
点击“设置”中的“ROI选项”,即可找到四种裁剪(ROI选择)选项。 通常建议使用第二个选项(2.拖动光标选择裁剪区域。请求对相同尺寸的图像重复裁剪)。
1. 在设置框中使用“启用裁剪边框附近像素”选项(不要询问是否裁剪)。
2. 拖动光标选择裁剪区域(ROI)。询问是否对相同大小的图像重复裁剪[默认]。
3. 拖动光标选择裁剪区域。不要选择重复裁剪。
4. 自动选择被深色边界包围的图像进行裁剪。

输入文件读取完毕后,将显示Flatfield-Interactive窗口,其中显示最近显示的结果。

Flatfield-Interactive 主窗口,显示像素轮廓
(与Flatfield 的第一幅图相同)

结果使用之前的公式显示。  设置(保存在 imatest-v2.ini 中),在这种情况下,像素轮廓图叠加了未归一化的轮廓。

弗拉特菲尔德控制

  • 读取图像文件读取图像,然后执行计算并显示结果。
  • 显示下拉菜单用于选择要显示的结果。选择结果如下表所示。
  • 主显示设置(位于“显示”下方)允许您选择所选显示的最重要设置,例如如何对结果进行归一化、是否显示伪彩色图等。按右侧的“更多设置”即可访问其他设置。
  • 屏幕底部的“均匀性”按钮会打开“平面均匀性设置”对话框(如下图所示)。此对话框包含“主显示设置”下拉菜单中未显示的高级设置。
  • “瑕疵”按钮会打开“瑕疵检测”设置对话框。
  • 均匀性数据提示

    缩放/旋转 3D/数据光标
    点击图像即可选择操作。 “缩放”按钮用于放大图像。按住 Shift 键并单击或双击图像即可缩小。 “旋转 3D”按钮用于旋转 3D 图像(2D 图像会进行缩放)。 “数据光标”按钮会打开一个名为“数据提示”的小窗口,显示图像或曲线的值。右键单击“数据提示”可将其移除或访问其他选项。

  • 可以移除“从设备获取”复选框,因为“设置” > “设备管理器”更适合设置直接获取。
  • 重新加载会重新加载图像。这对于图像采集最为重要,它允许直接从 USB 相机或制造商的评估板等设备读取图像。
  • 保存屏幕保存并可选择显示 Flatfield 窗口。
  • 保存数据将结果保存为 CSV 和/或 XML 文件。 打开“保存”对话框。
  • 点击“帮助”按钮将打开此网页。(其他帮助选项可在顶部工具栏的“帮助”下拉菜单中找到。)
  • 出口离开 Flatfield 窗口。

Flatfield-交互式设置窗口

当您在读取图像时选择“是” (非快速模式)或按下 Flatfield Interactive 屏幕底部的“均匀性”按钮时,设置窗口将打开。它与Flatfield设置窗口类似,但缺少一些显示选项,因为这些选项是在Flatfield-Interactive显示下拉菜单中进行的。

Flatfield Interactive 的 Imatest Master 设置对话框
  • 标题默认为文件名。您可以根据需要更改它。
  • 专家/简化模式简化模式会将初学者可能不需要的高级选项灰显。
  • 标准设置选择常用设置:适合初学者。

地块面积

此区域中的大多数设置适用于在Flatfield-Interactive窗口中选择的显示器。因此, Flatfield中使用的一些显示器选项缺失(或已禁用)。(其中一些选项可能应该禁用。)下面列出的一些设置与Flatfield-Interactive窗口的“主显示器设置”下拉菜单中的设置重复。

  • 等高线图显示选项提供八种显示选项。支持 3D 图。归一化仅指像素等高线显示。
图像上叠加的轮廓(未归一化)
叠加在图像上的轮廓(归一化为 1)
带色条的伪彩色(未归一化)
带色条的伪彩色(归一化为 1)
3D伪彩色带色条(未归一化)
3D伪彩色(带色条,归一化为1)
3D伪彩色着色(带颜色条,未归一化)
3D伪彩色着色(带颜色条,归一化为1)
    • 缩放选项轮廓图缩放(自动/手动等)设置像素轮廓显示的缩放比例。
自动或手动缩放:
按缩放设置。
缩放比例由缩放按钮设置。
缩放比例:0 - 1 或 255:-4 - 0 光圈值固定缩放:亮度像素图为 0 - 1 或 255;
-4 - 0 光圈值,用于光圈值图。
缩放(最小值 - 最大值)全自动缩放。
    • 缩放按钮:打开右侧所示的对话框。您可以选择手动或自动缩放两个等高线图。 “最小值”和“最大值”用于设置未选中“自动缩放”时的缩放比例。
等高线图缩放窗口
等高线图的手动缩放
  • 颜色阴影(图 1):选择红色/蓝色、红色/绿色、绿色/蓝色,或 ΔE 和 ΔC 的几种变体(76(即普通)、94 和 2000)。
    • 显示类型:夸张色彩、伪彩色和 3D 选项。
    • 像素(伽马编码)、强度(线性—使用伽马)和光圈差。
  • (均匀性轮廓下方的下拉菜单)可在几种不同的归一化方式之间进行选择,例如 R、G、B 和 Y,R/G 和 B/G,或者 Delta-L*、a*、b* 和 C*。
  • ( V&H频谱图下方的下拉菜单)选择频率和空间图平滑。
  • 高通滤波器 (HPF) 下拉菜单:启用 EMVA 1288 计算中的高通滤波器 (HPF) 复选框。用于直方图。
  • (网格图右侧的下拉菜单)选择要显示的参数:均值和标准差、ΔC 和 ΔE 等。
  • (网格等值线图右侧的下拉菜单)选择要显示的单个参数(值和等值线)。设置如下所示。
  • 特殊计算:无、CPIQ 或 ISO 17957。
  • 网格图和等高线图的网格大小。从单个区域到 32×18,10×10 为典型值。

精细细节显示可选择夸张的局部噪声(带或不带轮廓线)、伪彩色轮廓、斑点检测(包括非线性处理)或多个 3D 图。

设置区域

  • 伽玛值是指从指定的最大值到深灰色值,以像素值对数与曝光值对数曲线计算得到的平均斜率。它仅影响光圈轮廓图和 ISO 18844 光晕测量;对其他测量没有影响。默认值 (0.5) 是数码相机的典型值。伽玛值可以通过“颜色/色调交互式”或“自动”模式,使用几种常用的灰阶阶梯图之一进行测量,也可以通过旧版模块“阶梯图”或“颜色检查”进行测量。计算伽玛值的一些问题将在光圈轮廓图旁边讨论。
  • 边角区域(默认 32 x 32 像素)允许您选择要分析的图像边角区域。这些区域会影响图表下方的数值读数(例如:边角:最差 = ... )。可选区域大小包括 10 x 10 像素、32 x 32 像素、1%(最小 10 x 10)、2%(最小 10 x 10)、5% 和 10%。
  • 裁剪图像边缘附近的像素(左、右、上、下) ( “设置”区域)。仅当在“设置”中选中“不询问裁剪”(使用 LF 输入对话框中的“裁剪...边缘设置”)时可用。如果选中,图像将沿左、右、上、下边缘裁剪指定数量的像素。
  • 颜色空间会影响颜色阴影、网格和网格轮廓图中的颜色阴影 ΔE 和 ΔC 测量值。

以下选项在 Imatest Studio 中不可用。这些选项在“使用 Flatfield 第 2 部分”中有详细介绍。

  • 通道:您可以选择红色、蓝色、绿色和 Y(亮度)通道。
  • 热像素和坏像素:勾选相应的复选框,即可显示热像素(红色 ¤ )和/或坏像素(蓝色 • )。热像素值接近或等于传感器的最大值(8 位文件中为 255),而坏像素值接近或等于 0。您可以选择在任意通道、所有通道或选定通道中检测热像素/坏像素。
热像素和死像素设置

由于信号处理(尤其是 JPEG 压缩)会导致缺陷像素级别发生偏移,您可以使用滑块将热像素的检测阈值设置为 6-255 像素,将死像素的检测阈值设置为 0-249 像素。(极端值适用于在白色或黑色背景上进行的测量。)单击滑块末端的<或>可将阈值调整 1 个单位。默认值分别为 252 和 4。要使此功能生效,JPEG 文件必须以最高质量级别保存;在较低质量级别下,孤立的热像素和死像素往往会模糊不清。详细信息请参见[此处]。  使用均匀性第 2 部分。

下拉菜单

Flatfield Interactive窗口顶部下方有四个下拉菜单:文件、设置、 INI 文件设置、帮助。

该文件包含多个与文件相关的功能

  • 读取图像文件
  • 打印
  • 将图像保存到文件
  • 保存时域噪声图像。仅当计算时域噪声时适用——即应用信号平均且选中“平均时计算图像²”选项时。
  • 保存伪原始/重新马赛克图像 — 将图像保存为未去马赛克的(拜耳原始图像)。
  • 保存屏幕 — 显示屏幕并可选择保存(大多数情况下我们不会保存屏幕)
  • 打开图像文件文件夹
  • 打开最近保存的文件夹
  • 预览 JSON 结果
  • 查看所有 EXIF 数据
  • 图片统计/查看器
  • 关闭

设置

  • 小号、正常号、大号、特大号字体
  • 重置屏幕 — 将屏幕重置为原始大小和位置(位于主窗口上方)
  • 文件图像
  • 设备管理器 — 打开设备管理器,用于选择图像采集设备、调整设置和预览图像。
  • 从设备获取图像 > 允许您选择用于获取图像的设备。不推荐使用。设备管理器更可靠。
  • 信号平均 > 允许您对多达 128 张直接采集的图像进行平均,以减少噪声,并在基于 EMVA-1288 的非平场计算中分离时间和空间噪声,以及计算噪声图像。
  • 在求平均值时计算图像的平方。这是分离空间噪声和时间噪声所必需的。

输入设置

以下设置在所有 Imatest 版本中均可用:

    • 标题默认为文件名。您可以根据需要更改它。
    • 显示均匀性等值线图(绘图区域;默认开启)。
      开启或关闭主光衰减轮廓图。默认开启(已勾选),但Imatest Master用户如果对其他结果(例如热像素/坏像素和颜色阴影)感兴趣,可以将其关闭。提供四种显示选项。“归一化”仅指第一层(级别)图。
      平面场应用示例,第 1 部分。
图像上叠加的轮廓(未归一化)
叠加在图像上的轮廓(归一化为 1)
带色条的伪彩色(未归一化)
带色条的伪彩色(归一化为 1)
  • 启用加速功能后,如果未选择相应的图表,则不会计算某些结果(需要大量计算时间的结果),因此也不会将其保存到 CSV 输出文件中。这可以在生产环境中节省大量时间。如果您需要使用加速功能,请分别在启用和禁用加速功能的情况下运行Flat Field ,并检查 CSV 输出文件,以确认其中是否包含所需的结果。
  • 伽玛值的默认值为 0.5,这在数码相机中很常见。伽玛值仅影响第二个数值(以光圈值衡量的光线衰减),对第一个数值没有影响。可以使用Stepchart 软件,通过多种常用的阶梯图来测量伽玛值。(反射图最易于使用,但也可以使用透射图来测量动态范围。)第二个数值下方将讨论计算伽玛值时遇到的一些问题。
  • 边角区域(默认 32 x 32 像素)允许您选择要分析的图像边角区域。可选区域大小包括 10 x 10 像素、32 x 32 像素、1%(最小 10 x 10)、2%(最小 10 x 10)、5% 和 10%。这些区域可用作颜色变化ΔE 和 ΔC 计算的参考区域。
  • 裁剪图像边缘附近的像素(左、右、上、下) (设置区域)。选中此项后,图像将沿左、右、上、下边缘裁剪指定数量的像素。设置中提供了多种裁剪(ROI 选择)选项。这些选项包括:
    不要要求裁剪。(请使用 LF 输入对话框中的设置。)
    拖动光标选择裁剪区域。请求对相同尺寸的图像重复裁剪。
    拖动光标选择裁剪区域。不要选择重复裁剪。

    虽然在 Imatest 2.3.12 之前,第一个选项(不要求裁剪... )是默认选项,但第二个选项(拖动光标选择裁剪。要求对相同大小的图像重复裁剪)类似于 SFR 中的 ROI 选择,可能更受欢迎。

统一性设置

均匀性设置窗口(适用于Imatest Master )。

Imatest Master 和 IT 版本提供以下选项:

  • 颜色阴影(不均匀性)显示颜色不均匀性,即三个(R、G、B)通道中两个通道的差值或商,或者L*a*b* 颜色差异指标之一(ΔE = sqrt(ΔL* 2 + Δa* 2 + Δb* 2 )、ΔC = sqrt(Δa* 2 + Δb* 2 )、ΔE 94 、ΔC 94 、ΔE 00 、ΔC 00 ),均以图像中心为参考(可以是中心区域,其大小在“角和边区域”框中指定;也可以是中心 25% 的面积)。颜色阴影通常是由光线照射到传感器的角度造成的。在像素尺寸较小的传感器上,颜色阴影往往最为严重。有多种选项可供选择。 [注:在颜色阴影图中,计算 ΔC 和 ΔE 时使用图像中心作为参考;但在实现 CPIQ Phase 2 规范的网格图中,计算 ΔC 和 ΔE 时使用整幅图像的平均值作为参考。]
    • 颜色阴影选项:不显示(关闭绘图)、红/蓝、红/绿、绿/蓝,或 ΔE 或 ΔC(各种模式和参考区域)。红/蓝(光谱的两端)是最常用的阴影显示方式。 (绘图单位)。在“颜色阴影”框的右侧,可以选择“像素(伽马编码)” 、 “强度(线性)”或“光圈差” 。如果选择了 ΔE 或 ΔC 指标,则这些选项会灰显。
      像素显示所选通道的像素值比率。如果选中“归一化” ,则图表将归一化到 1.0(最大值)。
      强度(线性)使用输入的 Gamma 值去除图像文件的伽马编码,并显示所选通道的强度比。如果选中“归一化” ,则将图表归一化到 1.0(最大值)。
      光圈显示所选通道之间的光圈值差异。如果选中“归一化” ,则图表将归一化为 0(最大值)。
    • 显示选择显示类型。共有四种选择。
      下面列出一些示例。
      夸张的色彩2D. 提高色彩饱和度,以增强色彩不均匀性的可见性。
      伪彩色二维
      3D伪彩色,带阴影,自动缩放。阴影突出轮廓形状。
      3D伪彩色,自动缩放。
    • 归一化(复选框) 如果选中(默认),则阴影图的最大值将被归一化为 1,以用于商值显示(红/绿等)。仅影响图表本身,不影响图表下方的数值。未归一化的最大值、最小值和其他值将显示在图表下方。
    • 额外平滑:此选项会增加轮廓图和阴影图的平滑度。默认选中,强烈建议启用。取消选中后,轮廓图和阴影图会更加粗糙,更容易出现噪声,并且运行速度较慢。此复选框可能会在未来的版本中移除。
  • 色彩均匀性配置文件显示沿对角线、垂直线和水平线的像素级别。具体显示器可在右侧下拉菜单中选择。详情如下。
  • 网格图:以网格形式显示结果。您可以选择网格( m x n )以及每个网格位置要显示的两个参数。
    • 网格大小:单个区域,3x3 至 10x10,20x15,24x16,32x18,15x15,16x16,20x20,25x25,27x27(顺序不一定如此)。
    • 网格计算:
      • 均值(像素级)和标准差,
      • 色差Delta-C 和 Delta-E、Delta-C 94 和 Delta-E 94、Delta-C 00 和 Delta-E 00,均相对于整幅图像的平均值计算。注: CPIQ颜色变异性指标 (D) 为网格图中的最大 Delta-C 值。当选择 Delta-C 和 Delta-E 时,该指标会显示在图下方。
      • 平均值(像素)和色温差(K)
      • R/G 和 B/G 像素比率,
      • 均匀性图像圆 CIELAB a* 和 b*,
      • 平均值(像素级)和信噪比(s/n),平均值(像素级)和信噪比(dB)。
    • 最小阈值(0-1) (默认值=0)。网格图分析中包含的像素最小阈值。可用于自动排除图像中的暗区,例如右图所示。

我们可以根据要求添加更多网格图测量数据。

  • 直方图可用于诊断坏点(热像素和死像素)。具体描述如下。
  • 精细细节图显示噪声和传感器不均匀性的细节图像(示例如下)。图像密度缓慢变化(渐晕,低空间频率)会被去除,因此只保留短程到中程的变化,例如传感器噪声、灰尘斑点等。由于 Matlab 计算采用双精度浮点运算,每个颜色像素需要 24 字节(每个通道 8 字节),因此计算速度可能较慢且占用大量内存。
    夸大的局部噪声(标准)
    局部噪声及其轮廓
    带有色条的伪彩色轮廓
    带阈值的斑点检测(伪彩色)
    (另有几台3D显示器)

    有多种显示选项可供选择。第一种选项将噪声放大 10 倍。第二种选项将轮廓图(来自图像的平滑版本)叠加在噪声图像上。第三种选项生成局部不均匀性(同样经过平滑处理)的伪彩色图像,并在右侧显示颜色条(图例)。第四种选项突出显示暗点,通常由灰尘引起。还可以在精细细节图下方添加直方图。

  • 通道:您可以选择红色、蓝色、绿色或 Y(亮度)通道。颜色空间:用于从 RGB 颜色空间转换,其中显示 L*a*b* 颜色差异指标。
  • 热像素和坏像素通过勾选相应的方框,您可以显示热像素或亮像素(红色x )和/或坏像素或暗像素(蓝色 • )。
    dialog_HotDead该定义取决于选择的是绝对像素阈值还是相对百分比阈值:

    显示热像素或坏像素 (o):绝对像素阈值
    热像素值固定为传感器的最大值(8 位文件中为 255),死像素值固定为 0。由于信号处理(尤其是 JPEG 压缩)通常会导致这些值发生偏移,因此您可以使用滑块将热像素的检测阈值设置为 6-255 像素,将死像素的检测阈值设置为 0-249 像素。(极端值适用于在白色或黑色背景上进行的测量。)单击滑块两端的<或>可将阈值调整 1 个单位。默认值分别为 252 和 4。
    显示亮像素或暗像素 (o):相对阈值百分比
    亮像素是指高于 8 个相邻像素平均值的相对百分比阈值;暗像素是指低于 8 个相邻像素平均值的相对百分比阈值。
    聚类(在Imatest 4.0+中)定义为两个或多个相邻像素的组。

    为了使此功能正常工作,JPEG 文件应以最高质量级别保存;在较低质量级别下,孤立的热像素和坏像素往往会模糊不清。热像素和坏像素的详细信息如下所示。您可以选择在满足任意颜色通道(默认)、所有通道或选定通道的条件时,将像素计为热像素或坏像素(亮像素或暗像素)。

保存结果

按下“保存数据”按钮后,右侧会弹出对话框。您可以在此选择要保存的结果类型(CSV 和/或 JSON 文件)以及保存位置。默认保存位置是数据文件目录下的“Results”子目录。您也可以将结果保存到其他目录。CSV 和 JSON 数据保存的文件名称由根文件名、绘图类型和通道(R、G、B 或 Y)后缀以及文件扩展名组成。

例如: IMG_9875_ISO1600_RGB_f-stop_ctrG.png 。根文件名默认为图像文件名,但可以使用“结果根文件名”框进行更改。请务必按回车键。单击“是”或“否”后,主窗口将重新出现。

运行结束后,会弹出一个保存结果的对话框。您可以在其中选择要保存的图像以及保存位置。默认位置是图像文件夹下的“Results”子目录。您可以取消选中“Results”子目录复选框,将其更改为其他现有目录。这些选择会在下次运行时保存。

在勾选或取消勾选复选框之前,您可以先查看输出图形。图形、CSV、XML 和 JSON 结果将保存到文件中,文件名由根文件名、绘图类型和通道(R、G、B 或 Y)后缀以及文件扩展名组成。例如: IMG_9875_ISO1600_RGB_f-stop_ctrG.png 。根文件名默认为图像文件名,但您可以使用“结果根文件名”复选框进行更改。请务必按 Enter 键。对于批量运行,建议勾选“保存后关闭图形”以防止图形文件堆积(这会降低大多数系统的运行速度)。单击“是”或“否”后,主窗口将重新出现。

图形可以保存为 PNG 文件(一种标准的无损压缩图像文件格式)或 Matlab FIG 文件,后者可以使用“实用工具”菜单中的“打开图形文件”功能打开。虽然可以对图形文件进行编辑(缩放和旋转),但它们通常比 PNG 文件占用更多存储空间,因此不建议使用。

CSV 和 XML 文件包含EXIF 数据,即图像文件元数据,其中包含重要的相机、镜头和曝光设置。默认情况下, Imatest使用一个名为 jhead.exe 的小程序来读取 EXIF 数据,该程序仅适用于 JPEG 文件。要从所有图像文件格式中读取详细的 EXIF 数据,我们建议您下载、安装并选择Phil Harvey 的 ExifTool ,具体操作请参见此处。