Imatest 取扱説明書 - はじめに

Imatestソフトウェアは、テストチャート画像からデジタルカメラの多くの画質要素を測定できます。

これから始める方は、以下を調べてみることをおすすめします。

画像品質要因ページと初心者向けIQテスト。

最もよく利用されているチャートタイプ/分析モジュールは、 SFRplusとeSFR ISOの2種類です。これらを使用すると、単一のテストチャート画像から非常に多くの画像品質要素を測定できます。その他のモジュールやチャートを使用すれば、多種多様なテスト課題に対応できます。

このページ内のコンテンツへのリンク:

Imatestのワークフロー

Imatestの基本的なワークフロー
1. テストする必要のある画像品質要素(シャープネス、色再現性、階調再現性、ノイズ、光学歪みなど)を特定する。
2. テストを実行するために必要なテストチャートを選択してください。チャートはImatestストアで入手できます。
3.グラフを撮影する際は、目的の分析モジュールの指示に従って構図を決めてください。初心者の方は、いくつかのモジュールのサンプル画像をGitHubからダウンロードできます。
4. Imatestを開き、 適切なモジュールを使用して画像を解析してください。
5.結果は、経験に基づき、同等のカメラとの比較によって解釈してください。
6.必要に応じて、数値とテキストで構成される結果(CSVまたはJSON形式)を保存してください。

ダウンロードと試用版 — Imatestはここからダウンロードできます。インストール手順はこちらです。新規ユーザーの場合は、14日間の無料試用期間が自動的に開始されます。  ソフトウェアを初めて実行する際に、この手順が適用されます。準備ができたら、ストアからImatestライセンスを購入し、以下のリンクに記載されている手順に従ってアクティベートしてください。

オンライン認証|オフライン認証|オンライン非認証|オフライン非認証|フローティングライセンス|プロキシサーバー|ナレッジベースには、認証に関する問題を解決するのに役立つリンクがいくつか掲載されています。
 

ライセンス認証に関する注意事項: Imatest ノードロックライセンスは、一度に 1 台のコンピュータでのみ認証できますが、認証はコンピュータ間で移動できます。Imatestは、必要な数のコンピュータ (Macintosh と Windows) にインストールして、インストールしたままにしておくことができます。認証を別のコンピュータに移動するには、上記の手順に従って、古いコンピュータで認証を解除してから、新しいコンピュータで認証する必要があります。Imatestフローティングライセンスは、認証解除と再認証の手順が不要なため、複数のコンピュータ間でより簡単に共有できます。さまざまなライセンスの種類については、こちらをご覧ください。

ほとんどのエンジニアはGUIベースのImatest Masterを使用しています。

Imatestのその他のバージョンには以下が含まれます。

Imatest Studioは、個人写真家がカメラやレンズをテストするために必要な機能をすべて備えている(ただし、カメラの設計や製造に必要な高度な機能は多く欠けている)ソフトウェアで、個人写真家や小規模スタジオが利用できる。

Imatest IT (Industrial Testing)は、Imatestソフトウェアの非GUIバージョンであり、製造環境向けに設計されています。ITインターフェースについては、このページでは説明しません。

Imatest メインウィンドウ

Imatest Main Window▶
Imatest メインウィンドウ

Imatestのメインウィンドウからは、Imatestのすべての機能にアクセスできます。メインウィンドウは2021.2リリースで更新されました。新しいImatestメインウィンドウについては、こちらをご覧ください。

メインメニューで「クラシックUI」を選択することで、オリジナルのImatestインターフェースを使用することもできます。クラシックメインウィンドウに関するドキュメントはこちらです。

クラシックなImatestメインウィンドウ。
画像をクリックすると拡大表示されます。

対話型 vs. 自動(バッチ)

Imatestのほとんどの分析は、対話モードまたは自動(バッチ)モードのいずれかで実行できます。

詳細については、「固定モジュールとインタラクティブモジュール」をご覧ください。

バージョン2021.2では、 Imatestに新しいメインウィンドウが導入され、画像の選択と分析がより簡単になりました。

新しいImatestメインウィンドウ(2021.2)では、分析カードの下部付近にある「対話型/自動(バッチ)」スイッチオプションを設定して、目的のモードを選択してください。

対話型分析と自動(バッチ)分析のオプション
(これらは、後述の「ROIオプション」で説明する自動領域選択と手動領域選択とは混同しないでください。)

対話モード

このモードを使用すると、ファイルから、または取得デバイスから直接画像を読み込んで分析したり、設定や結果をインタラクティブに確認したりできます。

自動(バッチ)モード

このモードを使用すると、事前に設定された設定(自動実行/バッチ実行前)に基づいて、個々のファイルまたはファイルのバッチに対して効率的に分析を実行できます。

新しいImatest GUIで、解析(eSFR ISOなど)を選択し、解析カードのモードを「対話型」に設定します。新しいImatest GUIで、分析(eSFR ISOなど)を選択し、モードを自動(バッチ)に設定します。

クラシックImatest UIウィンドウを使用している場合は、右側の列(インタラクティブ)にある「分析」をクリックしてこのオプションを選択します。

例: eSFR ISO設定

クラシックImatest UIウィンドウを使用している場合は、このオプションは、一番左の(固定)列にある「解析タイプ」をクリックすることで選択できます。

例: eSFR ISO 自動

両方のモードが利用可能な場合は、設定と結果を確認するために、まず対話モードを実行してください。
自動(バッチ)モードでは、対話モードで設定されたほとんどの設定が使用されます。
解析の実行中にパラメータを変更することができます。このモードで実行する前に、パラメータを設定する必要があります。

結果はインタラクティブなウィンドウで確認できます。

結果はCSV、JSONファイル、またはHTMLやPDF形式のレポートとして保存することもできます。

結果は固定図、CSVファイル、およびJSONファイルで提供されます。
解析対象となる画像は、画像ファイルから取得することも、デバイスマネージャを使用して設定する直接取得によって取得することもできます。

ファイルからのみ画像を読み込みます。

バッチ読み取りは利用できません複数の画像ファイルを選択することで、画像のバッチを分析できます。
信号平均化は高速で便利です複数の画像ファイルの信号平均化をサポートします。

グラフとモジュールの選択:何を測定したいですか?

このガイドは、初心者が自分のニーズに最も合うチャートを選択できるよう支援することを目的としています。画像品質要因とシャープネス 主要な測定値に関する詳細な情報が含まれています。

すでにグラフを選択済みの場合は、この表をスキップしてください。

測定値、チャート、モジュールのガイド(測定値別索引付き)
インタラクティブなモジュールは、「クラシックインターフェース」列で強調表示されています。
測定チャート

新しいメイン

ウィンドウ

クラシックインターフェース

鋭さ(あらゆる斜めの刃先から)
手動でのROI検出。旧規格のISO 12233:2000チャートを含む、あらゆる傾斜エッジに対応します。複数の画像を分析する必要がある場合、ROIの選択はやや複雑になることがあります。
垂直MTF測定用の切り抜き斜めエッジ画像

「シャープネス」の分析オプションで、「適切なターゲット」を選択します。

SFR

再チャート

シャープネス、横色収差、色調、色彩など...

これらの斜めエッジチャートは、ROIの自動検出機能を備え、複数の画像品質測定を実行します。インタラクティブモード(「設定」で表示)または固定モード(「自動」で表示)のどちらでも実行できます。ここでは、それらの比較を示します。

それぞれに特有の強みと用途がある。

SFRplusは、空間的な鮮明度と歪み測定において最も優れた性能を発揮します。

eSFR ISOは、詳細な色とノイズの測定を行い、エイリアシングとモアレを測定するためのウェッジも含まれています。

SFRregは超広角用途に使用できます。長距離測定用に、大型のSFRregチャートを印刷することも可能です。

チェッカーボードは、最も正確な歪み測定機能を備えています。

SFRplus 、 eSFR ISO 、チェッカーボード、ドットパターンチャートは、画像全体(またはほぼ全体)を埋めるように設計されています。その他のほとんどのチャートは、画像の一部のみを埋めるように設計されています。

分析オプションで

「注目の」

SFR Plusターゲットを選択してください。

SFRplusの設定

SFRplus Auto

分析オプションで

「注目の」

eSFR ISOターゲットを選択してください。

eSFR ISO設定

eSFR ISO 自動

分析オプション

「注目の」

SFR Regターゲットを選択してください。

SFRreg セットアップ

SFRreg Auto

分析オプションで

「おすすめ」で、チェッカーボードターゲットを選択してください。

チェッカーボードセットアップ

チェッカーボードオート

質感、鮮明度

対数周波数コントラストとこぼれたコイン(またはランダム/枯葉チャート)。斜めのエッジでは細かい質感の反応を測定できないため、重要です。

分析オプション

「シャープネス」で、「Log Fコントラスト」ターゲットを選択します。

対数Fコントラスト

リチャート – ログFC

分析オプション

「シャープネス」を選択

ランダム/枯葉ターゲット。

ランダムな/枯れ葉

リチャート – ランダム

シャープネス、
情報処理能力

シーメンス・スターチャート。

分析オプションで

「シャープネス」を選択

星図の目標。

星

リチャート – スター

シャープネス、
エイリアシング、モアレ
ウェッジもeSFR ISOの一部です。
対数Fコントラストチャート分析オプションで

「鋭さ」

ウェッジターゲットを選択します。

ウェッジ

リチャート – ウェッジ

シャープネス(相対値)
任意の画像から

画像のバッチを高速に比較する
測定値は標準規格ではありません。

対数Fコントラストチャート

ユーティリティメニューの「イメージツール」で、

最もシャープなファイルを見つける

最もシャープなファイルを見つける

色の反応、
音調応答(OECF)、ノイズ、
カラー補正マトリックス(CCM)

カラー/トーンのインタラクティブモードと自動モードは、非常に多くのグレースケールステップチャートとカラーチャートに対応しています。ここではその一部のみを紹介します。

カラーチェッカーSG
カラーゲージ_120W ChromaDuMonde 28テストチャート
分析オプションで

色、

適切な対象を選択してください。

(Colorchecker 24、Colorchecker SG、

一般MxNカラー、

その他にも多くの選択肢があります)

色調自動

色調インタラクティブ

ダイナミックレンジ

多層透過型写真フィルムチャートを用いて測定。
ダイナミックレンジの測定について詳しくはこちらをご覧ください。

dynamic_35_E_200W
ダイナミックレンジのページを参照してください。

色調自動

色調インタラクティブ

ステップチャート(レガシーモジュール)

色彩とトーンの反応
Colorcheckは、 X-Rite 24パッチColorcheckerのみをサポートしています。
色調は新作におすすめです。

分析オプションで

色、

「Colorchecker 24 via Colorcheck」ターゲットを選択します。

カラーチェック
(旧型モジュール)は、24パッチのX-Riteカラーチェッカーでのみ動作します。

音色応答(OECF)とノイズ
ステップチャート。新規作品には色調/トーンの使用をお勧めします。

Image of the Q-13 Gray scale分析オプションで

トーン、適切なターゲットを選択してください。

ステップチャート
(レガシーモジュール)は、複数のグレースケールステップチャートに対応しています。

照明の均一性、
色の濃淡、欠陥ピクセル

フラットフィールド画像を解析するための多用途モジュール

光量低下等高線図分析オプション

均一、

均一性ターゲットを選択します。

均一

ユニフォーミティ・インタラクティブ

これらのモジュールはフラットフィールド画像に対応しています。

傷(センサーの欠陥)
設定は、目に見える傷は検出され、目に見えない傷は無視されるように慎重に調整されています。
元のテスト画像(トリミング済み)分析オプション

均一性/欠陥、

フラットフィールドターゲットを選択してください。

シミ検出

フラットフィールド画像に対応しています。

ねじれ、
横方向の色収差

複数の規格に対応。画像全体(またはほぼ全体)をカバーするように設計されています。

分析オプション

ねじれ、

ドットパターンターゲットを選択します。

ドット柄

ねじれ
歪みの測定方法について詳しくはこちらをご覧ください。

チェッカーボードは、従来の歪み補正モジュールよりも堅牢で正確であり、(より歪んだ画像にも対応できます)。

分析オプション

ねじれ、

チェッカーボードターゲットを選択してください。

チェッカーボードセットアップ

チェッカーボードオート

歪み(レガシーモジュール)

カスタムチャート

複数の画像品質測定

分析オプションで

「注目の」

任意チャートのターゲットを選択します。

任意チャートに関する注記:

Imatestチャートは、複数のサイズと媒体で入手可能です。

    • ガラス上のクロム(最大4x4インチ(100x100mm、超微細、グレースケールなし))
    • カラー写真フィルム(最大8×10インチ、高画質、低ノイズ)
    • 白黒フィルム(最大12x20インチ、カラーよりもノイズが多い、NIRおよびSWIR(近赤外線および短波赤外線)に適している)
    • 写真用紙(インクジェットよりも細かく、近赤外線と短波赤外線に適している)、
    • インクジェットプリンター(高さ44インチまで対応。非常に小さなチャートには粗すぎるため適していません)。インクジェットチャートはご自身で印刷することもできますが、最高品質を求める場合は、Imatestストアで購入することをお勧めします。

チャートの適合性に関するご質問は、 [email protected]までお気軽にお問い合わせください。カメラの画素解像度と視野角をお知らせください。

Imatestを実行中

Imatestは、

  • ImatestアイコンをダブルクリックするImatest_icon_16デスクトップ上で、
  • Windows スタートメニューから:スタート→すべてのプログラム→ Imatest →バージョン→ Imatest_icon_16右図はImatest Editionです。
  • または、win64 英語版のインストールの場合、通常は C:\Program Files (x86)\Imatest version (ここでversionは Master、IS、Studio など) にある Imatest ディレクトリから入手できます。

数秒後(初回インストールまたは再起動後、最大1分後)、下図に示すImatestのメインウィンドウが開きます。

新しいImatestメインウィンドウでは、画像を選択し、実行する解析を選択できます(どちらから選択しても構いません)。「解析」ボタンをクリックして実行します。ROIの選択やその他の設定が必要な場合は、ユーザーが入力するためのウィンドウが表示されます。(従来のUIを使用している場合は、左側の2列にあるボタンのいずれかをクリックしてImatest解析モジュールを実行します。)

目次。

Imatestのサポートを探す

  • Imatestに関する包括的なヘルプは、ドキュメントページ(目次)に掲載されています。
  • Imatestソフトウェアの上部メニューにある「学習」アイコンには、重要なオンラインドキュメントへのリンクがあります。
  • ツールチップ(マウスカーソルをボタンの上に重ねたときに数秒間表示されるテキストブロック)には、ボタンの機能に関する簡潔な説明が含まれています。
  • クラシックUIでは、 Imatestメインウィンドウ(右側のタブ付きボックスを含む)のほとんどのボタンを右クリックすると、そのボタンの機能に関するヘルプドキュメントが開きます。
  • 動画とオンライン研修が利用可能です。

初心者の方は、いくつかのモジュールのサンプル画像をGitHubからダウンロードできます。

ご質問ですか?多くの場合、ドキュメントページを検索するか、ウェブページの右上にある虫眼鏡アイコンを使用してウェブサイト全体を検索することで回答が見つかります。それでも解決しない場合は、

技術サポートに関するご質問は、[email protected]までお送りください。
販売に関する質問(購入、更新など)は[email protected]までお送りください。
テストチャートに関する質問、特にテストチャートのカスタマイズに関する質問は、 charts at imatest dot comまでお送りください。

これらのメールはそれぞれ複数の人に送信されます。特定の人に連絡を取ろうとしている場合でも、これらのメールを1通含めておくと、相手が不在の場合でも迅速な返信が得られる可能性が高くなります。他にも役立つリソースをいくつかご紹介します。

動画–オンライントレーニング–コンサルティング

保存された設定: imatest-v2.ini

設定はimatest-v2.iniという名前のINIファイルに保存されます。詳細については、 「保存された設定(INIファイル)」 および「データ」タブの「設定の管理」ボタンを参照してください。

設定項目には、フォントサイズ、画像の開閉用フォルダ、計算パラメータ、プロット選択、表示・保存する図などが含まれます。INIファイルドロップダウンメニューからは、いくつかのINIファイルユーティリティにアクセスできます(詳細は後述)。INI ファイルエディタまたは「設定の表示(iniファイル)」を使用して設定を表示または編集したり、 iniファイルを保存または読み込んだり、その他多くの操作を行うことができます。

トラブルシューティングやエラー修正に関連するさまざまな機能を実行できます。これらの機能については、 「保存された設定(INIファイル)」 、 「トラブルシューティング」 、および重要なナレッジベース記事「以前は正常に動作していたモジュールが動作しなくなった」で説明されています。上級ユーザーにとって役立つINIファイルインデックスには、 INIファイルモニターの説明が含まれています。

ドロップダウンメニューを表示する

「表示」ドロップダウンメニューには、フォント、ウィンドウ、図のサイズに影響する重要な設定が含まれています。フォントサイズは画像に合わせて適切なサイズに設定する必要があります。小さすぎるとテキストが読みにくくなり、テキスト用に確保されたスペースが活用されません。また、大きすぎるとテキストが他のオブジェクトを覆ってしまうため、適切なサイズに設定してください。

ウィンドウサイズドロップダウン
Imatestのメインウィンドウは、大きな(120dpi)フォントサイズで表示されます。
Imatestの非常に初期のバージョン

Imatestには、さまざまなコンピューターのDPIスケーリングに合わせてフォントサイズとウィンドウサイズを調整するための設定がいくつかあります。

これらにアクセスするには、(メインウィンドウの上部バーにある) 「表示」をクリックすると、左側に表示されているドロップダウンメニューが開きます。設定:

  • フォントサイズ:数字の中で正しく表示されるように設定してください。つまり、小さすぎたり大きすぎたりしないようにしてください。
  • 通常画面または拡大画面( Imatestメインウィンドウ)。
  • 標準サイズまたは拡大サイズ(1.25倍または1.5倍)。拡大表示の場合は、フォントサイズを大きくする必要がある場合があります。
  • 通常または拡大されたインタラクティブウィンドウ(カラー/トーンインタラクティブ、リチャート、バッチビューなど)

画像ファイルを開く

ほとんどのImatest解析モジュールは、イメージファイルを開く必要があります。

モジュールを開くとき(場合によっては)、または画像ファイルを開くボタンを押すとき(場合によっては)、画像ファイル名の入力を求めるダイアログボックスが表示されます。サポートされている画像ファイル形式は以下のとおりです。

サポートされている画像ファイル形式

詳細については、 「画像ファイル形式と取得デバイス」を参照してください。概要:

  • Matlabのimreadステートメントでサポートされているファイル形式。使用頻度の低い形式はグレー表示されます。
  • LibRawを使用して変換された商用RAWフォーマット。これにはCR2、NEF、RW2など多数が含まれます。LibRaw 0.20でサポートされているカメラについては、こちらをご覧ください。新しいカメラは通常、発売後1~2か月以内にLibRawに追加されます。
  • 「汎用RAW読み取り」ウィンドウで指定された拡張子によって識別されるバイナリファイル。拡張子ごとに、ピクセルサイズ、ビット深度、デモザイキングパラメータ、オフセットなどを設定できます。
  • TGA (タルガ)
  • DPX 、 Video DNG *、 ARI * などのビデオ形式(*LibRaw を使用して変換)
  • CSV (一部の赤外線システムで使用される特殊なフォーマット)
  • HDR(ハイダイナミックレンジ)ファイル
  • 画像取得装置の種類は非常に多く、ここにすべてを列挙することはできません。
複数ファイルの読み込み(バッチモード)読み込むファイルを複数選択できます。以下の複数画像ダイアログボックスへの応答に応じて、

ファイルは同じフォルダにあり、ピクセルサイズが同じ(ほとんどのモジュールの場合)で、フレームも同一である必要があります( SFRplusや自動検出を使用するその他のモジュールを除く。これらのモジュールでは、ファイルサイズは任意です)。「ファイルの結合」を選択すると、結合されたファイルをデフォルトで16ビットTIFF形式で保存するオプションが表示されます。バッチモードは、ReschartsやColor/Tone Interactiveなどのインタラクティブモジュールではサポートされていません。

結合されたファイルの場合、保存されるファイル名は、最初に選択されたファイル名に「_comb_n」が付加されたものになります。ここで、nは結合されたファイルの数です。

  • 追加の入力データを入力してください。エクスプレスモードが選択されていない限り、モジュールに応じて設定ウィンドウが開き、設定データが保存されます。ほとんどの追加データはオプションであり(以前の実行から保存されます)、変更したい設定のみに注意してください。 「OK」をクリックするとプログラムが実行され、 「キャンセル」をクリックすると実行が終了します。
  • 結果を保存しますか?解析を実行すると、結果を保存するかどうかを尋ねるダイアログボックスが表示されます。ダイアログボックスのチェックボックスを使用すると、保存する図、CSV (Excel で読み取り可能)、およびJSONファイルを選択できます。保存するかどうかを決定する前に、結果を確認できます。(評価版では保存ボックスは省略されています。) 図は PNG (ロスレス圧縮) 画像ファイルまたは Matlab Fig ファイルとして保存できます (サイズが大きいため推奨されません)。Fig ファイルは、 Open Fig fileを使用して開いて操作できます。

便利なボタン

新しいメインウィンドウで、 「学習」タブをクリックすると、Imatestの画像解析、チャート、IQF、および規格について学ぶことができます。教育用アプリへのリンクもあります。または、上部のメニューバーにある「ヘルプ」メニューをクリックしてください。

以下のボタンは、クラシックUIでヘルプにアクセスするために使用します。

画像右側のタブにあるこれらのボタンはそれぞれ、多くの説明と様々な機能を開くボタンが掲載された大きなヘルプウィンドウを開きます。これらのボタンの使い方を覚えておき、必要に応じて活用してください。

ヘルプガイド(ヘルプタブ内)をクリックすると、登録クイックスタート | Imatestの手順 |画像品質要因| Imatest ツアー |目次(サイトマップ) | FAQ |変更履歴 | レンズのテスト| MTF カーブと外観| SFRplus | トラブルシューティングなど、最も役立つ説明 Web ページへのリンクと、それらの内容の簡単な説明を含むウィンドウが開きます。

[設定の管理] ( [データ]タブ内) をクリックすると、 Imatest設定を保存するためのファイル imatest-v2.ini の内容を設定および確認するための主要な機能について説明するウィンドウが開きます。また、imatest.ini への完全なパス名が表示され、imatest-v2.ini が破損した場合に発生する可能性のあるバグを修正する方法も表示されます。機能ボタンには、[設定の保存...]、[設定の読み込み...]、[設定の表示/編集 (ini ファイル)]、[設定のコピー (ini ファイル)]、[設定のインポート/マージ]、[モジュールの編集/リセット]、[デフォルト設定のリセット (すべて)] があります。

エラー処理( 「データ」タブ内)をクリックすると、エラーが発生した場合の対処方法を示すウィンドウが開きます。このウィンドウには、変更ログとトラブルシューティングページへのリンク、現在のセッションまたは前回のセッションをクリップボードにコピーしてメールに貼り付けるためのボタン、およびimatest.iniファイルが破損した場合の修復手順が含まれています。

生ファイル

RAWファイルは、デジタルイメージセンサーの未処理の出力です。ベイヤーセンサーの場合、各RAWピクセルはRGRGRG、GBGBGB、...の順序で単一の色を表します。使用可能な標準ファイル形式(TIFF、JPEGなど)に変換するには、RAWコンバーターでRAWファイルを処理する必要があります。RAWコンバーターは、デモザイキング(ベイヤーシーケンスをフルカラーに変換)、ガンマカーブの適用(多くの場合、追加のトーンレスポンスカーブも適用)、色補正とホワイトバランス、ノイズ低減、画像のシャープ化など、いくつかの機能を実行します。これらの操作は、 Imatestの測定値、特にシャープネス(MTFまたはSFR)に影響を与えます。

画像ファイルがRAWファイルに忠実に再現されていること、つまり処理が最小限に抑えられていることを確認する最良の方法は、RAWファイルをImatestに読み込み、商用RAWファイル(拡張子:CR2、NEFなどで識別される)の場合はLibRaw 、それ以外の場合はGeneralized Read Rawを使用して標準フォーマット(通常はTIFF)に変換することです。  バイナリ現像ファイル(拡張子で識別され、多くの場合RAW)の場合。商用RAWファイルの場合は、右側のダイアログボックスが表示されます。このダイアログボックスでは、複数のRAW変換オプションから選択できます。商用ファイルとバイナリファイルの詳細については、 「RAWファイル」を参照してください。

生のファイルは、デモザイキング(標準のRGB形式)を使用して変換することも、デモザイキングを使用せずに変換することもできます(これにより、元のR、G(R)、B、G(B)チャンネルを個別に分析できます)。

Exitはすべての図を閉じ、Imatestを終了します。

図を閉じると、すべての図が閉じます。開いている図が多すぎるとコンピュータの動作が遅くなるため、これは重要です。図は、通常のWindowsの方法(右上隅の「×」をクリックするか、タスクバーの図アイコンを右クリックして「閉じる」を選択する)で個別に閉じることができます。

EXIF (ユーティリティのドロップダウンメニュー内)は、画像ファイルのEXIFメタデータを表示します。ExifToolがインストールされている場合(手順は下記参照)、ほとんどのファイル形式がサポートされます。EXIFデータは、設定を見つけやすくするためにアルファベット順に並べ替えたり、クリップボードにコピーしてテキストエディタに貼り付けたり、画像ファイルと同じフォルダ内のテキストファイルに保存したりできます。

EXIFビューア

図表

Imatestの図:図のサイズを変更したり、個々のグラフを拡大表示したりできます。
データカーソルを含むツールバーデータカーソルアイコンが表示されます。

Imatestの結果は、 「図」と呼ばれる個別のウィンドウに表示されます。右側には、 SFRを実行した結果を示す典型的な図が表示されています。

図は、標準的なWindows操作でサイズ変更、最小化、最大化、または閉じることができます。さらに、画像上部のツールバーには、WindowsおよびMATLAB固有の操作がいくつか用意されています。

ツールバーの最初の4つのアイコンは、標準的なWindowsアイコンです。 「新規ファイル」 、 「開く」 、 「保存」 、 「印刷」です。 「開く」と「保存」は、Matlabの.fig形式の図ファイルに対応しており、これらのファイルはストレージ容量を大量に消費するため、使用は控えめにしてください。

残りのアイコンのうち、ズームインしてください。 これは特に便利です。クリックするとハイライト表示され、グラフの特定領域を拡大表示できます。クリックしてドラッグすることで拡大範囲の矩形を作成したり、任意の点をクリックしてその点を拡大表示したりできます。画像内の任意の場所をダブルクリックすると、元の拡大表示に戻ります。

データカーソルの例
データカーソルの例

データカーソル、 データカーソルアイコンツールバーのアイコンをクリックすると、曲線をクリックして、データチップと呼ばれる小さなボックスにその座標を表示できます。データチップを右クリックすると、削除したり、その他のオプションを選択したりできます。

ほとんどのモジュールでは、図はPNGファイル(標準的な可逆圧縮画像ファイル形式)またはMatlab FIGファイルとして保存できます。保存した図は、ユーティリティドロップダウンメニューの「図ファイルを開く」から開き、ズームや回転などの操作を行うことができます。FIGファイルは、特に回転可能な3D FIGファイルの場合、より多くのストレージ容量を必要とするため、通常はPNGファイルが推奨されます。

オープンな図が多すぎる

複数の実行、特に複数の領域を含む実行を行うと、図が多数生成されることがあります。図が多すぎると、システムのパフォーマンスが低下します。図は、図の右上にある「×」をクリックするか、Windowsの一般的な操作で個別に閉じることができます。Imatestのメインウィンドウで「図を閉じる」をクリックすると、すべての図を閉じることができます。

CSVおよびJSON出力ファイル

Imatestの各モジュールは、オプションで、ほとんどの結果を含む2種類の出力ファイルを書き込むことができます。

  • CSVファイルは、多くの場合Microsoft Excelで表示されます。
  • JSONファイルは、単一の大きなJSON構造を含んでおり、 JSONウェブサイトからリンクされている関数を使用すれば、 ほぼあらゆる言語で書かれたプログラムにたった1行のコードで読み込むことができます。また、あらゆるテキストエディタで表示できます。

Imatestの出力に関するご要望やご提案がございましたら、 ご連絡ください。 [注:これらのファイルは評価モードでは保存されません。 ]

CSVファイルとは、 Excelで読み取り可能なカンマ区切り変数形式です。以下に、典型的な出力例を示します。

モジュール、カラーチェック
ファイル、Canon_EOS10d_ColorCheck_lt_small.jpg
実行日時:2005年12月31日 18:11:00
ゾーン、グレースケール、ピクセル、ピクセル/255、Px/255 理想、Log(exp)、Log(px/255)、WB エラー度、WB エラー 迷走
19、1、241.6、0.9475、0.9569、-0.050、-0.023、163、-3.8
20、2、215.8、0.8464、0.7922、-0.230、-0.072、491、-10.8
21、3、179.0、0.7020、0.6353、-0.440、-0.154、450、-10.0

同じデータをExcelで表示すると、次のようになります。

Excelに表示されたサンプルCSV出力

JSONファイルは、人間が多少読みやすいテキストファイルであり、単一の構造を持ち、事実上あらゆるプログラミング言語で書かれたプログラムに読み込むように最適化されています。

{
      "jstruct": {
            "dateRun": "03-May-2018 12:14:03",
            "ini_time_size": "03-May-2018 12:02:35 104121B  MD5 = 6a03a447754eefcc2ada6698ec63d30e",
            "version": "Imatest 5.1.0. ALPHA  Colorcheck",
            "build": "NOT COMPILED",
            "full_path_name": "C:\\imatest\\Data\\Colorcheck\\Canon_eos10d_ColorCheck_lt.jpg",
            "file_name": "Canon_eos10d_ColorCheck_lt.jpg",
            "mean_cameraSat_Pct": [0.9888],
            "pxlLevel_graypatch": [241.67,215.9,179.27,135.26,84.58,34.63],
            "pxlLevel_norml_graypatch": [0.9477,0.8467,0.703,0.5304,0.3317,0.1358],
            "densityNominal": [0.949,0.7882,0.6314,0.4784,0.3255,0.1922],
            "logExposure": [-0.05,-0.23,-0.44,-0.7,-1.05,-1.5],
            "logNormlPxlLevel": [-0.023,-0.072,-0.153,-0.275,-0.479,-0.867],
            "whiteBalErrDegs": [157.3,478,487.1,833.4,954.2,568.3],
...
            "Mean_Delta_E_00": [5.31],
            "Max_Delta_E_00": [11.42],
            "Sigma_Delta_E_00": [5.76],
            "Mean_Delta_C_00": [3.05],
            "Mean_White_Balance_delta_C_00": [2.87],
            "Max_Delta_C_00": [7.52],
            "Sigma_Delta_C_00": [3.45],
            "Mean_Delta_C_00_Sat_corrected": [3.08],
            "Max_Delta_C_00_Sat_corrected": [7.5],
            "Sigma_Delta_C_00_Sat_corrected": [3.44],
            "passfail": {
                  "ini_time_size": "04-Jul-2017 09:31:58 1734B  MD5 = 1a759325ea50ce2c4bc826dae419feac",
                  "passFailFile": "C:\\imatest\\Data\\ini_files\\passfailtest_1.txt",
                  "started_at": "2018-05-03 12:14:03",
                  "ended_at": "2018-05-03 12:14:20",
                  "runtime": [9.135914449],
                  "INI_read_success": "[colorcheck] NOT FOUND",
                  "all_tests_passed": [1]
            }
      }
}

Imatestライセンス(EULA)

Imatestライセンスの全文はこちらでご覧いただけます。

ライセンス保持者は、 www.imatest.comへのリンクを含めることを条件に、印刷物、ウェブサイト、ディスカッションフォーラムなどでテスト結果を公開することが推奨されます。Imatest ロゴの使用も推奨されます。ただし、Imatest LLC からの明示的な許可なしに、Imatest を広告や製品プロモーションに使用することはできません。ご質問がある場合は、お問い合わせください。

テストを成功させるためのヒント

Imatest LLCは、公開されたレビューの内容について法的責任を負いません。テスト結果、特にMTFのテスト結果を公開する場合は、適切な手法を用いるよう注意してください。考慮すべき事項には、

頑丈なカメラサポート頑丈な三脚、ケーブルレリーズ、そして可能であれば一眼レフカメラにはミラーロックを使用してください。Imatestはプロの試験ラボ向けに高品質なソリューションを提供しています。
ターゲットマウント屋外で作業する場合は、標的が風で揺れないように注意してください。
目標距離印刷されたエッジの品質が測定結果に影響しないよう、対象物から十分な距離(倍率が十分に低いこと)を確保してください。対象物までの距離に関する考慮事項は、こちらに記載されています。
集中カメラのピントが被写体に正確に合っていることを確認してください。マニュアルフォーカスを使用したか、オートフォーカスを使用したかをメモしておきましょう。こぼれたコインや枯れ葉などの被写体は、オートフォーカスではうまく機能しない場合があります。
ターゲットアライメントほとんどの場合、チャートはレンズの光軸に対して垂直(法線方向)になるように配置してください。中心だけでなく、四隅もピントが合っていることを確認してください。
照明できる限り均一になるようにしてください。必要に応じて入射光メーターを使用してください。
暴露影やハイライトがクリッピング(飽和)しないように注意してください。クリッピングが発生すると、結果の精度が低下します。
生データの変換と設定RAW現像ソフト(カメラ内またはカメラ外)と画像処理パイプライン、特にシャープネス処理は、画質に大きな違いをもたらします。コントラストとホワイトバランスも重要です。コントラストとトランスファーカーブに影響を与える設定も、大きな効果を発揮します。可能であれば、「リニア」設定(追加のトーンレスポンス調整を行わない直線的なガンマカーブ)を使用してください。
ガンマ SFRのシャープネス結果は、ガンマ設定に対して中程度の感度を持ちます。ガンマ誤差が10%の場合、MTF50は2.5%変化します。ガンマは、コントラストが既知の傾斜エッジ(≤ 10の場合)またはColor/Tone Interactive 、 Color/Tone Auto 、 Colorcheck 、またはStepchartを実行してグレースケールチャートから測定できます。
清潔さとフィルターレンズ表面は清潔に保ってください。保護フィルター(UVフィルターまたはスカイライトフィルター)が装着されているかどうかを確認してください。フィルターの有無によって画質が変わることがあります。特に、シャープネスの低下よりもコントラストの低下が顕著です。Imatestを使えば、その違いを確認できます。
ファイル形式RAW、PNG、TIFF、または最高品質のJPEGを使用してください。これらの設定の効果を特にテストする場合を除き、最大解像度または最高品質未満のJPEGを使用しないでください。
レンズ設定レンズの性能は、絞り(F値)と焦点距離(ズームレンズの場合)に大きく左右されます。これらの設定は(EXIFデータに保存されるため簡単に)記録し、レポートに必ず含めてください。特に最適な(最もシャープな)絞り値は重要です。レンズの性能は、被写体までの距離にも多少影響されます。ファイル名の変更機能を使用すると、EXIFデータを使用して画像ファイル名に重要な設定を追加できます。
ホワイトバランス特にカラーチェックにおいては、できる限りニュートラルに近い色であるべきです。
これは大げさに思えるかもしれませんが、カメラやレンズのテストで培った技術は、日々の写真撮影にも必ず役立ちます。アルフレッド・スティーグリッツは、ベルリンで学生時代に写真に出会った際、フィルムや現像液を徹底的にテストしました。アンセル・アダムスも、ゾーンシステムの開発において広範なテストを行いました。テストが彼らの独自のビジョンを生み出したと主張する人はいないでしょうが、テストが彼らのビジョンを比類なき美しさを持つプリントへと昇華させる技術に大きく貢献したことは間違いありません。