Imatest 사용 설명서 - 시작하기

Imatest 소프트웨어는 테스트 차트 이미지를 통해 다양한 디지털 카메라 이미지 품질 요소를 측정할 수 있습니다.

처음 시작하시는 분이라면 다음 내용을 살펴보시는 것을 추천합니다:

이미지 품질 요소 페이지 및 초보자를 위한 IQ 테스트 .

가장 인기 있는 차트 유형/분석 모듈은 SFRplus 와 eSFR ISO 입니다. 이 두 가지를 사용하면 단일 테스트 차트 이미지에서 매우 다양한 이미지 품질 요소를 측정할 수 있습니다. 다른 모듈과 차트를 활용하면 다양한 테스트 문제를 해결할 수 있습니다.

이 페이지의 콘텐츠 링크:

Imatest 워크플로

Imatest 기본 워크플로
1. 테스트해야 할 이미지 품질 요소 (선명도, 색상 응답, 톤 응답, 노이즈, 광학적 왜곡 등)를 결정합니다 .
2. 검사를 수행하는 데 필요한 검사 차트를 선택하십시오 . 차트는 Imatest 스토어 에서 구입할 수 있습니다 .
3. 차트를 촬영할 때는 분석하려는 모듈의 지침에 따라 구도를 잡으세요. 처음 시작하는 경우, 여러 모듈의 샘플 이미지를 GitHub 에서 다운로드할 수 있습니다 .
4. Imatest를 열고 적절한 모듈을 사용하여 이미지 를 분석하십시오 .
5. 결과를 경험을 바탕으로 해석하고 유사한 카메라와의 비교를 통해 판단하십시오.
6. 필요에 따라 수치와 텍스트로 구성된 결과를 CSV 또는 JSON 형식으로 저장하세요 .

다운로드 및 체험판 — Imatest는 여기에서 다운로드할 수 있습니다. 설치 방법은 여기에서 확인하세요. 신규 사용자의 경우 14일 무료 체험이 자동으로 시작 됩니다.  소프트웨어를 처음 실행할 때입니다. 준비가 되면 스토어 에서 Imatest 라이선스를 구매하고 다음 링크에 안내된 대로 활성화할 수 있습니다.

온라인 활성화 | 오프라인 활성화 | 온라인 비활성화 | 오프라인 비활성화 | 플로팅 라이선스 | 프록시 서버 | 기술 자료 에는 활성화 문제를 해결하는 데 도움이 되는 여러 링크가 있습니다.
 

라이선스 활성화 참고: Imatest 노드 고정 라이선스는 한 번에 한 대의 컴퓨터에서만 활성화할 수 있지만, 활성화 상태는 컴퓨터 간에 이동할 수 있습니다. Imatest는 원하는 만큼 많은 컴퓨터(Mac 및 Windows)에 설치하고 계속 설치 상태로 유지할 수 있습니다. 활성화 상태를 다른 컴퓨터로 이동하려면 기존 컴퓨터에서 라이선스를 비활성화한 다음 위 지침에 따라 새 컴퓨터에서 활성화해야 합니다. Imatest 플로팅 라이선스는 비활성화 및 재활성화 단계가 필요하지 않으므로 여러 컴퓨터에서 더 쉽게 공유할 수 있습니다. 다양한 라이선스 유형에 대한 자세한 내용은 여기를 참조하십시오.

대부분의 엔지니어는 GUI 기반의 Imatest Master를 사용합니다.

Imatest의 다른 버전은 다음과 같습니다.

Imatest Studio 는 개인 사진작가가 카메라와 렌즈를 테스트하는 데 필요한 모든 것을 갖추고 있지만(카메라 설계 및 제조에 필요한 고급 기능은 부족함), 개인 사진작가와 소규모 스튜디오에서 이용할 수 있습니다.

Imatest IT (산업용 테스트)는 제조 환경에 맞게 설계된 Imatest 소프트웨어의 비 GUI 버전입니다. 이 페이지에서는 IT 인터페이스에 대해서는 다루지 않습니다.

Imatest 메인 창

Imatest Main Window▶
Imatest 메인 창

Imatest 메인 창을 통해 사용자는 Imatest의 모든 기능에 접근할 수 있습니다. 메인 창은 2021.2 릴리스에서 업데이트되었습니다. 새로운 Imatest 메인 창에 대한 자세한 내용은 여기에서 확인하세요.

메인 메뉴에서 "클래식 UI"를 선택하면 기존 Imatest 인터페이스를 사용할 수도 있습니다. 클래식 메인 창에 대한 설명은 여기에서 확인할 수 있습니다 .

클래식 Imatest 메인 창.
이미지를 클릭하면 전체 크기로 볼 수 있습니다.

대화형 vs. 자동(일괄 처리)

대부분의 Imatest 분석은 대화형 모드 또는 자동(일괄 처리) 모드로 수행할 수 있습니다.

자세한 내용은 고정형 모듈과 대화형 모듈 비교 페이지 에서 확인할 수 있습니다.

Imatest는 2021.2 버전에서 새로운 메인 창을 도입하여 이미지 선택 및 분석이 더욱 쉬워졌습니다.

새로운 Imatest 메인 창(2021.2)에서 분석 카드 하단에 있는 대화형/자동(일괄 처리) 전환 옵션을 설정하여 원하는 모드를 선택하십시오.

대화형 분석 옵션과 자동(일괄) 분석 옵션 비교
(이는 아래의 ROI 옵션 에서 설명하는 자동 영역 선택과 수동 영역 선택과 혼동해서는 안 됩니다.)

대화형 모드

이 모드를 사용하면 파일에서 이미지를 읽고 분석하거나, 이미지 획득 장치 에서 직접 이미지를 읽고 분석하고, 설정 및 결과를 대화형으로 탐색할 수 있습니다.

자동(일괄) 모드

이 모드는 이전에 구성한 설정(자동/일괄 실행 전)을 사용하여 개별 파일 또는 파일 배치에 대한 분석을 효율적으로 실행할 수 있도록 합니다.

새로운 Imatest GUI 에서 분석(예: eSFR ISO)을 선택하고 분석 카드의 모드를 대화형으로 설정하십시오. 새로운 Imatest GUI 에서 분석 유형(예: eSFR ISO)을 선택하고 모드를 자동(일괄 처리)으로 설정하십시오.

클래식 Imatest UI 창을 사용하는 경우, 오른쪽 열의 분석(대화형)을 클릭하여 이 옵션을 선택합니다.

예시: eSFR ISO 설정

클래식 Imatest UI 창을 사용하는 경우, 가장 왼쪽 열(고정)의 분석 유형을 클릭하여 이 옵션을 선택할 수 있습니다.

예시: eSFR ISO 자동

두 가지 모드가 모두 사용 가능한 경우, 설정 및 결과를 확인하기 위해 대화형 모드를 먼저 실행해야 합니다.
자동(일괄 처리) 모드는 대화형 모드에서 구성한 대부분의 설정을 사용합니다.
분석 실행 중에 매개변수를 변경할 수 있습니다. 이 모드에서 실행하기 전에 매개변수를 설정해야 합니다.

결과는 대화형 창에서 확인할 수 있습니다.

결과는 CSV, JSON 파일 또는 HTML 및 PDF 보고서 형식으로 저장할 수 있습니다.

결과는 고정된 수치, CSV 및 JSON 파일 형식으로 제공됩니다.
분석할 이미지는 이미지 파일에서 얻거나 장치 관리자를 사용하여 설정한 직접 획득 방식 을 통해 얻을 수 있습니다.

파일에서 이미지S만 읽어옵니다.

일괄 읽기 불가 여러 이미지 파일을 선택하여 이미지 배치를 분석할 수 있습니다.
신호 평균화는 빠르고 편리합니다. 여러 이미지 파일의 신호 평균화를 지원합니다.

차트 및 모듈 선택: 무엇을 측정하고 싶으신가요?

이 가이드는 초보자가 자신의 필요에 가장 적합한 차트를 선택하는 데 도움을 주기 위해 작성되었습니다. 이미지 품질 요소및선명도 주요 측정값에 대한 자세한 내용을 포함하고 있습니다.

차트를 이미 선택하셨다면 이 표는 건너뛰세요 .

측정, 도표 및 모듈에 대한 안내 (측정 단위별 색인)
대화형 모듈은 클래식 인터페이스 열에 강조 표시되어 있습니다.
측정 차트

새로운 메인

창문

클래식 인터페이스

(비스듬한 모서리에서 측정한) 선명도
수동 ROI 감지 기능. 구형 ISO 12233:2000 차트를 포함하여 모든 경사진 모서리에서 작동합니다. 여러 이미지를 분석해야 하는 경우 ROI 선택이 까다로울 수 있습니다.
수직 MTF 측정을 위한 비스듬한 가장자리로 자른 이미지

분석 옵션에서 "선명도"를 선택하고 적절한 대상을 지정하십시오.

SFR

레샤르츠

선명도, 색수차 , 톤, 색상 등...

이 사선형 차트는 자동 ROI 감지 기능을 제공하며, 다양한 이미지 품질 측정을 수행합니다. "설정"으로 표시된 대화형 모드 또는 "자동"으로 표시된 고정 모드로 실행할 수 있습니다. 두 모드의 비교는 여기에서 확인할 수 있습니다.

각각은 특정한 강점과 활용 분야를 가지고 있습니다.

SFRplus는 최고의 공간 선명도와 디테일, 그리고 우수한 왜곡 측정 결과를 보여줍니다.

eSFR ISO는 상세한 색상 및 노이즈 측정을 수행하며 , 에일리어싱 및 모아레 현상 측정을 위한 웨지를 포함 합니다 .

SFRreg는 초광각 응용 분야에 사용할 수 있습니다. 장거리 측정을 위해 대형 SFRreg 차트를 인쇄할 수 있습니다.

체커보드 방식은 왜곡 측정값이 가장 정확합니다.

SFRplus , eSFR ISO , 체커보드 및 도트 패턴 차트는 이미지를 완전히 채우거나 거의 완전히 채우도록 설계되었습니다. 다른 대부분의 차트는 이미지의 일부만 채우도록 설계되었습니다.

분석 옵션에서

"추천 상품"

SFR Plus 대상을 선택하세요.

SFRplus 설정

SFR플러스 오토

분석 옵션에서

"추천 상품"

eSFR ISO 타겟을 선택하세요.

eSFR ISO 설정

eSFR ISO 자동

분석 옵션 에서

"추천 상품"

SFR 등록 대상을 선택하세요.

SFRreg 설정

SFRreg 자동

분석 옵션 에서

"추천"에서 체커보드 타겟을 선택하세요.

체커보드 설정

체커보드 오토

질감, 선명도

로그 주파수 대비 및 흩어진 동전 차트(또는 무작위/마른 나뭇잎 차트). 비스듬한 모서리는 미세한 질감 반응을 측정할 수 없기 때문에 중요합니다.

분석 옵션에서

"선명도"에서 Log F 대비를 목표로 선택하십시오.

로그 F-대비

Rescharts – 로그 FC

분석 옵션에서

"선명도"를 선택하세요

무작위/마른 잎 대상.

무작위/마른 잎

Rescharts – 랜덤

날카로움,
정보 용량

지멘스 별자리 차트.

분석 옵션에서

"선명도"를 선택하세요

별자리 지도를 목표로 삼으세요.

별

레샤츠 – 스타

날카로움,
앨리어싱, 모아레
웨지(Wedges) 또한 eSFR ISO의 일부입니다.
로그 F-대비 차트 분석 옵션에서

"날카로움",

웨지 타겟을 선택하세요 .

쐐기

레샤츠 – 웨지

선명도(상대적)
어떤 이미지에서든

이미지 배치에 대한 빠른 비교
측정 방식이 표준이 아닙니다.

로그 F-대비 차트

유틸리티 메뉴의 이미지 도구를 선택하세요.

가장 날카로운 파일을 찾아보세요

가장 날카로운 파일을 찾아보세요

색상 반응,
음색 응답(OECF), 노이즈,
색상 보정 매트릭스(CCM)

색상/톤 대화형 및 자동 기능은 매우 다양한 회색조 단계 차트와 색상 차트를 지원합니다. 여기서는 몇 가지만 보여줍니다.

컬러체커 SG
컬러게이지_120W 크로마듀몬드 28 테스트 차트
분석 옵션에서

색상,

적절한 대상을 선택하십시오 .

(컬러체커 24, 컬러체커 SG,

일반 MxN 색상,

(그리고 다른 여러 옵션들도 있습니다)

색상/톤 자동

색상/톤 인터랙티브

동적 범위

다층 투과형 사진 필름 차트를 사용하여 측정했습니다.
다이내믹 레인지 측정 에 대해 자세히 알아보세요.

다이내믹_35_E_200W
동적 범위 페이지를 참조하십시오.

색상/톤 자동

색상/톤 인터랙티브

스텝차트 (레거시 모듈)

색상 및 톤 반응
Colorcheck는 X-Rite 24패치 Colorchecker만 지원합니다.
새로운 작업에는 색상/톤 조정을 권장합니다.

분석 옵션에서

색상,

"Colorcheck를 통한 Colorchecker 24" 대상을 선택합니다.

컬러체크
(레거시 모듈)은 24패치 X-Rite 컬러 체커에서만 작동합니다.

톤 응답(OECF) 및 노이즈
단계별 차트. 새 작품에는 색상/톤 사용을 권장합니다.

Image of the Q-13 Gray scale 분석 옵션에서

어조, 적절한 대상 을 선택하세요 .

단계도
(레거시 모듈)은 여러 개의 회색조 단계 차트와 함께 작동합니다.

조명의 균일성,
색상 음영, 결함 픽셀

평면장 이미지를 분석하기 위한 다용도 모듈

광량 감소 등고선 플롯 분석 옵션에서

일률,

균일성 목표를 선택하세요 .

일률

균일성 인터랙티브

이 모듈들은 플랫 필드 이미지와 함께 작동합니다.

결함 (센서 결함)
설정은 눈에 띄는 결점은 감지하고 눈에 잘 띄지 않는 결점은 무시하도록 세심하게 조정되었습니다.
원본 테스트 이미지(잘린 부분) 분석 옵션에서

균일성/결함,

플랫 필드 타겟을 선택 하세요 .

잡티 감지

플랫필드 이미지와 함께 작동합니다.

왜곡,
측면 색수차

여러 표준과 호환됩니다. 이미지를 완전히 채우거나 거의 완전히 채우도록 설계되었습니다.

분석 옵션에서

왜곡,

도트 패턴 대상을 선택 하세요 .

점 무늬

왜곡
왜곡 측정 에 대해 자세히 알아보세요

체커보드 효과 는 기존 왜곡 모듈보다 더욱 견고하고 정확하며 (더 많은 왜곡된 이미지에서도 작동합니다).

분석 옵션에서

왜곡,

체커보드 타겟을 선택하세요 .

체커보드 설정

체커보드 오토

왜곡 (레거시 모듈)

사용자 지정 차트

다양한 이미지 품질 측정

분석 옵션에서

"추천 상품"

임의 차트 대상을 선택합니다.

임의 차트 참고 사항:

Imatest 차트는 다양한 크기와 재질로 제공됩니다.

    • 유리 위에 크롬 도금 (최대 4x4인치(100x100mm); 초정밀; 회색조 없음)
    • 컬러 사진 필름 (최대 8x10인치, 고화질, 저노이즈)
    • 흑백 필름 (최대 12x20인치, 컬러 필름보다 노이즈가 많음, 근적외선 및 단파 적외선 촬영에 적합)
    • 사진 인화지 (잉크젯 용지보다 입자가 얇고 근적외선 및 단파 적외선에 더 적합함)
    • 잉크젯 프린터 (높이 최대 44인치, 매우 작은 차트에는 적합하지 않을 정도로 인쇄 품질이 떨어짐). 직접 잉크젯 차트를 인쇄 할 수도 있지만, 최고 품질을 위해서는 Imatest 스토어 에서 구매하는 것을 권장합니다.

차트 적합성 에 대한 문의 사항은 imatest.com으로 연락 주시기 바랍니다. 카메라의 픽셀 해상도와 시야각을 알려주시면 더욱 정확한 답변을 드릴 수 있습니다.

Imatest 실행

Imatest는 다음으로 시작됩니다.

  • Imatest 아이콘을 두 번 클릭합니다. 이마스테트_아이콘_16 데스크톱 에서 ,
  • Windows 시작 메뉴에서: 시작 → 모든 프로그램 → Imatest → 버전 → 이마스테트_아이콘_16 오른쪽에 그림으로 나와 있는 Imatest 에디션입니다 .
  • 또는 Imatest 디렉터리(일반적으로 Win64 영어 설치 환경에서는 C:\Program Files (x86)\Imatest version 경로 에 있음, 여기서 version은 Master, IS, Studio 등임)에서 찾을 수 있습니다.

몇 초 후(최초 설치 또는 재부팅 후 최대 1분) 아래 그림과 같은 Imatest 메인 창이 열립니다.

새로운 Imatest 메인 창 에서 사용자는 이미지를 선택하고 실행할 분석을 선택할 수 있습니다. (순서는 상관없습니다.) "분석" 버튼을 클릭하여 분석을 실행합니다. ROI 선택 또는 기타 설정이 필요한 경우, 사용자가 입력할 수 있는 창이 나타납니다. (기존 UI를 사용하는 경우, 왼쪽 두 열에 있는 버튼 중 하나를 클릭하여 Imatest 분석 모듈을 실행합니다.)

목차 .

Imatest 도움말 찾기

  • Imatest에 대한 자세한 도움말은 문서 페이지(목차) 에서 찾을 수 있습니다.
  • Imatest 소프트웨어 상단 메뉴의 ' 학습 ' 아이콘에는 중요한 온라인 문서 링크가 있습니다.
  • 툴팁(버튼 위에 마우스 커서를 올렸을 때 몇 초 동안 나타나는 텍스트 블록)에는 버튼 기능에 대한 간결한 설명이 포함되어 있습니다.
  • 클래식 UI 에서는 Imatest 메인 창의 대부분 버튼(오른쪽 탭 상자 포함)을 마우스 오른쪽 버튼으로 클릭하면 해당 버튼 기능에 대한 도움말 문서가 열립니다.
  • 동영상 및 온라인 교육 자료를 이용하실 수 있습니다.

처음 시작하시는 분들은 GitHub 에서 여러 모듈의 샘플 이미지를 다운로드하실 수 있습니다.

궁금한 점이 있으신가요? 문서 페이지를 검색하거나 웹페이지 오른쪽 상단에 있는 돋보기 아이콘을 사용하여 웹사이트 전체를 검색하면 답변을 찾을 수 있는 경우가 많습니다. 그래도 찾을 수 없다면,

기술 지원 관련 질문은 [email protected]으로 보내주세요.
판매 관련 문의사항(구매, 갱신 등) 은 [email protected]으로 보내주세요.
테스트 차트 관련 질문, 특히 테스트 차트 사용자 지정에 관한 질문은 [email protected]으로 보내주세요.

이러한 이메일은 각각 여러 사람에게 발송됩니다. 특정인에게 연락하려는 경우에도 이러한 이메일 주소를 하나 이상 포함하는 것이 좋습니다. 해당인이 부재중일 경우 더 빠른 답변을 받을 가능성이 높기 때문입니다. 다음은 몇 가지 유용한 자료입니다.

동영상 – 온라인 교육 – 컨설팅

저장된 설정: imatest-v2.ini

설정은 imatest-v2.ini라는 INI 파일에 저장되며, 저장된 설정(INI 파일) 및 데이터 탭 의 설정 관리 버튼에서 자세히 설명합니다 .

설정에는 글꼴 크기, 이미지 열기 및 저장 폴더, 계산 매개변수, 플롯 선택, 표시 및 저장할 그림 등이 포함됩니다 . 아래 설명된 바와 같이 INI 파일 드롭다운 메뉴에서 여러 INI 파일 유틸리티에 액세스할 수 있습니다. INI 파일 편집기 또는 설정 보기(ini 파일)를 사용 하여 설정을 보거나 편집하고 , ini 파일을 저장하거나 불러오는 등 다양한 작업을 수행할 수 있습니다.

저장된 설정(INI 파일) , 문제 해결 , 그리고 중요한 기술 자료 게시물인 ' 이전에는 작동하던 모듈이 작동을 멈췄습니다 '에 설명된 여러 가지 문제 해결 및 오류 수정 기능을 사용할 수 있습니다. 고급 사용자에게 유용한 INI 파일 색인에는 INI 파일 모니터 에 대한 설명이 포함되어 있습니다.

드롭다운 메뉴를 표시합니다

디스플레이 드롭다운 메뉴에는 글꼴, 창 및 그림 크기에 영향을 미치는 중요한 설정이 포함되어 있습니다. 글꼴 크기는 이미지에 맞춰 적절하게 설정해야 합니다. 너무 작으면 텍스트를 읽기 어렵고 텍스트를 위해 예약된 공간을 활용하지 못하며, 너무 크면 텍스트가 다른 개체를 가리게 됩니다.

창 크기 드롭다운
큰 글꼴(120dpi)이 적용된 Imatest 메인 창
Imatest의 아주 초기 버전

Imatest에는 다양한 컴퓨터의 DPI 스케일링에 맞춰 글꼴과 창 크기를 조정할 수 있는 여러 설정이 있습니다.

이러한 설정에 접근하려면 메인 창 상단 표시줄의 ' 표시 '를 클릭하세요. 그러면 왼쪽에 표시된 드롭다운 메뉴가 열립니다. 설정:

  • 글꼴 크기: 숫자에 올바르게 표시되도록, 즉 너무 작거나 크지 않도록 설정하십시오.
  • 일반 화면 또는 확대 화면 ( Imatest 메인 창).
  • 일반 크기 또는 확대된 그림(1.25배 또는 1.5배). 확대된 그림의 경우 글꼴 크기를 키워야 할 수도 있습니다.
  • 일반 또는 확대된 대화형 창(색상/톤 대화형, Rescharts, 일괄 보기 등)

이미지 파일을 엽니다

대부분의 Imatest 분석 모듈은 이미지 파일을 열어야 합니다.

모듈을 열거나(경우에 따라) 이미지 파일을 열기 위한 버튼을 누르면(다른 경우에 따라) 이미지 파일 이름을 입력하라는 대화 상자가 나타납니다. 지원되는이미지 파일 형식은 아래에 요약되어 있습니다.

지원되는 이미지 파일 형식

자세한 내용은 이미지 파일 형식 및 획득 장치를 참조하십시오. 요약:

  • MATLAB의 imread 문에서 지원하는 모든 파일 형식입니다. 사용 빈도가 낮은 형식은 회색으로 표시됩니다 .
  • LibRaw를 사용하여 변환할 수 있는 상용 RAW 포맷에는 CR2, NEF, RW2 등이 있습니다. LibRaw 0.20 지원 카메라 목록을 참조하십시오 . 새로운 카메라는 일반적으로 출시 후 한두 달 이내에 LibRaw에 추가됩니다.
  • 일반화된 읽기 원시 창에 지정된 확장자로 식별되는 바이너리 파일입니다 . 해당 확장자에 대해 픽셀 크기, 비트 심도, 디모자이킹 매개변수, 오프셋 등을 설정할 수 있습니다.
  • TGA (타르가)
  • DPX , Video DNG * 및 ARI *를 포함한 비디오 형식 (*LibRaw를 사용하여 변환됨)
  • CSV (일부 적외선 시스템에서 사용되는 특수 형식)
  • HDR( 고해상도 범위) 파일
  • 매우 다양한 영상 획득 장치들이 있습니다 . 너무 많아서 여기에 모두 나열할 수는 없습니다.
여러 파일 읽기(일괄 모드) 읽을 파일을 여러 개 선택할 수 있습니다. 아래의 다중 이미지 대화 상자에 어떻게 응답하느냐에 따라,

파일은 같은 폴더에 있어야 하고, (대부분의 모듈에서) 픽셀 크기가 동일해야 하며, 프레임도 동일해야 합니다( SFRplus 및 자동 감지 기능을 사용하는 다른 모듈의 경우 파일 크기는 상관없습니다). '파일 병합'을 선택하면 병합된 파일을 기본적으로 16비트 TIFF 형식으로 저장할 수 있는 옵션이 제공됩니다. Rescharts 또는 Color/Tone Interactive와 같은 대화형 모듈에서는 일괄 처리 모드가 지원되지 않습니다.

병합된 파일의 경우 저장된 파일 이름은 처음에 선택한 파일 이름에 _comb_n이 추가된 것과 동일하며, 여기서 n은 병합된 파일의 개수입니다.

  • 추가 입력 데이터를 입력하십시오. Express 모드를 선택하지 않은 경우, 모듈에 따라 설정을 지정하는 설정 창이 열립니다. 대부분의 추가 데이터는 선택 사항이며(이전 실행에서 저장됨), 변경하려는 설정만 입력하면 됩니다. 프로그램을 실행하려면 확인을 클릭하고, 실행을 종료하려면 취소를 클릭하십시오.
  • 결과를 저장하시겠습니까? 분석이 실행된 후, 결과를 저장할지 묻는 대화 상자가 나타납니다. 대화 상자의 확인란을 사용하여 저장할 그림, CSV(Excel에서 읽을 수 있는) 파일 및 JSON 파일을 선택할 수 있습니다. 저장할 항목을 결정하기 전에 결과를 검토할 수 있습니다. (평가판에서는 ' 저장' 상자가 생략되어 있습니다.) 그림은 PNG(무손실 압축) 이미지 파일 또는 Matlab Fig 파일로 저장할 수 있습니다(Matlab Fig 파일은 크기가 크기 때문에 권장하지 않습니다). Fig 파일은 '그림 파일 열기'를 사용하여 열고 편집할 수 있습니다.

유용한 버튼

새로운 메인 창에서 "학습" 탭을 클릭하여 Imatest 이미지 분석, 차트, IQF 및 표준에 대해 알아보세요. 교육용 앱 링크도 있습니다. 또는 상단 메뉴 모음에서 "도움말 " 메뉴를 클릭하세요.

아래 버튼은 클래식 UI 에서 도움말에 접근하는 데 사용됩니다.

이미지 오른쪽 탭에 있는 각 버튼을 클릭하면 자세한 설명과 다양한 기능을 실행하는 버튼이 포함된 큰 도움말 창이 열립니다. 이러한 버튼 들을 숙지하고 필요할 때마다 사용하시기 바랍니다.

도움말 가이드 ( 도움말 탭)를 클릭하면 가장 유용한 안내 웹페이지 링크와 각 페이지에 대한 간략한 설명이 포함된 창이 열립니다. 해당 페이지에는 등록 빠른 시작 | Imatest 사용 설명 | 이미지 품질 요소 | Imatest 둘러보기 | 목차(사이트맵) | FAQ | 변경 로그 | 렌즈 테스트 | MTF 곡선 및 외관 | SFRplus | 문제 해결 등이 있습니다.

[데이터 탭]의 [ 설정 관리]를 클릭 하면 Imatest 설정 파일인 imatest-v2.ini의 내용을 설정하고 확인하는 주요 기능에 대한 설명이 포함된 창이 열립니다. 또한 imatest.ini 파일의 전체 경로를 표시하고 imatest-v2.ini 파일이 손상되었을 때 발생할 수 있는 오류를 수정하는 방법도 안내합니다. 기능 버튼에는 [설정 저장...], [설정 불러오기...], [설정 보기/편집(ini 파일)], [설정 복사(ini 파일)], [설정 가져오기/병합], [모듈 편집/초기화], [기본값 재설정(모두)]이 있습니다 .

( 데이터 탭에서 ) 오류 처리를 선택하면 오류가 발생했을 때 수행해야 할 작업을 보여주는 창이 열립니다. 여기에는 변경 로그 및 문제 해결 페이지 링크, 현재 또는 마지막 세션을 클립보드에 복사하여 이메일에 붙여넣는 버튼, imatest.ini 파일이 손상된 경우 복구하는 방법에 대한 지침이 포함됩니다.

원본 파일

RAW 파일은 디지털 이미지 센서의 처리되지 않은 출력물입니다. 베이어 센서의 경우, 각 RAW 픽셀은 RGRGRG, GBGBGB, ... 순서로 단일 색상을 나타냅니다. 사용 가능한 표준 파일 형식(TIFF, JPEG 등)으로 변환하려면 RAW 변환기를 통해 처리해야 합니다. RAW 변환기는 디모자이킹 (베이어 시퀀스를 전체 색상으로 변환), 감마 곡선 적용(종종 추가적인 톤 응답 곡선 포함), 색 보정 및 화이트 밸런스 조정, 노이즈 감소, 이미지 선명도 향상 등 여러 기능을 수행합니다. 이러한 작업은 Imatest 측정값, 특히 선명도(MTF 또는 SFR)에 영향을 미칩니다.

이미지 파일이 원본 파일과 최대한 유사하게, 즉 최소한의 처리만 거쳤는지 확인하는 가장 좋은 방법은 Imatest로 원본 파일을 불러와 LibRaw를 사용하여 상용 원본 파일(CR2, NEF 등 확장자로 식별됨)의 경우 표준 형식(일반적으로 TIFF)으로 변환하거나, Generalized Read Raw를 사용하여 표준 형식으로 변환하는 것입니다.  바이너리 개발 파일 (확장자, 일반적으로 RAW) 의 경우 오른쪽 대화 상자가 나타납니다. 상업용 RAW 파일의 경우 여러 RAW 변환 옵션 중에서 선택할 수 있습니다. 상업용 파일과 바이너리 파일 모두에 대한 자세한 내용은 RAW 파일 섹션을 참조하십시오 .

RAW 파일은 디모자이킹(표준 RGB 형식)을 사용하거나 디모자이킹 없이 변환할 수 있습니다(디모자이킹을 사용하지 않으면 원래의 R, G(R), B, G(B) 채널을 개별적으로 분석할 수 있습니다).

Exit 명령을 실행하면 모든 수치가 사라지고 Imatest가 종료됩니다.

[도형 닫기]를 클릭하면 모든 도형이 닫힙니다. 너무 많은 도형이 열려 있으면 컴퓨터 속도가 느려지므로 이 기능은 중요합니다. 일반적인 Windows 방법(오른쪽 상단의 X 버튼을 클릭하거나 작업 표시줄의 도형 아이콘을 마우스 오른쪽 버튼으로 클릭하고 [닫기]를 선택)을 사용하여 도형을 개별적으로 닫을 수 있습니다.

EXIF ( 유틸리티 드롭다운 메뉴)를 선택하면 이미지 파일의 EXIF 메타데이터가 표시됩니다. ExifTool이 설치되어 있으면 대부분의 파일 형식이 지원됩니다(설치 방법 참조 ). EXIF 데이터는 알파벳순으로 정렬하여 설정을 쉽게 찾을 수 있고, 클립보드에 복사하여 텍스트 편집기에 붙여넣을 수 있으며, 이미지 파일과 동일한 폴더에 텍스트 파일로 저장할 수 있습니다.

EXIF 뷰어

수치

Imatest 그림: 크기를 조정하거나 개별 그래프를 확대할 수 있습니다.
데이터 커서를 포함하는 툴바 데이터 커서 아이콘 ,이 표시됩니다.

Imatest 결과는 Figures 라는 개별 창에 표시됩니다. SFR 실행 결과인 일반적인 Figures는 오른쪽에 나와 있습니다.

그림은 표준 Windows 작업을 사용하여 크기 조정, 축소, 최대화 또는 닫을 수 있습니다. 또한 이미지 상단의 도구 모음에서 몇 가지 Windows 및 MATLAB 관련 작업을 찾을 수 있습니다.

툴바의 처음 네 아이콘은 표준 Windows 아이콘인 새 파일 , 열기 , 저장 및 인쇄 입니다. 열기 와 저장은 Matlab .fig 그림 파일을 가리키는데, 이 파일은 과도한 저장 공간을 차지하므로 가급적 사용을 자제해야 합니다.

나머지 아이콘 중에서 확대하려면 다음을 클릭하세요 . 특히 유용한 기능입니다. 클릭하면 해당 부분이 강조 표시되고 그래프의 특정 영역을 확대할 수 있습니다. 클릭하고 드래그하여 확대 영역을 만들거나, 아무 지점이나 클릭하여 해당 지점을 확대할 수 있습니다. 이미지 내부 아무 곳이나 두 번 클릭하면 확대되지 않은 전체 이미지로 돌아갑니다.

데이터 커서 예시
데이터 커서 예제

데이터 커서 , 선택됨 데이터 커서 아이콘 툴바 아이콘을 사용하면 곡선을 클릭하여 데이터팁 이라는 작은 상자에 해당 좌표를 표시할 수 있습니다. 데이터팁을 마우스 오른쪽 버튼으로 클릭하면 삭제하거나 추가 옵션을 선택할 수 있습니다.

대부분의 모듈에서 그림은 PNG 파일(표준 무손실 압축 이미지 파일 형식) 또는 MATLAB FIG 파일로 저장할 수 있습니다. FIG 파일은 유틸리티 드롭다운 메뉴에서 "그림 파일 열기 "를 선택하여 열고 확대/축소 및 회전 등의 편집이 가능합니다. 하지만 FIG 파일은 특히 회전이 가능한 3D FIG 파일의 경우 저장 공간을 훨씬 많이 차지하기 때문에 일반적으로 PNG 파일이 선호됩니다.

너무 많은 열린 도형

여러 번 실행하거나 특히 여러 지역을 대상으로 실행할 경우 그림이 많이 생성될 수 있습니다. 그림이 너무 많이 열려 있으면 시스템 성능이 저하됩니다 . 그림은 오른쪽 상단의 X 버튼을 클릭하거나 일반적인 Windows 기능을 사용하여 개별적으로 닫을 수 있습니다. Imatest 메인 창에서 "그림 닫기"를 클릭하면 모든 그림을 한 번에 닫을 수 있습니다.

CSV 및 JSON 출력 파일

Imatest 의 개별 모듈은 대부분의 결과를 포함하는 두 가지 유형의 출력 파일을 선택적으로 작성할 수 있습니다.

  • CSV 파일은 대부분 마이크로소프트 엑셀에서 볼 수 있습니다.
  • JSON 파일은 하나의 큰 JSON 구조를 포함하고 있으며, JSON 웹사이트 에서 제공하는 함수를 사용하여 거의 모든 프로그래밍 언어로 작성된 프로그램에서 단 한 줄의 코드로 읽어들일 수 있습니다 . 또한 모든 텍스트 편집기에서 내용을 표시할 수 있습니다.

Imatest 출력 결과 에 대한 요청이나 제안 사항이 있으시면 언제든지 문의해 주세요 . [ 참고: 평가 모드에서는 이러한 파일이 저장되지 않습니다. ]

CSV 파일 은 Excel에서 읽을 수 있는 쉼표로 구분된 변수(CSV) 형식입니다. 일반적인 출력 예시는 다음과 같습니다.

모듈, 컬러체크
파일,Canon_EOS10d_ColorCheck_lt_small.jpg
실행 날짜, 2005년 12월 31일 18시 11분
영역, 회색, 픽셀, 픽셀/255, 픽셀/255 이상, 로그(exp), 로그(px/255), WB 오차도, WB 오차 혼합
19, 1, 241.6, 0.9475, 0.9569, -0.050, -0.023, 163, -3.8
20, 2, 215.8, 0.8464, 0.7922, -0.230, -0.072, 491, -10.8
21, 3, 179.0, 0.7020, 0.6353, -0.440, -0.154, 450, -10.0

엑셀에서 동일한 데이터를 표시하면 다음과 같습니다.

Excel에 표시된 CSV 파일 출력 예시

JSON 파일은 사람이 읽기 쉬운 텍스트 파일로, 거의 모든 프로그래밍 언어로 작성된 프로그램에서 읽어들이기에 최적화된 단일 구조를 가지고 있습니다.

{
      "jstruct": {
            "dateRun": "03-May-2018 12:14:03",
            "ini_time_size": "03-May-2018 12:02:35 104121B  MD5 = 6a03a447754eefcc2ada6698ec63d30e",
            "version": "Imatest 5.1.0. ALPHA  Colorcheck",
            "build": "NOT COMPILED",
            "full_path_name": "C:\\imatest\\Data\\Colorcheck\\Canon_eos10d_ColorCheck_lt.jpg",
            "file_name": "Canon_eos10d_ColorCheck_lt.jpg",
            "mean_cameraSat_Pct": [0.9888],
            "pxlLevel_graypatch": [241.67,215.9,179.27,135.26,84.58,34.63],
            "pxlLevel_norml_graypatch": [0.9477,0.8467,0.703,0.5304,0.3317,0.1358],
            "densityNominal": [0.949,0.7882,0.6314,0.4784,0.3255,0.1922],
            "logExposure": [-0.05,-0.23,-0.44,-0.7,-1.05,-1.5],
            "logNormlPxlLevel": [-0.023,-0.072,-0.153,-0.275,-0.479,-0.867],
            "whiteBalErrDegs": [157.3,478,487.1,833.4,954.2,568.3],
...
            "Mean_Delta_E_00": [5.31],
            "Max_Delta_E_00": [11.42],
            "Sigma_Delta_E_00": [5.76],
            "Mean_Delta_C_00": [3.05],
            "Mean_White_Balance_delta_C_00": [2.87],
            "Max_Delta_C_00": [7.52],
            "Sigma_Delta_C_00": [3.45],
            "Mean_Delta_C_00_Sat_corrected": [3.08],
            "Max_Delta_C_00_Sat_corrected": [7.5],
            "Sigma_Delta_C_00_Sat_corrected": [3.44],
            "passfail": {
                  "ini_time_size": "04-Jul-2017 09:31:58 1734B  MD5 = 1a759325ea50ce2c4bc826dae419feac",
                  "passFailFile": "C:\\imatest\\Data\\ini_files\\passfailtest_1.txt",
                  "started_at": "2018-05-03 12:14:03",
                  "ended_at": "2018-05-03 12:14:20",
                  "runtime": [9.135914449],
                  "INI_read_success": "[colorcheck] NOT FOUND",
                  "all_tests_passed": [1]
            }
      }
}

Imatest 라이선스(EULA)

Imatest 라이선스 전문은 여기에서 확인할 수 있습니다 .

라이선스 소지자는 www.imatest.com 링크를 포함하는 조건으로 인쇄물, 웹사이트 및 토론 포럼에 테스트 결과를 게시할 수 있습니다. Imatest 로고 사용도 권장합니다. 단, Imatest LLC의 명시적인 허가 없이는 광고 또는 제품 홍보 목적으로 Imatest를 사용할 수 없습니다. 문의 사항이 있으시면 연락주시기 바랍니다 .

성공적인 테스트를 위한 팁

Imatest LLC는 게시된 리뷰 내용에 대해 어떠한 법적 책임도 지지 않습니다. 특히 MTF와 관련된 테스트 결과를 게시할 계획이라면 올바른 방법을 사용하는 데 주의를 기울여야 합니다. 고려 사항은 다음과 같습니다.

견고한 카메라 지지대 견고한 삼각대와 릴리즈 케이블을 사용하고, 가능하다면 DSLR 카메라의 경우 미러 락 기능을 사용하십시오. Imatest는 전문 테스트 연구소를 위한 고품질 솔루션을 제공합니다.
타겟 마운팅 야외에서 작업하는 경우, 표적이 바람에 흔들리지 않도록 하십시오.
목표 거리 측정 시 인쇄물의 가장자리 품질이 영향을 미치지 않도록 대상과의 충분한 거리를 확보하십시오(배율이 충분히 낮아야 함). 대상과의 거리에 대한 고려 사항은 여기에 나와 있습니다.
집중하다 카메라 초점이 피사체에 정확하게 맞춰졌는지 확인하십시오. 수동 초점을 사용했는지 자동 초점을 사용했는지 기록해 두세요. '쏟아진 동전/낙엽' 과 같은 일부 피사체는 자동 초점으로 촬영할 때 제대로 초점이 맞춰지지 않을 수 있습니다.
목표 정렬 대부분의 경우, 시력표는 렌즈의 광축에 수직으로 놓아야 합니다. 중앙뿐만 아니라 모서리 부분까지 초점이 맞는지 확인하십시오.
조명 가능한 한 균일해야 합니다. 필요한 경우 입사광량계를 사용하십시오.
노출 그림자나 하이라이트 부분이 과도하게 채도가 높아지지 않도록 주의하세요. 채도가 너무 높으면 결과물의 정확도가 떨어집니다.
원본 변환 및 설정 RAW 변환기(카메라 내부 또는 외부)와 이미지 처리 파이프라인, 특히 선명도 설정은 결과물에 큰 영향을 미칠 수 있습니다. 명암비와 화이트 밸런스 또한 중요합니다. 명암비와 전송 곡선에 영향을 주는 설정도 상당한 효과를 낼 수 있습니다. 가능하다면 "선형" 설정(즉, 추가적인 톤 응답 조정 없이 직선 감마 곡선)을 사용하는 것이 좋습니다.
감마 SFR 선명도 결과는 감마 설정에 다소 민감합니다. 감마 오차가 10%가 되면 MTF50이 2.5% 변경됩니다. 감마는 알려진 대비(≤ 10인 경우)의 기울어진 가장자리 또는 Color/Tone Interactive , Color/Tone Auto , Colorcheck 또는 Stepchart를 실행하여 회색조 차트에서 측정할 수 있습니다.
청결도 및 필터 렌즈 표면은 깨끗해야 합니다. 자외선 차단 필터나 채광 필터와 같은 보호 필터가 있는지 확인하십시오. 필터 유무에 따라 결과가 달라질 수 있으며, 선명도보다는 대비가 저하될 가능성이 더 큽니다. Imatest를 사용하면 확인할 수 있습니다.
파일 형식 RAW, PNG, TIFF 또는 최고 품질의 JPEG 형식을 사용하십시오. 특정 설정의 효과를 테스트하는 경우가 아니라면 최대 해상도 또는 JPEG 품질보다 낮은 형식을 절대 사용 하지 마십시오 .
렌즈 설정 렌즈 성능은 조리개(f-스톱)와 초점 거리(줌 렌즈의 경우)에 크게 좌우됩니다. 이러한 설정값은 EXIF 데이터에 저장되므로 쉽게 확인할 수 있으며, 보고서에 반드시 포함해야 합니다. 특히 최적의(가장 선명한) 조리개 값을 파악하는 것이 중요합니다. 렌즈 성능은 피사체와의 거리에도 어느 정도 영향을 받습니다. 파일 이름 변경 기능을 사용하면 EXIF 데이터를 활용하여 이미지 파일 이름에 주요 설정값을 추가할 수 있습니다.
화이트 밸런스 특히 컬러체크에서 최대한 중성색에 가까워야 합니다.
이게 좀 번거롭게 느껴질 수도 있지만, 카메라와 렌즈 테스트를 통해 익히는 기술은 일상적인 사진 촬영에도 큰 도움이 됩니다. 알프레드 스티글리츠는 베를린에서 학생 시절 사진을 접했을 때 필름과 현상액을 광범위하게 테스트했습니다. 앤셀 아담스 역시 자신의 존 시스템 개발 과정에서 수많은 테스트를 거쳤습니다. 물론 테스트가 그들의 독창적인 시각을 만들어냈다고 단언할 수는 없겠지만, 그들의 시각을 초월적인 아름다움을 지닌 사진 작품으로 구현해내는 데에는 분명 큰 기여를 했을 것입니다.