Imatest 使用说明 - 入门指南

Imatest软件可以根据测试图表图像测量数码相机的多种图像质量因素。

如果您是新手,我们建议您探索以下内容:

图像质量因素页面和初学者智商测试。

最常用的两种图表类型/分析模块是SFRplus和eSFR ISO 。它们允许用户从单个测试图表图像中测量多种图像质量因素。其他模块和图表可帮助您应对各种各样的测试挑战。

本页内容链接:

Imatest工作流程

Imatest 基本工作流程
1.确定需要测试的图像质量因素(清晰度、色彩响应、色调响应、噪声、光学畸变等)。
2.选择执行测试所需的测试图表。图表可在Imatest 商店中找到。
3.拍摄图表,并按照相应分析模块的说明进行构图。如果您是新手,可以从GitHub下载几个模块的示例图片。
4.打开 Imatest 并使用相应的模块分析图像。
5. 根据经验并与同类相机进行比较来解读结果。
6.根据需要保存结果(结果包含数字和文本,以 CSV 或 JSON 格式)。

下载及试用版 —您可以点击此处下载Imatest 。安装说明请点击此处。如果您是新用户,将自动开始14 天免费试用。  首次运行软件时。准备就绪后,您可以从商店购买Imatest许可证,并按照这些链接中的说明激活它。

在线激活|离线激活|在线停用|离线停用|浮动许可证|代理服务器|知识库包含多个链接,可帮助解决激活问题。
 

许可证激活说明: Imatest 节点锁定许可证一次只能在一台计算机上激活,但激活状态可以在计算机之间转移。您可以在任意数量的计算机(包括 Macintosh 和 Windows 系统)上安装Imatest ,并保持其安装状态。要将激活状态转移到另一台计算机,您需要先在旧计算机上停用许可证,然后在新计算机上按照上述说明进行激活。Imatest浮动许可证无需停用和重新激活步骤,因此可以更轻松地在多台计算机之间共享。点击此处了解更多关于不同许可证类型的信息。

大多数工程师使用基于图形用户界面的Imatest Master 。

Imatest 的其他版本包括:

Imatest Studio拥有个人摄影师测试相机和镜头所需的一切(但缺少设计和制造相机的许多高级功能),可供个人摄影师和小工作室使用。

Imatest IT (工业测试)是 Imatest 软件的非图形用户界面版本,专为制造环境设计。本页不讨论其 IT 界面。

Imatest 主窗口

Imatest Main Window▶
Imatest 主窗口

Imatest 主窗口允许用户访问 Imatest 的所有功能。我们的主窗口已在 2021.2 版本中更新。点击此处了解新的 Imatest 主窗口。

也可以选择使用原始的 Imatest 界面,只需在主菜单中选择“经典 UI”即可——有关经典主窗口的文档在此处。

经典 Imatest 主窗口。
点击图片查看完整尺寸。

交互式 vs. 自动(批量)

大多数Imatest分析都可以在交互式或自动(批量)模式下进行。

详情请参阅“固定模块与交互式模块”页面。

在 2021.2 版本中, Imatest 引入了新的主窗口,使选择图像和分析变得更加容易。

在新的 Imatest 主窗口 (2021.2) 中,通过设置分析卡底部附近的交互式/自动(批处理)开关选项来选择所需的模式。

交互式分析选项与自动(批量)分析选项
(这些不应与下文“ROI选项”部分描述的自动区域选择与手动区域选择混淆。)

交互模式

使用此模式可以读取和分析文件中的图像,或直接从采集设备读取和分析图像,并以交互方式探索设置和结果。

自动(批量)模式

使用此模式可以高效地对单个文件或一批文件运行分析,使用先前已配置的设置(在自动/批量运行之前)。

在新的 Imatest GUI 中,选择分析(例如 eSFR ISO),并将分析卡上的模式设置为交互式。在新的 Imatest GUI 中,选择分析类型(例如 eSFR ISO),并将模式设置为自动(批量)。

如果使用经典 Imatest UI窗口,则单击右侧列中的“分析”(交互式)来选择此选项。

示例: eSFR ISO设置

如果使用经典 Imatest UI窗口 - 可以通过单击最左侧(固定)列中的分析类型来选择此选项。

示例: eSFR ISO 自动

如果两种模式都可用,则应先运行交互模式以验证设置和结果。
自动(批量)模式使用交互模式下配置的大部分设置。
分析过程中可以更改参数在此模式下运行前必须设置参数。

结果可在交互式窗口中查看。

结果还可以保存为 CSV、JSON 文件或 HTML 和 PDF 报告。

结果以固定格式的图形、CSV 和 JSON 文件呈现。
待分析的图像可以从图像文件或通过直接采集获得,这可以通过设备管理器进行设置。

仅读取文件中的图像。

批量读取不可用可以通过选择多个图像文件来分析多批图像
信号平均法快速便捷支持对多个图像文件进行信号平均

选择图表和模块:您想测量什么?

本指南旨在帮助初学者选择最能满足其需求的图表。图像质量因素和清晰度 包含有关关键测量的详细信息。

如果您已经选择了图表,请跳过此表。

测量、图表和模块指南,按测量单位索引
交互式模块在“经典界面”栏中以高亮显示。
测量图表

新主街

窗户

经典界面

锐度(从任何倾斜边缘)
手动ROI检测。适用于任何倾斜边缘,包括旧版ISO 12233:2000标准。当需要分析多张图像时,ROI选择可能会比较繁琐。
用于测量垂直调制传递函数 (MTF) 的裁剪斜边图像。

在“锐度”的分析选项中,选择“适当目标”。

SFR

雷沙茨

清晰度、横向色差、色调、色彩等等……

这些斜边图表具有自动ROI检测功能,并可执行多项图像质量测量。它们可以以交互模式(标记为“设置”)或固定模式(标记为“自动”)运行。此处对它们进行了比较。

它们各自具有特定的优势和应用场景。

SFRplus具有最佳的空间清晰度细节和良好的畸变测量结果。

eSFR ISO可进行详细的颜色和噪声测量,并包含用于测量混叠和莫尔条纹的楔形块。

SFRreg可用于超广角应用。可打印大型 SFRreg 图表用于远距离测量。

棋盘格法具有最精确的失真测量精度。

SFRplus 、 eSFR ISO 、棋盘格和点阵图案图表旨在填充(或几乎填充)整个图像。大多数其他图表仅设计用于填充图像的一部分。

分析选项

“特色”

选择 SFR Plus 目标。

SFRplus 设置

SFRplus 汽车

分析选项

“特色”

选择 eSFR ISO 目标。

eSFR ISO设置

eSFR ISO 自动

在分析选项中

“特色”

选择SFR Reg目标。

SFRreg 设置

SFRreg 汽车

分析选项

“特色”,选择棋盘格目标。

棋盘格设置

棋盘格自动

质感、清晰度

对数频率对比度和散落硬币(或随机/枯叶)图表。这一点很重要,因为倾斜边缘无法测量精细纹理响应。

在分析选项中

“锐度”,选择 Log F 对比度目标。

对数 F 对比度

Rescharts – Log FC

在分析选项中

“锐度”,选择

随机/枯叶目标。

随机/枯萎的树叶

Rescharts – 随机

清晰度
信息能力

西门子星形图表。

分析选项

“锐度”,选择

星图目标。

星星

雷沙茨 – 明星

清晰度
同构效应,莫尔条纹
楔形体也是 eSFR ISO 的一部分。
对数 F 对比度图分析选项

“锐利度”

选择楔形目标。

楔

雷沙茨楔形

清晰度(相对)
从任何图像

快速比较多批图像
测量方法不规范。

对数 F 对比度图

在“实用工具”菜单下的“图像工具”中,选择

查找最清晰的文件

查找最清晰的文件

颜色响应
音调响应(OECF)、噪声、
颜色校正矩阵(CCM)

颜色/色调交互式和自动模式支持大量的灰度阶梯图和颜色图。这里仅展示其中一部分。

ColorChecker SG
ColorGauge_120W ChromaDuMonde 28 测试图表
分析选项

颜色,

选择合适的目标。

(Colorchecker 24,Colorchecker SG,

通用MxN颜色,

以及许多其他选项)

颜色/色调自动

颜色/色调互动

动态范围

使用多层透射式照相胶片图表进行测量。
了解更多关于测量动态范围的信息。

dynamic_35_E_200W
请参阅动态范围页面。

颜色/色调自动

颜色/色调互动

步骤图(旧版模块)

色彩与色调响应
Colorcheck 仅支持X-Rite 24 色块Colorchecker。
建议在新作品中使用色彩/色调。

分析选项

颜色,

选择“通过 Colorcheck 选择 Colorchecker 24”目标。

颜色检查
(旧版模块)仅适用于 24 色 X-Rite 色彩检查器。

音调响应(OECF)和噪声
步骤图。建议在新作品中使用色彩/色调。

Image of the Q-13 Gray scale分析选项

语气,选择合适的目标。

步骤图
(旧版模块)可与多个灰度阶梯图配合使用。

照明均匀性,
颜色阴影,缺陷像素

用于分析平场图像的多功能模块

光照衰减等值线图在分析选项中

均匀性,

选择均匀性目标。

均匀性

Uniformity Interactive

这些模块适用于平场图像。

瑕疵(传感器缺陷)
设置经过精心调整,可以检测出可见的瑕疵,而忽略不太明显的瑕疵。
原始测试图像(已裁剪)在分析选项中

均匀性/瑕疵,

选择平场目标。

瑕疵检测

适用于平场图像。

失真,
横向色差

兼容多种标准。设计用于填充(或几乎填充)图像。

在分析选项中

失真,

选择点阵图案目标。

点状图案

失真
了解更多关于测量失真的信息

棋盘格校正比传统的失真校正模块更强大、更准确(并且可以处理更多失真图像)。

在分析选项中

失真,

选择棋盘格目标。

棋盘格设置

棋盘格自动

失真(旧版模块)

自定义图表

多项图像质量测量

分析选项

“特色”

选择任意图表目标。

任意图表注释:

Imatest 测试图表有多种尺寸和材质可供选择:

    • 玻璃上镀铬(最大 4x4 英寸(100x100 毫米;超精细;无灰阶)),
    • 彩色胶卷(最大 8x10 英寸;精细;低噪点)
    • 黑白胶片(最大尺寸 12x20 英寸;噪点比彩色胶片多;适用于近红外和短波红外成像),
    • 相纸(比喷墨打印纸更精细,更适合近红外和短波红外成像),
    • 喷墨打印(高度可达 44 英寸;但打印效果过于粗糙,不适合制作非常小的图表)。您可以自行打印喷墨图表,但为了获得最佳质量,我们建议您从Imatest 商店购买。

我们鼓励客户联系[email protected]咨询海图适用性问题。请告知我们您相机的像素分辨率和视野范围。

运行 Imatest

Imatest由

  • 双击 Imatest 图标Imatest_icon_16在桌面上,
  • 从 Windows 开始菜单:开始→所有程序→ Imatest →版本→ Imatest_icon_16 Imatest版本,如图所示(右图)。
  • 或者从 Imatest 目录(通常是 C:\Program Files (x86)\Imatest version ,其中version为 Master、IS、Studio 等)中获取,适用于 win64 英文语言安装。

几秒钟后(首次安装或重启后最多一分钟),如下所示的Imatest主窗口将打开。

在新的 Imatest 主窗口中,用户可以选择图像,然后选择要运行的分析。(顺序不限。)点击“分析”按钮即可运行。如果需要选择 ROI 或其他设置,将会弹出一个窗口供用户输入。(如果使用经典界面,则可以通过点击左侧两列中的按钮来运行Imatest分析模块。)

目录。

寻找 Imatest 帮助

  • 您可以在文档页面(目录)上找到全面的Imatest帮助。
  • “学习”图标(Imatest 软件顶部菜单)包含指向重要在线文档的链接。
  • 工具提示(当鼠标悬停在按钮上时,会显示几秒钟的文本块)包含按钮功能的简明说明。
  • 在经典用户界面中,右键单击Imatest主窗口中的大多数按钮(包括右侧的选项卡框)会打开按钮功能的帮助文档。
  • 提供视频和在线培训。

如果您是新手,可以从Github下载几个模块的示例图片。

有问题吗?您通常可以通过搜索“文档”页面或使用网页右上角的放大镜图标搜索整个网站来找到答案。如果这不起作用,

技术支持问题请发送至 [email protected] 。
销售问题(关于购买、续订等)请发送至 [email protected] 。
有关测试图表的问题(尤其是有关测试图表定制的问题)请发送至 [email protected] 。

这些邮件每封都会发送给多人。即使您想联系的是特定人员,也建议发送一封这样的邮件,因为如果该人员不在,您更有可能快速得到回复。以下是一些其他有用的资源。

视频–在线培训–咨询

已保存的设置:imatest-v2.ini

设置保存在名为 imatest-v2.ini 的 INI 文件中,在“已保存的设置(INI 文件)” 和“数据”选项卡中的“管理设置”按钮中有详细说明。

设置项包括字体大小、图像的打开和保存文件夹、计算参数、绘图选择以及要显示和保存的图形。您可以通过“INI 文件”下拉菜单访问多个 INI 文件实用程序(如下所述)。您可以使用INI 文件编辑器或“查看设置(ini 文件)”查看或编辑设置,保存或加载 ini 文件,以及执行更多操作。

您可以执行许多与故障排除和错误修复相关的功能,这些功能在“已保存的设置(INI 文件)” 、 “故障排除”以及重要的知识库文章“ 以前运行正常的模块停止工作”中均有描述。 “INI 文件索引”包含INI 文件监视器的说明,高级用户会对此感兴趣。

显示下拉菜单

“显示”下拉菜单包含影响字体、窗口和图形大小的重要设置。您应该根据图像大小设置合适的字体:字体不宜过小,否则文字难以阅读且未充分利用文本空间;字体也不宜过大,否则文字会遮挡其他对象。

窗口大小下拉菜单
Imatest 主窗口采用大尺寸(120 dpi)字体
Imatest 的一个非常早期的版本

Imatest具有多种设置,可根据不同计算机的 DPI 缩放调整字体和窗口大小。

要访问这些设置,请点击“显示” (位于主窗口顶部栏),这将打开左侧所示的下拉菜单。设置:

  • 字体大小:设置字体大小,使其在数字中显示正确,即不要太小或太大。
  • 正常或放大屏幕( Imatest主窗口)。
  • 正常尺寸或放大尺寸(1.25 倍或 1.5 倍)。放大尺寸的图片可能需要放大字体。
  • 普通或放大的交互式窗口(颜色/色调交互式窗口、Rescharts窗口、批量视图等)

打开图像文件

大多数Imatest分析模块需要打开图像文件。

当您打开模块(在某些情况下)或按下按钮打开图像文件(在其他情况下)时,会弹出一个对话框,要求您输入图像文件名。支持的图像文件格式汇总如下。

支持的图像文件格式

请参阅“图像文件格式和采集设备”了解详细信息。摘要:

  • Matlab imread语句支持的任何文件类型。不常用的格式以灰色显示。
  • LibRaw支持转换多种商业 RAW 格式,包括 CR2、NEF、RW2 等。请参阅LibRaw 0.20 支持的相机列表。新相机通常会在发布后的一到两个月内添加到 LibRaw 中。
  • 在“通用读取原始数据”窗口中,可以通过指定的扩展名识别二进制文件。您可以为扩展名设置像素大小、位深度、去马赛克参数、偏移量等。
  • TGA (塔加)
  • 视频格式,包括DPX 、 Video DNG * 和ARI *(*使用 LibRaw 转换)
  • CSV (某些红外系统中使用的一种特殊格式)
  • HDR高动态范围文件
  • 图像采集设备种类繁多——这里无法一一列举。
多文件读取(批量模式)您可以选择多个文件进行读取。根据您对多图像对话框(如下所示)的响应方式,

文件应位于同一文件夹中,像素尺寸相同(大多数模块如此),且取景方式相同( SFRplus和其他使用自动检测的模块除外,这些模块的文件尺寸可以任意)。如果您选择“合并文件”,则可以选择将合并后的文件默认保存为 16 位 TIFF 格式。Rescharts或 Color/Tone Interactive 等交互式模块不支持批量处理模式。

对于合并的文件,保存的文件名与第一个选定的文件名相同,并附加 _comb_n,其中 n 是合并文件的数量。

  • 输入其他数据。除非选择了快速模式,否则将打开一个“设置”窗口,显示设置数据(具体取决于模块)。大多数附加数据都是可选的(并且会从之前的运行中保存);您只需关注想要更改的设置。单击“确定”运行程序,或单击“取消”终止运行。
  • 保存结果?分析运行完毕后,会弹出一个对话框询问您是否要保存结果。对话框中的复选框允许您选择要保存的图形文件、CSV(Excel 可读)文件和JSON文件。您可以先查看结果,然后再决定是否保存。 (评估版中省略了“保存”复选框。)图形文件可以保存为 PNG(无损压缩)图像文件或 Matlab Fig 文件(不推荐,因为文件较大)。可以使用“打开图形文件”功能打开和编辑 Fig 文件。

实用按钮

在新主窗口中,点击“学习”选项卡,了解 Imatest 图像分析、图表、IQF 和标准。该选项卡还包含教育应用程序的链接。或者,点击顶部菜单栏中的“帮助”菜单。

下面的按钮用于访问经典用户界面中的帮助。

图片右侧标签页中的每个按钮都会打开一个大型帮助窗口,其中包含大量说明和可打开各种功能的按钮。您应该熟悉这些按钮,并在需要时使用它们。

帮助指南(在“帮助”选项卡中)会打开一个窗口,其中包含一些最有用的说明网页的链接以及对其内容的简要说明,包括注册快速入门 | Imatest 说明|图像质量因素| Imatest 导览|目录(网站地图) |常见问题解答|更改日志|测试镜头| MTF 曲线和外观| SFRplus |故障排除。

“管理设置” (位于“数据”选项卡中)会打开一个窗口,其中解释了设置和查看用于保存Imatest设置的文件 imatest-v2.ini 内容的一些关键功能。它还会显示 imatest.ini 的完整路径,并说明如何修复 imatest-v2.ini 损坏时可能出现的错误。功能按钮包括“保存设置...”、“加载设置...”、“查看/编辑设置(ini 文件)”、“复制设置(ini 文件)”、“导入/合并设置”、“编辑/重置模块”和“重置默认值(全部)” 。

“错误处理” (位于“数据”选项卡中)会打开一个窗口,显示遇到错误时应采取的操作。其中包含指向“更改日志”和“故障排除”页面的链接、用于将当前或上次会话复制到剪贴板以便粘贴到电子邮件中的按钮,以及有关在 imatest.ini 文件损坏时如何修复的说明。

原始文件

原始文件是数字图像传感器未经处理的输出。对于拜耳传感器,每个原始像素代表 RGRGRG、GBGBGB……序列中的一种颜色。为了转换为可用的标准文件格式(TIFF、JPEG 等),原始文件必须经过原始转换器处理。原始转换器执行多种功能:去马赛克(将拜耳序列转换为全彩色)、应用伽玛曲线(通常还会应用额外的色调响应曲线)、色彩校正和白平衡、降噪以及锐化图像。这些操作会影响Imatest测量结果,尤其是锐度(MTF 或 SFR) 。

确保图像文件忠实还原原始文件(即处理量最小)的最佳方法是将原始文件导入 Imatest,并使用LibRaw (适用于商业原始文件,例如 CR2、NEF 等扩展名)或通用读取原始文件 (GRRAW ) 将其转换为标准格式(通常为 TIFF)。  对于二进制开发文件(也通过扩展名识别,通常为 RAW),如果是商业 RAW 文件,则会显示右侧的对话框。您可以从中选择几种 RAW 转换选项。有关商业文件和二进制文件的详细信息,请参阅“RAW 文件”部分。

原始文件可以进行去马赛克转换(标准 RGB 格式),也可以不进行去马赛克转换(这样就可以分别分析原始的 R、G(R)、B、G(B) 通道)。

退出操作会关闭所有图形并终止 Imatest。

“关闭图形”会关闭所有图形窗口。这一点很重要,因为如果打开的图形窗口过多,电脑运行速度会变慢。您可以使用常用的 Windows 方法单独关闭图形窗口——单击右上角的“X”或右键单击任务栏上的图形图标并选择“关闭” 。

EXIF (位于“实用工具”下拉菜单中)显示图像文件的EXIF元数据。安装ExifTool后,支持大多数文件格式(安装说明见下文)。EXIF 数据可以按字母顺序排列,方便查找设置,也可以复制到剪贴板(粘贴到文本编辑器中),还可以保存到与图像文件位于同一文件夹中的文本文件中。

EXIF 查看器

Figures

 

Imatest figure: You can resize it or zoom in on individual plots.
The toolbar, which includes Data cursor Data Cursor icon, is shown.

Imatest results are displayed in individual windows called Figures. A typical figure— a result of running SFR— is shown on the right.

Figures may be resized, minimized, maximized, or closed using standard Windows operations. In addition, several Windows and Matlab-specific operations can be found in the toolbar at the top of the image.

The first four icons in the toolbar are standard Windows icons: New file, Open, Save, and Print. Open and Save refer to Matlab .fig figures, which should be used sparingly because they require excessive storage. 

Of the remaining icons, Zoom in: is particularly useful. Clicking on it highlights it and enables you to zoom in on regions of the plots. You can click and drag to create a zoom rectangle or you can click on any point to zoom in on that point. Double-clicking anywhere inside the image restores the full unzoomed image.

Data Cursor example
Data cursor example

Data Cursor, selected on by the Data Cursor icon toolbar icon, lets you click on a curve and display its coordinates in a small box called a Datatip. Right-clicking on the Datatip lets you can delete it or choose additional options.

In most modules, figures can be saved as either PNG files (a standard losslessly-compressed image file format) or as Matlab FIG files, which can be opened by Open Fig file in the Utility dropdown menu, then manipulated (zoomed and rotated). PNG files are usually preferred because FIG files require much more storage, especially for 3D FIG files, which can be rotated. 

Too many open Figures

Figures can proliferate if you do a number of runs, especially runs with multiple regions. System performance degrades if too many Figures are open. Figures can be closed individually by clicking X on the upper right of the Figure or by any of the usual Windows techniques. You can close them all by clicking Close figures in the Imatest main window.

CSV and JSON output files

Individual Imatest modules can optionally write two types of output file that contain most results.

  • CSV files are most often displayed with Microsoft Excel.
  • JSON files, which contain a single large JSON structure, can be read into programs written in almost any language with a single line of code using functions linked from the JSON website. They can be displayed in any text editor.

Please contact us if you have requests or suggestions about Imatest output. [Notes: These files are not saved in evaluation mode. ]

CSV files– Excel-readable Comma-Separated Variable format. Here is an example of typical output.

Module,Colorcheck
File,Canon_EOS10d_ColorCheck_lt_small.jpg
Run date,31-Dec-2005 18:11:00
Zone,Gray,Pixel,Pixel/255,Px/255 ideal,Log(exp),Log(px/255),WB Err Deg,WB Err Mired
19, 1, 241.6, 0.9475, 0.9569, -0.050, -0.023, 163, -3.8
20, 2, 215.8, 0.8464, 0.7922, -0.230, -0.072, 491, -10.8
21, 3, 179.0, 0.7020, 0.6353, -0.440, -0.154, 450, -10.0

The same data displayed in Excel looks like this.

Sample .CSV output displayed in Excel

JSON files are somewhat human-readable text files that contain a single structure— optimized for reading into programs written in virtually any programming language.

{
      "jstruct": {
            "dateRun": "03-May-2018 12:14:03",
            "ini_time_size": "03-May-2018 12:02:35 104121B  MD5 = 6a03a447754eefcc2ada6698ec63d30e",
            "version": "Imatest 5.1.0. ALPHA  Colorcheck",
            "build": "NOT COMPILED",
            "full_path_name": "C:\\imatest\\Data\\Colorcheck\\Canon_eos10d_ColorCheck_lt.jpg",
            "file_name": "Canon_eos10d_ColorCheck_lt.jpg",
            "mean_cameraSat_Pct": [0.9888],
            "pxlLevel_graypatch": [241.67,215.9,179.27,135.26,84.58,34.63],
            "pxlLevel_norml_graypatch": [0.9477,0.8467,0.703,0.5304,0.3317,0.1358],
            "densityNominal": [0.949,0.7882,0.6314,0.4784,0.3255,0.1922],
            "logExposure": [-0.05,-0.23,-0.44,-0.7,-1.05,-1.5],
            "logNormlPxlLevel": [-0.023,-0.072,-0.153,-0.275,-0.479,-0.867],
            "whiteBalErrDegs": [157.3,478,487.1,833.4,954.2,568.3],
...
            "Mean_Delta_E_00": [5.31],
            "Max_Delta_E_00": [11.42],
            "Sigma_Delta_E_00": [5.76],
            "Mean_Delta_C_00": [3.05],
            "Mean_White_Balance_delta_C_00": [2.87],
            "Max_Delta_C_00": [7.52],
            "Sigma_Delta_C_00": [3.45],
            "Mean_Delta_C_00_Sat_corrected": [3.08],
            "Max_Delta_C_00_Sat_corrected": [7.5],
            "Sigma_Delta_C_00_Sat_corrected": [3.44],
            "passfail": {
                  "ini_time_size": "04-Jul-2017 09:31:58 1734B  MD5 = 1a759325ea50ce2c4bc826dae419feac",
                  "passFailFile": "C:\\imatest\\Data\\ini_files\\passfailtest_1.txt",
                  "started_at": "2018-05-03 12:14:03",
                  "ended_at": "2018-05-03 12:14:20",
                  "runtime": [9.135914449],
                  "INI_read_success": "[colorcheck] NOT FOUND",
                  "all_tests_passed": [1]
            }
      }
}

Imatest license (EULA)

The full text of the Imatest license can be found here.

License holders are encouraged to publish test results in printed publications, websites, and discussion forums, provided they include links to www.imatest.com. The use of the Imatest Logo is encouraged. However you may not use Imatest for advertising or product promotion without explicit permission from Imatest LLC. Contact us if you have questions. 

Tips for successful testing

Imatest LLC assumes no legal liability for the contents of published reviews. If you plan to publish test results, especially for MTF, you should take care to use good technique. Considerations include,

Sturdy camera supportUse a sturdy tripod, cable release, and, if possible, mirror-lock on DSLRs. Imatest offers high quality solutions for professional test labs.
Target mountingIf you are working outdoors, be sure the target doesn't shake in the wind.
Target distanceBe sure you're far enough from the target (the magnification is low enough) so the printed edge quality doesn't affect the measurements. Target distance considerations are given here.
FocusBe sure the camera is focused accurately on the target. Note whether you used manual or automatic focus. Some targets, like Spilled Coins/Dead Leaves targets, may work poorly with autofocus.
Target alignmentIn most cases, the chart should be normal (perpendicular) to the optical axis of the lens. Make sure the corners, as well as the center, are in focus.
IlluminationShould be as even as possible. Use an incident light meter if needed.
ExposureTake care not to clip (saturate) shadows or highlights. This will reduce accuracy of the results.
Raw conversion and settingsThe Raw converter (in or out of the camera) and image processing pipeline, particularly Sharpening, can make a huge difference. Contrast and White balance are also important. Settings that affect contrast and transfer curve can also have a strong effect. If possible a "Linear" setting (meaning a straight gamma curve with no additional tonal response adjustments) should be used.
GammaSFR sharpness results are moderately sensitive to the Gamma setting: A 10% gamma error changes MTF50 by 2.5%. Gamma can be measured from slanted edges of known contrast (if ≤ 10) or from a grayscale chart by running Color/Tone Interactive, Color/Tone Auto, Colorcheck or Stepchart.
Cleanliness and filtersLens surfaces should be clean. You should note whether you have a protective (UV or Skylight) filter. It can make a difference— more likely reduced contrast than reduced sharpness. With Imatest you can find out.
File formatsUse Raw, PNG, TIFF, or the highest JPEG quality. Never use less than the maximum resolution or JPEG quality unless you are specifically testing the effects of these settings.
Lens settingsLens performance is a strong function of the aperture (f-stop) and focal length (for zooms). Be sure to record these settings (easy because they're saved with the EXIF data) and include them in your reports. The optimum (sharpest) aperture is of particular interest. Lens performance is also somewhat affected by the distance to the target. Rename Files can add key settings to the image file name using EXIF data.
White balanceShould be close as possible to neutral, particularly in Colorcheck.
This may seem like a lot of fuss, but the technique you develop in testing cameras and lenses will spill over to your daily photography. Alfred Stieglitz tested film and developers extensively when he discovered photography as a student in Berlin. Ansel Adams performed extensive tests in the development of his zone system. Although nobody would claim that testing is responsible for their unique vision, it certainly contributed to the skill that transformed their vision into prints of transcendent beauty.