Imatest 使用說明 - 入門指南

Imatest軟體可以根據測試圖表影像測量數位相機的多種影像品質因素。

如果您是新手,我們建議您探索以下內容:

圖像品質因素頁面和初學者智商測驗。

最常用的兩種圖表類型/分析模組是SFRplus和eSFR ISO 。它們允許使用者從單一測試圖表影像中測量多種影像品質因素。其他模組和圖表可幫助您應對各種各樣的測試挑戰。

本頁內容連結:

Imatest工作流程

Imatest 基本工作流程
1.確定需要測試的影像品質因素(清晰度、色彩響應、色調響應、雜訊、光學畸變等)。
2.選擇執行測試所需的測試圖表。圖表可在Imatest 商店中找到。
3.拍攝圖表,並依照對應分析模組的說明進行構圖。如果您是新手,可以從GitHub下載幾個模組的範例圖片。
4.開啟 Imatest 並使用對應的模組分析影像。
5. 根據經驗並與同類相機進行比較來解讀結果。
6.根據需要儲存結果(結果由數字和文字組成,格式為 CSV 或 JSON)。

下載及試用版 —您可以點擊此處下載Imatest 。安裝說明請點擊此處。如果您是新用戶,將自動開始14 天免費試用。  首次運行軟體時。準備好後,您可以從商店購買Imatest許可證,並按照這些連結中的說明啟動它。

線上啟用|離線啟動|線上停用|離線停用|浮動許可證|代理伺服器|知識庫包含多個鏈接,可協助解決啟動問題。
 

許可證啟動說明: Imatest 節點鎖定許可證一次只能在一台電腦上激活,但激活狀態可以在電腦之間轉移。您可以在任意數量的電腦(包括 Macintosh 和 Windows 系統)上安裝Imatest ,並保持其安裝狀態。若要將啟動狀態轉移到另一台計算機,您需要先在舊計算機上停用許可證,然後在新計算機上按照上述說明啟動。 Imatest浮動授權更容易在多台電腦之間共用,因為它不需要停用和重新啟用步驟。點擊此處了解更多關於不同許可證類型的信息。

大多數工程師使用基於圖形使用者介面的Imatest Master 。

Imatest 的其他版本包括:

Imatest Studio擁有個人攝影師測試相機和鏡頭所需的一切(但缺少設計和製造相機的許多高級功能),可供個人攝影師和小型工作室使用。

Imatest IT (工業測試)是 Imatest 軟體的非圖形使用者介面版本,專為製造環境設計。本頁不討論其 IT 介面。

Imatest 主窗口

Imatest Main Window▶
Imatest 主窗口

Imatest 主視窗允許使用者存取 Imatest 的所有功能。我們的主視窗已在 2021.2 版本中更新。點擊此處了解新的 Imatest 主視窗。

也可以選擇使用原始的 Imatest 介面,只需在主選單中選擇「經典 UI」即可——有關經典主視窗的文件在此處。

經典 Imatest 主視窗。
點擊圖片可看完整尺寸。

互動式 vs. 自動(批次)

大多數Imatest分析都可以在互動式或自動(批次)模式下進行。

詳情請參閱「固定模組與互動式模組」頁面。

在 2021.2 版本中, Imatest 引入了新的主窗口,使選擇影像和分析變得更加容易。

在新的 Imatest 主視窗 (2021.2) 中,透過設定分析卡底部附近的互動式/自動(批次)開關選項來選擇所需的模式。

互動式分析選項與自動(批次)分析選項
(這些不應與下文「ROI選項」部分所述的自動區域選擇與手動區域選擇混淆。)

互動模式

使用此模式可以讀取和分析文件中的影像,或直接從擷取裝置讀取和分析影像,並以互動方式探索設定和結果。

自動(批量)模式

使用此模式可以有效地對單一檔案或一批檔案執行分析,使用先前已配置的設定(在自動/批次運行之前)。

在新的 Imatest GUI 中,選擇分析(例如 eSFR ISO),並將分析卡上的模式設定為互動式。在新的 Imatest GUI 中,選擇分析類型(例如 eSFR ISO),並將模式設為自動(批次)。

如果使用經典 Imatest UI窗口,請按一下右側列中的「分析」(互動式)以選擇此選項。

範例: eSFR ISO設定

如果使用經典 Imatest UI視窗 - 可以透過點擊最左側(固定)列中的分析類型來選擇此選項。

範例: eSFR ISO 自動

如果兩種模式都可用,則應先執行互動模式以驗證設定和結果。
自動(批次)模式使用互動模式下配置的大部分設定。
分析過程中可以更改參數在此模式下運作前必須設定參數。

結果可在互動式視窗中查看。

結果也可以儲存為 CSV、JSON 檔案或 HTML 和 PDF 報告。

結果以固定格式的圖形、CSV 和 JSON 檔案呈現。
待分析的影像可以從影像檔案或透過直接擷取取得,這可以透過裝置管理員進行設定。

僅讀取文件中的圖像。

批量讀取不可用可以透過選擇多個影像檔案來分析多批影像
訊號平均法快速便捷支援對多個影像檔案進行訊號平均

選擇圖表和模組:您想測量什麼?

本指南旨在幫助初學者選擇最能滿足其需求的圖表。影像品質因素和清晰度 包含關鍵測量的詳細資訊。

如果您已經選擇了圖表,請跳過此表。

測量、圖表和模組指南,按測量單位索引
互動式模組在「經典介面」欄中以高亮顯示。
測量圖表

新主街

窗戶

經典介面

銳利度(從任何傾斜邊緣)
手動ROI檢測。適用於任何傾斜邊緣,包括舊版ISO 12233:2000標準。當需要分析多張影像時,ROI選擇可能會比較繁瑣。
用於測量垂直調變傳遞函數 (MTF) 的裁切斜邊影像。

在「銳利度」的分析選項中,選擇「適當目標」。

SFR

雷沙茨

清晰度、橫向色差、色調、色彩等等…

這些斜邊圖表具有自動ROI檢測功能,並可執行多項影像品質測量。它們可以以互動模式(標記為“設定”)或固定模式(標記為“自動”)運行。此處對它們進行了比較。

它們各自具有特定的優勢和應用場景。

SFRplus具有最佳的空間清晰度細節和良好的畸變測量。

eSFR ISO可進行詳細的色彩和雜訊測量,並包含用於測量混疊和莫爾條紋的楔形塊。

SFRreg可用於超廣角應用。可列印大型 SFRreg 圖表用於遠距離測量。

棋盤格法具有最精確的失真測量精準度。

SFRplus 、 eSFR ISO 、棋盤格和點陣圖案圖表旨在填滿(或幾乎填滿)整個影像。大多數其他圖表僅設計用於填充圖像的一部分。

分析選項

“特色”

選擇 SFR Plus 目標。

SFRplus 設定

SFRplus 汽車

分析選項

“特色”

選擇 eSFR ISO 目標。

eSFR ISO設定

eSFR ISO 自動

在分析選項中

“特色”

選擇SFR Reg目標。

SFRreg 設定

SFRreg 汽車

分析選項

“特色”,選擇棋盤格目標。

棋盤格設定

棋盤格自動

質感、清晰度

對數頻率對比和散落硬幣(或隨機/枯葉)圖表。這一點很重要,因為傾斜邊緣無法測量精細紋理反應。

在分析選項中

“銳利度”,選擇 Log F 對比目標。

對數 F 對比度

Rescharts – Log FC

在分析選項中

“銳利度”,選擇

隨機/枯葉目標。

隨機/枯萎的樹葉

Rescharts – 隨機

清晰度
資訊能力

西門子星形圖表。

分析選項

“銳利度”,選擇

星圖目標。

星星

雷沙茨 – 明星

清晰度
同構效應,莫爾條紋
楔形體也是 eSFR ISO 的一部分。
對數 F 對比圖分析選項

“銳利度”

選擇楔形目標。

楔

雷沙茨楔形

清晰度(相對)
從任何圖像

快速比較多批影像
測量方法不規範。

對數 F 對比圖

在「實用工具」選單下的「影像工具」中,選擇

尋找最清晰的文件

尋找最清晰的文件

顏色響應
音調響應(OECF)、噪音、
顏色校正矩陣(CCM)

顏色/色調互動式和自動模式支援大量的灰階階梯圖和顏色圖。這裡僅展示其中一部分。

ColorChecker SG
ColorGauge_120W ChromaDuMonde 28 測試圖表
分析選項

顏色,

選擇合適的目標。

(Colorchecker 24,Colorchecker SG,

通用MxN顏色,

以及許多其他選項)

顏色/色調自動

顏色/色調互動

動態範圍

使用多層透射式照相膠片圖表進行測量。
了解更多關於測量動態範圍的資訊。

dynamic_35_E_200W
請參閱動態範圍頁面。

顏色/色調自動

顏色/色調互動

步驟圖(舊版模組)

色彩和色調響應
Colorcheck 僅支援X-Rite 24 色塊Colorchecker。
建議在新作品中使用色彩/色調。

分析選項

顏色,

選擇「透過 Colorcheck 選擇 Colorchecker 24」目標。

顏色檢查
(舊版模組)僅適用於 24 色 X-Rite 色卡。

音調響應(OECF)和噪音
步驟圖。建議在新作品中使用色彩/色調。

Image of the Q-13 Gray scale分析選項

語氣,選擇合適的目標。

步驟圖
(舊版模組)可與多個灰階階梯圖搭配使用。

照明均勻性,
顏色陰影,缺陷像素

用於分析平場影像的多功能模組

光照衰減等值線圖在分析選項中

均勻性,

選擇均勻性目標。

均勻性

Uniformity Interactive

這些模組適用於平場影像。

瑕疵(感測器缺陷)
設定經過精心調整,可以偵測出可見的瑕疵,而忽略不太明顯的瑕疵。
原始測試影像(已裁切)在分析選項中

均勻性/瑕疵,

選擇平場目標。

瑕疵檢測

適用於平場影像。

失真,
橫向色差

相容於多種標準。設計用於填充(或幾乎填充)圖像。

在分析選項中

失真,

選擇點陣圖案目標。

點狀圖案

失真
了解更多關於測量失真的信息

棋盤格校正比傳統的失真校正模組更強大、更準確(並且可以處理更多失真影像)。

在分析選項中

失真,

選擇棋盤格目標。

棋盤格設定

棋盤格自動

失真(舊版模組)

自訂圖表

多項影像品質測量

分析選項

“特色”

選擇任意圖表目標。

任一圖表註記:

Imatest 測試圖表有多種尺寸和材質可供選擇:

    • 玻璃上鍍鉻(最大 4x4 英吋(100x100 毫米;超精細;無灰階)),
    • 彩色膠卷(最大 8x10 英吋;精細;低雜訊)
    • 黑白膠片(最大尺寸 12x20 英吋;雜訊比彩色膠片多;適用於近紅外線和短波紅外線成像),
    • 相紙(比噴墨列印紙更精細,更適合近紅外線和短波紅外線成像),
    • 噴墨列印(高度可達 44 吋;但列印效果過於粗糙,不適合製作非常小的圖表)。您可以自行列印噴墨圖表,但為了獲得最佳質量,我們建議您從Imatest 商店購買。

我們鼓勵客戶聯絡[email protected]諮詢海圖適用性問題。請告知我們您相機的像素解析度和視野範圍。

運行 Imatest

Imatest由

  • 雙擊 Imatest 圖標Imatest_icon_16在桌面上,
  • 從 Windows 開始功能表:開始→所有程式→ Imatest →版本→ Imatest_icon_16 Imatest版本,如圖所示(右圖)。
  • 或從 Imatest 目錄(通常是 C:\Program Files (x86)\Imatest version ,其中version為 Master、IS、Studio 等)中獲取,適用於 win64 英文語言安裝。

幾秒鐘後(首次安裝或重新啟動後最多一分鐘),如下所示的Imatest主視窗將會開啟。

在新的 Imatest 主視窗中,使用者可以選擇映像,然後選擇要執行的分析。 (順序不限。)點選「分析」按鈕即可運行。如果需要選擇 ROI 或其他設置,將會彈出一個視窗供使用者輸入。 (如果使用經典介面,則可以點擊左側兩列中的按鈕來執行Imatest分析模組。)

目錄。

尋找 Imatest 幫助

  • 您可以在文件頁面(目錄)上找到全面的Imatest幫助。
  • 「學習」圖示(Imatest 軟體頂部選單)包含指向重要線上文件的連結。
  • 工具提示(當滑鼠懸停在按鈕上時,會顯示幾秒鐘的文字區塊)包含按鈕功能的簡明說明。
  • 在經典使用者介面中,以滑鼠右鍵按一下Imatest主視窗中的大多數按鈕(包括右側的選項卡框)會開啟按鈕功能的說明文件。
  • 提供影片和線上培訓。

如果您是新手,可以從Github下載幾個模組的範例圖片。

有問題嗎?您通常可以透過搜尋「文件」頁面或使用網頁右上角的放大鏡圖示搜尋整個網站來找到答案。如果這不起作用,

技術支援問題請發送至 [email protected] 。
銷售問題(關於購買、續約等)請寄至[email protected] 。
有關測試圖表的問題(尤其是有關測試圖表定制的問題)請發送至 [email protected] 。

這些郵件每封都會寄給多人。即使您想聯繫的是特定人員,也建議發送這樣的郵件,因為如果該人員不在,您更有可能快速得到回覆。以下是一些其他有用的資源。

影片–線上培訓–諮詢

已儲存的設定:imatest-v2.ini

設定保存在名為 imatest-v2.ini 的 INI 檔案中,在「已儲存的設定(INI 檔案)」 和「資料」標籤中的「管理設定」按鈕中有詳細說明。

設定項目包括字體大小、圖像的開啟和儲存資料夾、計算參數、繪圖選擇以及要顯示和儲存的圖形。您可以透過「INI 檔案」下拉式選單存取多個 INI 檔案實用程式(如下所述)。您可以使用INI 文件編輯器或「檢視設定(ini 檔案)」檢視或編輯設置,儲存或載入 ini 文件,以及執行更多操作。

您可以執行許多與故障排除和錯誤修復相關的功能,這些功能在「已儲存的設定(INI 檔案)」 、 「故障排除」以及重要的知識庫文章「 先前運作正常的模組停止運作」中均有描述。 「INI 檔案索引」包含INI 檔案監視器的說明,進階使用者會對此感興趣。

顯示下拉式選單

「顯示」下拉式選單包含影響字型、視窗和圖形大小的重要設定。您應該根據圖像大小設定合適的字體:字體不宜過小,否則文字難以閱讀且未充分利用文字空間;字體也不宜過大,否則文字會遮擋其他物件。

視窗大小下拉選單
Imatest 主視窗採用大尺寸(120 dpi)字體
Imatest 的一個非常早期的版本

Imatest具有多種設置,可根據不同電腦的 DPI 縮放調整字體和視窗大小。

若要存取這些設置,請點擊「顯示」 (位於主視窗頂部欄),這將開啟左側所示的下拉式選單。設定:

  • 字體大小:設定字體大小,使其在數字中顯示正確,即不要太小或太大。
  • 正常或放大螢幕( Imatest主視窗)。
  • 正常尺寸或放大尺寸(1.25 倍或 1.5 倍)。放大尺寸的圖片可能需要放大字體。
  • 普通或放大的互動式視窗(顏色/色調互動視窗、Rescharts視窗、批次視圖等)

打開圖像文件

大多數Imatest分析模組需要開啟映像檔。

當您開啟模組(在某些情況下)或按下按鈕開啟影像檔案(在其他情況下)時,會彈出一個對話框,要求您輸入影像檔案名稱。支援的圖像檔案格式匯總如下。

支援的圖像檔案格式

請參閱「影像檔案格式和擷取設備」以了解詳細資訊。摘要:

  • Matlab imread語句支援的任何檔案類型。不常用的格式以灰色顯示。
  • LibRaw支援轉換多種商業 RAW 格式,包括 CR2、NEF、RW2 等。請參閱LibRaw 0.20 支援的相機清單。新相機通常會在發布後的一到兩個月內添加到 LibRaw 中。
  • 在「通用讀取原始資料」視窗中,可以透過指定的副檔名來識別二進位檔案。您可以為副檔名設定像素大小、位元深度、去馬賽克參數、偏移量等。
  • TGA (塔加)
  • 視訊格式,包括DPX 、 Video DNG * 和ARI *(*使用 LibRaw 轉換)
  • CSV (某些紅外線系統中使用的一種特殊格式)
  • HDR高動態範圍文件
  • 影像擷取設備種類繁多-這裡無法一一列舉。
多文件讀取(批次模式)您可以選擇多個文件進行讀取。根據您對多圖像對話框(如下所示)的回應方式,

檔案應位於同一資料夾中,像素尺寸相同(大多數模組如此),且取景方式相同( SFRplus和其他使用自動偵測的模組除外,這些模組的檔案尺寸可以任意)。如果您選擇“合併文件”,則可以選擇將合併後的文件預設為 16 位元 TIFF 格式。 Rescharts或 Color/Tone Interactive 等互動式模組不支援批次處理模式。

對於合併的文件,儲存的文件名稱與第一個選定的文件名稱相同,並附加 _comb_n,其中 n 是合併文件的數量。

  • 輸入其他數據。除非選擇了快速模式,否則將開啟一個「設定」窗口,顯示設定資料(取決於模組)。大多數附加資料都是可選的(並且會從先前的運行中儲存);您只需專注於想要更改的設定。按一下「確定」運行程序,或按一下「取消」終止運行。
  • 保存結果?分析運行完畢後,會彈出一個對話框詢問您是否要儲存結果。對話方塊中的複選框可讓您選擇要儲存的圖形檔案、CSV(Excel 可讀)檔案和JSON檔案。您可以先查看結果,然後再決定是否要儲存。 (評估版中省略了「儲存」複選框。)圖形檔案可以儲存為 PNG(無損壓縮)影像檔案或 Matlab Fig 檔案(不推薦,因為檔案較大)。可以使用「開啟圖形檔案」功能開啟和編輯 Fig 檔案。

實用按鈕

在新主視窗中,點擊「學習」標籤,以了解 Imatest 影像分析、圖表、IQF 和標準。該選項卡還包含教育應用程式的連結。或者,點擊頂部選單列中的「幫助」選單。

下面的按鈕用於存取經典用戶介面中的幫助。

圖片右側標籤頁中的每個按鈕都會開啟一個大型幫助窗口,其中包含大量說明和可開啟各種功能的按鈕。您應該熟悉這些按鈕,並在需要時使用它們。

幫助指南(在「幫助」標籤中)會開啟一個窗口,其中包含一些最有用的說明網頁的連結以及對其內容的簡要說明,包括註冊快速入門 | Imatest 說明|圖像品質因素| Imatest 導覽|目錄(網站地圖) |常見問題解答|更改日誌|測試鏡頭| MTF 曲線外觀和故障排除|

「管理設定」 (位於「資料」標籤中)會開啟一個窗口,其中解釋了設定和檢視用於儲存Imatest設定的檔案 imatest-v2.ini 內容的一些關鍵功能。它還會顯示 imatest.ini 的完整路徑,並說明如何修復 imatest-v2.ini 損壞時可能出現的錯誤。功能按鈕包括「儲存設定...」、「載入設定...」、「檢視/編輯設定(ini 檔案)」、「複製設定(ini 檔案)」、「匯入/合併設定」、「編輯/重設模組」和「重設預設值(全部)」 。

「錯誤處理」 (位於「資料」標籤中)會開啟一個窗口,顯示遇到錯誤時應採取的動作。其中包含指向「更改日誌」和「故障排除」頁面的連結、用於將當前或上次會話複製到剪貼簿以便貼上到電子郵件中的按鈕,以及有關在 imatest.ini 檔案損壞時如何修復的說明。

原始文件

原始文件是數位影像感測器未經處理的輸出。對於拜耳感光元件,每個原始像素代表 RGRGRG、GBGBGB…序列中的一種顏色。為了轉換為可用的標準檔案格式(TIFF、JPEG 等),原始檔案必須經過原始轉換器處理。原始轉換器執行多種功能:去馬賽克(將拜耳序列轉換為全彩)、應用伽瑪曲線(通常還會應用額外的色調響應曲線)、色彩校正和白平衡、降噪以及銳化影像。這些操作會影響Imatest測量結果,尤其是銳利度(MTF 或 SFR) 。

確保影像檔案忠實還原原始檔案(即處理量最小)的最佳方法是將原始檔案匯入 Imatest,並使用LibRaw (適用於商業原始文件,例如 CR2、NEF 等副檔名)或通用讀取原始檔案 (GRRAW ) 將其轉換為標準格式(通常為 TIFF)。  對於二進位開發文件(也透過副檔名識別,通常為 RAW),如果是商業 RAW 文件,則會顯示右側的對話方塊。您可以從中選擇幾種 RAW 轉換選項。有關商業文件和二進製文件的詳細信息,請參閱“RAW 文件”部分。

原始檔案可以進行去馬賽克轉換(標準 RGB 格式),也可以不進行去馬賽克轉換(這樣就可以分別分析原始的 R、G(R)、B、G(B) 通道)。

退出操作會關閉所有圖形並終止 Imatest。

“關閉圖形”會關閉所有圖形視窗。這一點很重要,因為如果開啟的圖形視窗太多,電腦運作速度會變慢。您可以使用常用的 Windows 方法單獨關閉圖形視窗—點擊右上角的「X」或右鍵單擊工作列上的圖形圖示並選擇「關閉」 。

EXIF (位於「實用工具」下拉選單中)顯示影像檔案的EXIF元資料。安裝ExifTool後,支援大多數檔案格式(安裝說明請見下文)。 EXIF 資料可以按字母順序排列,方便查找設置,也可以複製到剪貼簿(貼上到文字編輯器中),也可以儲存到與圖像檔案位於同一資料夾中的文字檔案中。

EXIF 檢視器

Figures

 

Imatest figure: You can resize it or zoom in on individual plots.
The toolbar, which includes Data cursor Data Cursor icon, is shown.

Imatest results are displayed in individual windows called Figures. A typical figure— a result of running SFR— is shown on the right.

Figures may be resized, minimized, maximized, or closed using standard Windows operations. In addition, several Windows and Matlab-specific operations can be found in the toolbar at the top of the image.

The first four icons in the toolbar are standard Windows icons: New file, Open, Save, and Print. Open and Save refer to Matlab .fig figures, which should be used sparingly because they require excessive storage. 

Of the remaining icons, Zoom in: is particularly useful. Clicking on it highlights it and enables you to zoom in on regions of the plots. You can click and drag to create a zoom rectangle or you can click on any point to zoom in on that point. Double-clicking anywhere inside the image restores the full unzoomed image.

Data Cursor example
Data cursor example

Data Cursor, selected on by the Data Cursor icon toolbar icon, lets you click on a curve and display its coordinates in a small box called a Datatip. Right-clicking on the Datatip lets you can delete it or choose additional options.

In most modules, figures can be saved as either PNG files (a standard losslessly-compressed image file format) or as Matlab FIG files, which can be opened by Open Fig file in the Utility dropdown menu, then manipulated (zoomed and rotated). PNG files are usually preferred because FIG files require much more storage, especially for 3D FIG files, which can be rotated. 

Too many open Figures

Figures can proliferate if you do a number of runs, especially runs with multiple regions. System performance degrades if too many Figures are open. Figures can be closed individually by clicking X on the upper right of the Figure or by any of the usual Windows techniques. You can close them all by clicking Close figures in the Imatest main window.

CSV and JSON output files

Individual Imatest modules can optionally write two types of output file that contain most results.

  • CSV files are most often displayed with Microsoft Excel.
  • JSON files, which contain a single large JSON structure, can be read into programs written in almost any language with a single line of code using functions linked from the JSON website. They can be displayed in any text editor.

Please contact us if you have requests or suggestions about Imatest output. [Notes: These files are not saved in evaluation mode. ]

CSV files– Excel-readable Comma-Separated Variable format. Here is an example of typical output.

Module,Colorcheck
File,Canon_EOS10d_ColorCheck_lt_small.jpg
Run date,31-Dec-2005 18:11:00
Zone,Gray,Pixel,Pixel/255,Px/255 ideal,Log(exp),Log(px/255),WB Err Deg,WB Err Mired
19, 1, 241.6, 0.9475, 0.9569, -0.050, -0.023, 163, -3.8
20, 2, 215.8, 0.8464, 0.7922, -0.230, -0.072, 491, -10.8
21, 3, 179.0, 0.7020, 0.6353, -0.440, -0.154, 450, -10.0

The same data displayed in Excel looks like this.

Sample .CSV output displayed in Excel

JSON files are somewhat human-readable text files that contain a single structure— optimized for reading into programs written in virtually any programming language.

{
      "jstruct": {
            "dateRun": "03-May-2018 12:14:03",
            "ini_time_size": "03-May-2018 12:02:35 104121B  MD5 = 6a03a447754eefcc2ada6698ec63d30e",
            "version": "Imatest 5.1.0. ALPHA  Colorcheck",
            "build": "NOT COMPILED",
            "full_path_name": "C:\\imatest\\Data\\Colorcheck\\Canon_eos10d_ColorCheck_lt.jpg",
            "file_name": "Canon_eos10d_ColorCheck_lt.jpg",
            "mean_cameraSat_Pct": [0.9888],
            "pxlLevel_graypatch": [241.67,215.9,179.27,135.26,84.58,34.63],
            "pxlLevel_norml_graypatch": [0.9477,0.8467,0.703,0.5304,0.3317,0.1358],
            "densityNominal": [0.949,0.7882,0.6314,0.4784,0.3255,0.1922],
            "logExposure": [-0.05,-0.23,-0.44,-0.7,-1.05,-1.5],
            "logNormlPxlLevel": [-0.023,-0.072,-0.153,-0.275,-0.479,-0.867],
            "whiteBalErrDegs": [157.3,478,487.1,833.4,954.2,568.3],
...
            "Mean_Delta_E_00": [5.31],
            "Max_Delta_E_00": [11.42],
            "Sigma_Delta_E_00": [5.76],
            "Mean_Delta_C_00": [3.05],
            "Mean_White_Balance_delta_C_00": [2.87],
            "Max_Delta_C_00": [7.52],
            "Sigma_Delta_C_00": [3.45],
            "Mean_Delta_C_00_Sat_corrected": [3.08],
            "Max_Delta_C_00_Sat_corrected": [7.5],
            "Sigma_Delta_C_00_Sat_corrected": [3.44],
            "passfail": {
                  "ini_time_size": "04-Jul-2017 09:31:58 1734B  MD5 = 1a759325ea50ce2c4bc826dae419feac",
                  "passFailFile": "C:\\imatest\\Data\\ini_files\\passfailtest_1.txt",
                  "started_at": "2018-05-03 12:14:03",
                  "ended_at": "2018-05-03 12:14:20",
                  "runtime": [9.135914449],
                  "INI_read_success": "[colorcheck] NOT FOUND",
                  "all_tests_passed": [1]
            }
      }
}

Imatest license (EULA)

The full text of the Imatest license can be found here.

License holders are encouraged to publish test results in printed publications, websites, and discussion forums, provided they include links to www.imatest.com. The use of the Imatest Logo is encouraged. However you may not use Imatest for advertising or product promotion without explicit permission from Imatest LLC. Contact us if you have questions. 

Tips for successful testing

Imatest LLC assumes no legal liability for the contents of published reviews. If you plan to publish test results, especially for MTF, you should take care to use good technique. Considerations include,

Sturdy camera supportUse a sturdy tripod, cable release, and, if possible, mirror-lock on DSLRs. Imatest offers high quality solutions for professional test labs.
Target mountingIf you are working outdoors, be sure the target doesn't shake in the wind.
Target distanceBe sure you're far enough from the target (the magnification is low enough) so the printed edge quality doesn't affect the measurements. Target distance considerations are given here.
FocusBe sure the camera is focused accurately on the target. Note whether you used manual or automatic focus. Some targets, like Spilled Coins/Dead Leaves targets, may work poorly with autofocus.
Target alignmentIn most cases, the chart should be normal (perpendicular) to the optical axis of the lens. Make sure the corners, as well as the center, are in focus.
IlluminationShould be as even as possible. Use an incident light meter if needed.
ExposureTake care not to clip (saturate) shadows or highlights. This will reduce accuracy of the results.
Raw conversion and settingsThe Raw converter (in or out of the camera) and image processing pipeline, particularly Sharpening, can make a huge difference. Contrast and White balance are also important. Settings that affect contrast and transfer curve can also have a strong effect. If possible a "Linear" setting (meaning a straight gamma curve with no additional tonal response adjustments) should be used.
GammaSFR sharpness results are moderately sensitive to the Gamma setting: A 10% gamma error changes MTF50 by 2.5%. Gamma can be measured from slanted edges of known contrast (if ≤ 10) or from a grayscale chart by running Color/Tone Interactive, Color/Tone Auto, Colorcheck or Stepchart.
Cleanliness and filtersLens surfaces should be clean. You should note whether you have a protective (UV or Skylight) filter. It can make a difference— more likely reduced contrast than reduced sharpness. With Imatest you can find out.
File formatsUse Raw, PNG, TIFF, or the highest JPEG quality. Never use less than the maximum resolution or JPEG quality unless you are specifically testing the effects of these settings.
Lens settingsLens performance is a strong function of the aperture (f-stop) and focal length (for zooms). Be sure to record these settings (easy because they're saved with the EXIF data) and include them in your reports. The optimum (sharpest) aperture is of particular interest. Lens performance is also somewhat affected by the distance to the target. Rename Files can add key settings to the image file name using EXIF data.
White balanceShould be close as possible to neutral, particularly in Colorcheck.
This may seem like a lot of fuss, but the technique you develop in testing cameras and lenses will spill over to your daily photography. Alfred Stieglitz tested film and developers extensively when he discovered photography as a student in Berlin. Ansel Adams performed extensive tests in the development of his zone system. Although nobody would claim that testing is responsible for their unique vision, it certainly contributed to the skill that transformed their vision into prints of transcendent beauty.